packman, yast, update, all in this list . . .

I have an interesting problem I haven’t come across before.

I like to update my machine manually so remove apper. I’ve been doing it this way for many years.

But in 13.1 KDE if I go to the packman repository in Yast2
usually if I see a number of updates I just right click and select “All in this list > update if newer version available”
in 13.1 this does absolutely nothing. None of the updates are selected to be updated (not even the one I have currently manually selected). I need to go through each update one by one and select “update”

The most unusual thing about this is that I only see it in the Packman repository.

If I move to the oss-update repo and follow the same actions it behaves as it should and all available updates are selected.

I’ve tried removing the packman repo in the repo manager and adding it back in but still see the same behaviour.

any suggestions?

Maybe there’s a vendor change involved?
Many Packman packages had a wrong vendor (something like “”), this has been fixed recently (to “”).

But of course YaST/zypper or Apper don’t update those automatically, only if you’d enable vendor change.

ah, yes. That is it.
The old files that need to be updated still show obs:// while the updated file shows""

Thanks for the help.