Packman 'Wrong Checksums'

I’ve been trying to install vlc and lame from Packman but can’t because of ‘Digest verification failures’ on certain packages, something I’ve never experienced before:

Retrieving package libdca0-0.0.5-2.pm.5.1.x86_64 (1/8), 87.0 KiB (176.0 KiB unpacked)                                                                                                                     
Retrieving: libdca0-0.0.5-2.pm.5.1.x86_64.rpm [done]                                                                                                                                                      
Digest verification failed for libdca0-0.0.5-2.pm.5.1.x86_64.rpm. Expected cf0a4c5706fb8ff777dfc5f8e210bd108b28a9d8, found e1e62fb64615dd69304b49d517f1173ff719bd76. Continue? [yes/no] (no): n           
Failed to provide Package libdca0-0.0.5-2.pm.5.1. Do you want to retry retrieval?                                                                                                                         
                                                                                                                                                                                                          
[Packman|http://packman.inode.at/suse/11.3] Can't provide file './x86_64/libdca0-0.0.5-2.pm.5.1.x86_64.rpm' from repository 'Packman'                                                                     
History:                                                                                                                                                                                                  
 - libdca0-0.0.5-2.pm.5.1.x86_64.rpm has wrong checksum
Retrieving: libmp3lame0-3.98.4-2.pm.4.1.x86_64.rpm [done]                                                                                                                                                 
Digest verification failed for libmp3lame0-3.98.4-2.pm.4.1.x86_64.rpm. Expected f9a3b9ee0288a384520610edd27c20181fa3e2ad, found 78300168d9550528a10bfced7563647a10d34e96. Continue? [yes/no] (no): n      
Failed to provide Package libmp3lame0-3.98.4-2.pm.4.1. Do you want to retry retrieval?                                                                                                                    
                                                                                                                                                                                                          
[Packman|http://packman.inode.at/suse/11.3] Can't provide file './x86_64/libmp3lame0-3.98.4-2.pm.4.1.x86_64.rpm' from repository 'Packman'                                                                
History:                                                                                                                                                                                                  
 - libmp3lame0-3.98.4-2.pm.4.1.x86_64.rpm has wrong checksum

Hitting ‘continue’ & ‘retry’ repeats the problem & ‘ignore’ leaves the package uninstalled. There shouldn’t be any conflicts as I install all my multimedia from Packman. I tried changing Packman repo’s and had the same results. My repo’ list is modest:

zypper lr                                                                                                                                                                                              
# | Alias        | Name                               | Enabled | Refresh                                                                                                                                 
--+--------------+------------------------------------+---------+--------                                                                                                                                 
1 | Packman      | Packman repository (openSUSE_11.3) | Yes     | No                                                                                                                                      
2 | games        | Games (openSUSE_11.3)              | Yes     | No                                                                                                                                      
3 | repo-debug   | openSUSE-11.3-Debug                | No      | No                                                                                                                                      
4 | repo-non-oss | openSUSE-11.3-Non-Oss              | Yes     | No                                                                                                                                      
5 | repo-oss     | openSUSE-11.3-Oss                  | Yes     | No                                                                                                                                      
6 | repo-source  | openSUSE-11.3-Source               | No      | No                                                                                                                                      
7 | repo-update  | openSUSE-11.3-Update               | Yes     | No                   

I’m hesitant to add & install from the vlc repo’ in case it causes more problems. Is this a packaging problem ? Or am I messed up somehow ?

It’s OK…panic over.

I must have somehow corrupted the rpm database ‘sudo rpm --rebuilddb’ corrected the problems. I’ve no idea how I messed up.

Funny how you never think of things until afterward. :embarrassed: