Packman switch to LibAV

ffmpeg is in 11.4 packman

but it didn’t fix devede

get_iplayer on the other hand is OK

Installing ffmpeg from packman for openSUSE 11.3 has solved my problem of burning a DVD with correct audio sync.

I locked ffmpeg so it can’t be changed until the issue is resolved. In openSUSE 11.3 used to have to use libfaad from earlier versions of openSUSE.

When I had contacted packman about that issue they claimed it was do to gcc in 11.3 perhaps it a similar issue for ffmpeg and 11.4.

Needless to say using ffmpeg from 11.3 and then locking that package so it will not be updated has resolved my problems.

I’ll have a look at that

Did it force you to bring in any other packages by dependency to that ffmpeg package?

I see the version in 11.3 is the same as in my 11.4:

I did a quick limited check, and I notice with dvd compliant files created by the application ‘tovid’ that there is a problem creating DVD compliant files in 11.4 but not 11.3. It could be the ‘ac3’ audio track encoding related, but I can not state that for certain. I believe the ‘tovid’ versions I used to test (11.3 vs 11.4) are the same. Its possible (likely even) the underlying libraries/apps are the same versions. I’m suspicious of a difference in Intel compilers between 11.3 and 11.4 causing this (in libavcodec). However I don’t have time currently to investigate (and even if I did have the time this could be beyond my ability to determine).

Yes they are the same version. However they were compiled with different versions of compilers. This was the problem with libfaad and mythtv in 11.3, and it appears as though a similar problem has occured with ffmpeg, as the version from 11.3 works fine.

OldCPU the 11.3 version required that I also install libavfilter1

You didn’t switch completely to the 11.3 packman repo, just selected packages?

If this is a problem with a compiler difference between 11.3 and 11.4, it could be particularly nasty to fix, as the fix would need to come from upstream and make its way to the packman packagers. BUT I don’t know what the problem actually is … the possibility of it being due to different compilers is just speculation on my part, and should be treated as speculation until this can be properly investigated (by someone who knows more than I).

If this problem is confined to AC3, then I suppose our users could look at the possibility (as an interim measure) of using an alternate sound track in DVD videos. mp3 is NOT an option, as that is not supported in the DVD spec (to the best of my knowledge). Options are ac3, pcm (.wav or .AIFF), and mp2. I’ve also read of DTS ( ? ) . I have not tried to encode video for a DVD with an audio format other than AC3, so I don’t know how easy nor how difficult it would be to apply such a work around.

DeVeDE only offers a gui method of creating a disc with 5.1 surround sound or it offers the option to just copy the sound track if it’s already ac3.

I tried both on my non-ac3 video file and only the copy option produces something that works in the preview. However when it’s on a disc and in a DVD player it does not work. My only guess is that mplayer can just decode the sound but it’s obviously not DVD standard. Currently trying a video file that already has AC3 sound. I might just have to change my download habits a bit :wink:

I did not switch repositories that would be ridiculous just for “one” package. I can’t even imagine doing something as drastic and foolhearted as that. The only thing I did was went to packmans website and downloaded the ffmpeg package for 11.3.

In YaST, using my current repositories, nothing has been changed I installed libavfilter1, and locked the ffmpeg package so that it wouldn’t be changed back.

Pretty simple really.

OK I thought it had AC3 sound… it doesn’t… Also no matter what I do I still do not have sound on DVD’s created with DeVeDe. They play fine on my pc with VLC but not on the TV with a ‘normal’ DVD player… Guess there’s still something wrong with the encoder used by DeVeDe.

We are also tracking the issue on this thread:
Kdenlive not rendering DVD

It may not be a compiler problem like I speculated, but rather an ffmpeg problem, where mencoder may (??) have adopted the same method, breaking many apps for ac3 … Someone on the packman mailing list had this to say:

FFmpeg’s AC3 encoder was changed to expect float (instead of int16). The new encoder is faster on typical hardware (and at least not worse in quality). Toget the original behaviour, the programs have to open “ac3_fixed” instead of"ac3". (And yes, I know I’ve claimed in the past we do not break ABI,)
Now I see the mlt developer is working on a fix (where mlt is called by kdenlive): Git -

For each DVD creation capable application if one wishes to use any of them, then likely one needs to check with each of the upstream development contact media (whether it be a forum or mailing list or simple email address) and ask the developer to confirm they will be updating their code calls to ffmpeg.

For the time being, unfortunately, I’m booting to Mint 10 to do DVD’s in devede

Think I might reinstall Mint 9 for this purpose… Had it on a second hard drive for a few weeks until I realised I didn’t use it at all… It’s a shame it doesn’t work on 11.4 tho… Was working fine on 11.3!

This problem has the potential to impact all Linux distributions (as it originates with the ffmpeg developers). So choose one’s distribution version wisely and be careful as to the updates one does, as this is not an openSUSE specific problem.

Good point… :slight_smile: I’ll have to find a different way of converting my avi files to DVD’s for now…

Just found a post on the DeVeDe forums from an user who fixed the DeVeDe problem by downgrading mplayer and x264. I’ve emailed the packman packager of these to see if he can provide me some for testing. Not really related to the topic but since we’ve been talking about DeVeDe here I thought I’d mention it :slight_smile:

Ok, no reply from the packager so I decided on a different approach. I found a nice thread by OldCPU about converting MST files which I addapted to create DVD’s… Made 2 shell scripts. 1 for 4:3 dvd’s and one for 16:9 dvd’s… The resulting mpg’s can than be made into a DVD with DEVEDE and burned… it’s a round about way but functional… Now to raise a bug report with Devede about this…