Packman repository not refreshing

Hi,

I’m having a problem with the Packman repository lately. First, I added the Packman repo using a Germany mirror link. Everything worked fine until I decided to switch the repository URL to the standard Packman one (http://packman.inode.at/suse/11.3/packman.repo) instead of a mirror.

Then I started getting an error while refreshing repositories:

Error refreshing service Packman Repository (http://packman.inode.at/suse/11.3/packman.repo): Parse error: repoindex.xml[1] Document is empty

Quite frustratingly, for some reason zypper has made the Packman repo invisible and I can’t see it anywhere (not in Yast Software Repositories or in the /etc/zypp/repos.d folder. Yet, it still tries to use that repository when refreshing, and obviously gives me an error in the process.

Any idea how to completely remove all traces of this Packman repo from my system so I can start anew? (aside from an OS reinstall?)

Can you please post output of:

zypper lr -d

No need to reply, I fixed it by myself. Apparently I had to switch to the “Services” filter in Yast Software Repositories and delete the problematic Packman repo from there, and then re-add it again, this time another mirror. It works now.

I wonder though why it was in the Services section and not in the Repositories one?

sorry, I’m still not really experienced with zypper, or openSuse in general. :slight_smile:

Great - glad its all working now :slight_smile:

Thanks for this reply. I ran into that repoindex.xml[5] error.

Deleting the service fixed the problem with zypper.