packman repository intialisation problem (11.0)

after enabling packman and starting the software intallation tool I am getting the following message:

error while initializing repozitory:’: Error reading solv-file: /var/cache/zypp/solv/http:_ftp.skynet.be_pub_packman_suse_11.0/solv

ls -l /var/cache/zypp/solv/http:_ftp.skynet.be_pub_packman_suse_11.0

-rw-r–r-- 1 root root 53 Jul 2 15:25 cookie
-rw-r–r-- 1 root root 2614256 Jul 2 15:25 solv

I am running OpenSUSE 11.0, 64-bit version

I have tried to delete and enable the repository again but
it did not work. Other repositories seem to work OK.
For packman I am getting an empty list.

Will anybody help? thanks

Try to delete the directory itself;

close any programs using software or repository db’s.
open a terminal console and

’ cd /var/cache/zypp/solv/ ’

‘su’ to get root priv

’ rm -Rf http:_ftp.skynet.be_pub_packman_suse_11.0

*take care where you rm! :wink:

now run ’ zypper ref ’ to see if it rebuilds.

As note: it could be a tempory error with the repository, I’m not having this issue but give it some time (2 to 24 hours) before digging in only to find out it was not something with your system.


Drop the FTP. All you need is:

HTTP://packman, etc.

I have tried both suggested solutions, but neither has worked.

The directory was removed and sucessfully rebuild, but the problem persists. It lasts since I have freshly installed 11.0.

I have tried to change the repository address using the yast tool.
After changing the url into - LE portail belge – DE Belgische portaalsite! the tool went into endless
loop of checking and downloading and could not be interrupted.

The url http://packman/suse/11.0/ gave access error.

The only way I can work with packman is to download the packages via ftp and pronounce that directory as another repository.

Best regards

Sorry that didn’t work for you. Have you found a solution?

Repos seem to be the big buggaboo right now. I have read a lot of posts with questions and others with inconsistent information. I’ve put together a document that is taken from various sources which identifies the various repos and what they mean for updating.

It’s in *.doc form. Is there a way to upload it to the forum or do I have to just cut and paste?

I made the mistake of mixing some default repos with factory repos. Now I have a hybrid of 4.04 and 4.08 of KDE. for the packman repo anyway on opensuse 11.0 is borked. i get gpg check failures. so i switched to using Index of /suse/11.0
for packman instead.