Packman repository for 13.1 RC1

I don’t see packman repo for 13.1 now. It is possible(correctly) to use packman factory instead (


13.1 is not released yet. The repo should be there on release day or maybe a few days earlier.

You should not use the repo for Factory , because Factory is already on its way towards 13.2…
That said, at the moment the changes should be quite small still, so it may work for now.


Where is Tumbleweed?

Somewhere between Factory and 12.3?


NNW of 13.1 and SSW of Factory (South of 13.2).

I used factory. Grab what packages you need, then disable it.

I just used the packman 12.3 repo for a fresh install of rc1 and it all worked fine.

Thanks all!

I used too packman 12.3 repo. So I are 4 package dependency missing for vlc-nox.

Also for 13. 1 no libdvdcss repo, for moment.
However, VLC, tv-maxe, amarok, radio-tray worked all fine. :slight_smile:

I hope do not may experience problems when I transfer to the 13.1 packman repo.

You have to install all VLC packages from Packman: vlc, vlc-gnome (if wanted), vlc-noX-lang, vlc-codecs, vlc-noX, vlc-qt, libvlc5, libvlccore7.
Packman already has VLC 2.1.0, whereas 13.1RC1 still includes 2.0.8a, the packages are not compatible between those two versions!

Also for 13. 1 no libdvdcss repo, for moment.

Take the one for 12.3 as well.

So also Problem: nothing provides needed by vlc-noX-2.1.0-176.4.x86_64 is needed by (installed) vlc-noX-2.1.0-176.3.x86_64

However, I stop any updates of vlc and codecs while packman 13.1 repo appear if all working fine :smiley:

Used mmcheck for testing ( is designed to check your MultiMedia Setup in openSUSE Copyright (C) 2012 by James D. McDaniel,

Well, 12.3 contains libebml3 while 13.1 only has libebml4. VLC in the 12.3 Packman repo is of course compiled against libebml3, so you can’t install it on 13.1. Similar for libmatroska: 12.3 has libmatroska5, which got upgraded to libmatroska6 in 13.1.

SO use the Packman repo for Factory for now, that should work better with your 13.1 install (since Factory is still similar to 13.1, at least nearer than 12.3 :wink: )

However, I stop any updates of vlc and codecs while packman 13.1 repo appear if all working fine :smiley:

Yeah, right. But I doubt you would be able to play any matroska files (.mkv)…:wink:

Thank you for your reply.
I changed packman 12.3 repo with packman factory. So, VLC running with .mkv file now, more dependency package find. But, not 100%.
Now, missing for updates 4 libraries and plugins gstreamer.

Well, libass got upgraded to libass5 in Factory 2 days ago, didn’t know that, sorry.
As I said, Factory is already diverging of 13.1.

Hm, which libraries cannot be upgraded? Maybe you’re fine with the 12.3 versions?
Or you could maybe ignore that missing libass5? (libass is subtitle renderer for the ass/ssa subtitle format)
Or try to create a symlink from to the existing (in /usr/lib/ or /usr/lib64/)
Or install libass5 from Factory.

Anyway, the Packman repo should be available for 13.1 in the next weeks, certainly before the release.

Need updates: libafilter2, libafilter3, gstreamer-plugins-bad-1.0.10, gstreamer-plugins-bad-32bit.

I have now Packman factory.
I decided not upgraded these libraries (because all multimedia used working fine) and waiting for official packman repo for 13.1 :slight_smile: Are more safe this.

You should be able to uninstall libavfilter2 after the latest Packman updates, some other packages that used it have been updated to use ffmpeg2 instead now (libavfilter3 in that case). And I doubt that you need gstreamer-plugins-bad-32bit, I don’t have it installed on my system (that depends on what 32bit programs you use though, of course).

But yes, libavfilter3 and gstreamer-plugins-bad need libass as well.

Anyway, I guess you should be fine with the 12.3 versions of those, at least for now.

But don’t forget to change the Packman repo to 13.1 when it is available! :wink:

Thanks for answers. For me, this topic are resolved. Have a nice week.:slight_smile:

Hey all,
I don’t know if I should post here or just start a new thread but I have recently installed 13.1 on a 32-bit machine and I’m now getting the error during normal updates:

nothing provides ...

I do have the Packman repo enabled. Is the repo missing the package? Where do I get it?

Did you install the RC1 version of openSUSE ? or the final GM version ? That will provide the necessary ‘hint’ as to where this should be posted. Please note this thread is for the Release Candidate (RC1) version, and this is a 'Pre-Release/Beta sub forum area.

Anyway, did you check the search area for openSUSE applications ? ie Search for libass

or for the not filled in … Search

But which one? Apparently the repo for Factory, since is only available there.

Take the one for 13.1, the packages there are built against 13.1, and will require which is included in 13.1…

Post the output of “zypper lr -d” if in doubt.