Packman flash-player not working in Firefox

I installed flash-player through the Packman repository but flash does not load in Firefox. Anything using flash just displays a blank screen and when I right-click it gives me the regular options for right-clicking on a page rather than the flash player settings.

However, it does work in Chromium.

I tried using pepper flash and the freshplayerplugin but the same problem occurs. I also installed Multimedia Codecs and websites like Twitch and Hulu are working fine.

I would like to fix this because I try to minimize my use of Google applications as much as possible in my day-to-day use.

Here is a screenshot of my about:plugins page:

https://i.imgur.com/BPTOBTx.png

according to that screenshot you’ve got flash installed and enabled and it is the current version available from packman
if you have freshplayer I’d say remove it as it blocks the regular npapi flash from working
if you have an issue with a particular site tell us what site is it, I have Firefox 56 and flash 27 and they work fine I don’t have Chromium or pepper flash so I can’t comment about that
the thing is some sites can disable right clicking with a javascript which might or might not work with chrome there was a Firefox setting to disable this but it was removed
you can get those options with this addon
https://addons.mozilla.org/en-US/firefox/addon/settingsanity/

Maybe this bug:
https://lists.opensuse.org/opensuse-factory/2017-10/msg00597.html

maybe you have a flash blocking addon like flashblock?
https://addons.mozilla.org/en-US/firefox/addon/flashblock/
or maybe you’ve set the flash player to ask to activate instead of always activate
in about:addons in the plugins tab in the flash player options select always activate if not there should be a button on the left of the url bar where you can select weather to activate or not the flash plugin

I can confirm freshplayerplugin is fully removed and Firefox doesn’t detect it.

It seems like any site that uses Adobe Flash Player is affected. I use a virtual online classroom, which uses Flash and it doesn’t load for example.

The only addons I have installed are uBlock Origin, Pushbullet, Reddit Enhancement Suite, and HTTPS Everywhere. I tried deactivating uBlock for the page with Flash but that didn’t seem to do anything. And the Flash plugin has been set to “Always Activate” this entire time. :frowning:

I should mention that I have gone as far as reinstalling openSUSE Tumbleweed and doing the same procedure as stated on this Wiki page with no success. Every other distro I’ve tried such as KDE neon, Debian and Manjaro have worked with Adobe Flash, and I don’t plan on switching to those distros so I really want to get this to work.

to be honest I haven’t seen a site that uses flash in a long time, most of the sites I frequent have switched to html5
to the point at hand adobe has released a flash update adobe’s version is **27.0.0.183 **while packman is still at 27.0.0.170 which is the version you have you can get the current build from adobe
https://get.adobe.com/flashplayer/
packman should get the update soonish
http://packman.links2linux.org/package/flash-player
if you decide to get flash from adobe you’ll need to manually remove (zypper should give you that option) flash-player as adobe’s name for the package is flash-plugin so you can’t do an “upgrade”
one more thing is that mozilla blocked plugins from accessing local files so you can no longer open local flash files in Firefox the file:/// URI is no longer supported for flash files if your issue is with a downloaded swf you’ll need to run a local server and open it via http(s) (ftp doesn’t work either)
https://www.ghacks.net/2017/05/17/firefox-55-flash-runs-only-on-http-or-https/

Unfortunately, I have already tried the Adobe repository and the same issue occurs.

https://i.imgur.com/bhdqeot.png

one more thing to try is mozilla’s build of Firefox
https://ftp.mozilla.org/pub/firefox/releases/56.0.2/linux-x86_64/en-US/firefox-56.0.2.tar.bz2
just unpack it in your home and run it
if that build has no issues open a bug report
one more time I have no issues I’ve tried it on one site that uses flash banners for ads and they displayed if you tell us the site you’re having issues with maybe we can confirm it’s an opensuse issue or not just saying it doesn’t work isn’t enough
what about making a screenshot of that site and show us the flash place holders (mozilla bundled a screenshot tool in Firefox and offers free image hosting)

I never once stated or implied that just saying it doesn’t work is enough… I have said repeatedly that I want to fix this issue. Did I not make that clear?

Running Firefox from the tar archive yields the same result.

Here is a screenshot of the page that should load into Adobe Connect using the Flash plugin. This website is only accessible to people at my college so I cannot provide a link:

https://screenshots.firefoxusercontent.com/images/2d91149a-4784-4b84-80f6-b4e5ea97be38.png

OK I tried searching for some flash on the internet and I can confirm flash does not work on Firefox 56
I tried this site (got the link from adobe https://www.adobe.com/devnet/games/examples.html )
http://www.scarygirl.com/
I installed vivaldi and pepper flash and vivaldi loads flash fine
I do remember some time ago using flash on Firefox so the only recommendation I have left if try Firefox-esr it is packaged for TW but I’m not sure if it’s in the main repository you can get it from the mozilla repo

zypper ar -f http://download.opensuse.org/repositories/mozilla/openSUSE_Tumbleweed/mozilla.repo
zypper in firefox-esr

In that case I will continue to use Chromium for the only Flash website I use. Everything else I use uses HTML5 so I think I will be fine using Chromium just for Adobe Connect.

I will open a bug report by tonight.

Thanks a lot for your help! :slight_smile:

I honestly thought flash was working I went to a few local sites and saw animated ads so wrongly I thought they wore flash it turned out to be html5 (I gues you can have animations without flash)
the reason I asked for a url is because I had no idea where to find flash
this is obviously a mozilla issue as it exists in their build and with flash from adobe unfortunately nobody has reported it at their bugzilla
https://bugzilla.mozilla.org/buglist.cgi?quicksearch=flash