Packagekit "star" says there is an update - zypper says nothing to do.

For the last 3 days the packagekit say there is an update. (in KDE a box pops up) in MATE the star changes from empty to yellow.
When I run zypper up - it says nothing to do.

Is something broke in packagekit or is something broke in the repo data?

Every once in a while the message disappears (or the star goes clear again). Then it happens again a few hours later there is an update and again “Nothing to do”.

Not many here use Packagekit (I do not even install it). So it is a bit difficult to know what is wrong.

In any case, I would trust zypper/YaST, because they are the native openSUSE tools for these kind of things. :wink:

It could a locked package, see

TW users generally don’t trust PK, and recommend others not to have it. Then some say TW support was implemented a couple years ago. But as we can see PackageKit still doesn’t get it right.

I wish we could have a reliable point-and-click way to get updates, but maybe libzypp doesn’t offer a way that doesn’t rely on re-implementing zypper logic? Who knows.

Yep, it is python3-py package missing a dependency. Packagekit sees it needing installed but nothing provides a dependency (yet).