PackageKit problem

I was updating and this popped up in PackageKit:

Can’t provide file ‘./suse/i586/tack-5.6-83.1.i586.rpm’ from repository ‘openSUSE-DVD 11.0’

I don’t know whether the problem is with PackageKit, the repository, or my setup, but it won’t skip the package that the file is needed for and update the rest (rather, I don’t know how to force it to skip the package that needs this and update the rest).

Does anyone know how to fix this?


In your software repositories “openSUSE-DVD 11.0” is enabled and YaST looks for the openSUSE-DVD when updating. One way to resolved the issue is to insert the DVD (openSUSE 11.0) when YaST asked for it.

If you don’t like to do it every time (which I don’t) goto YaST > Software Repositories, and in the list find “openSUSE-DVD 11.0”. Select it and at bottom of the windows under Properties, uncheck the Enabled option. Now it is disabled and YaST wont look for it.

Many Thanks!

Thread moved to Applications

I really think it would be neat if openSUSE enabled the DVD repository automatically when there was no internet connection, and disabled that repository when there is an internet connection.