Packagekit blocks all commands

Hi:

host XP
guest OpenSuse 12.3
VB 4.2.18

I have tried to “zypper update”…I get “PackageKit is blocking zypper. This happens if you have an updater applet or other software management application using PackageKit running.
Tell PackageKit to quit? [yes/no] (no):”

I enter “Y”…and on and on and can’t update.

I tried to do a Skype install…went to many webpages…tried many commands…the same runaround.

Spent a lot of time searching and trying different commands, etc…all a dead-end…I’m tired…Is there any way to get OpenSuse 12.3 up and running correctly? I am new to all this and I am trying not to get discouraged.

On Sat, 02 Nov 2013 16:06:02 +0000, jimhebert wrote:

> Hi:
>
> host XP guest OpenSuse 12.3 VB 4.2.18
>
> I have tried to “zypper update”…I get “PackageKit is blocking
> zypper. This happens if you have an updater applet or other software
> management application using PackageKit running.
> Tell PackageKit to quit? [yes/no] (no):”
>
> I enter “Y”…and on and on and can’t update.
>
>
> I tried to do a Skype install…went to many webpages…tried many
> commands…the same runaround.
>
> Spent a lot of time searching and trying different commands,
> etc…all a dead-end…I’m tired…Is there any way to get
> OpenSuse 12.3 up and running correctly? I am new to all this and I am
> trying not to get discouraged.

Packagekit will eventually finish what it’s doing - just be patient. :slight_smile:

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

On Sat, 02 Nov 2013 16:06:02 +0000, jimhebert wrote:

> I tried to do a Skype install…went to many webpages…tried many
> commands…the same runaround.
>
> Spent a lot of time searching and trying different commands,
> etc…all a dead-end

It would be helpful if you told us what you’d tried, which instructions
you tried to follow, etc.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

After completing the install, I first login to “icewm”. That’s where I do any final tweaking, including installing additional software.

Unless you have especially configured it, “icewm” does not do packagekit, so it won’t get in the way.

When done with that, I can login to my regular desktop (KDE), and let packagekit do it’s thing. It won’t bother me, because I have already done the stuff I urgently wanted to install.

However, I usually configure “Apper” to not be automatically started in my KDE session, though I am allowing it run while testing 13.1RC2.

On 2013-11-02 17:06, jimhebert wrote:
>
> Hi:
>
> host XP
> guest OpenSuse 12.3
> VB 4.2.18
>
> I have tried to “zypper update”…I get “PackageKit is blocking
> zypper. This happens if you have an updater applet or other software
> management application using PackageKit running.
> Tell PackageKit to quit? [yes/no] (no):”

There are several methods.

  • You can wait, normally it finishes and lets you do what you want. The
    first time it takes longer, and even longer if you are using a virtual
    machine.

  • You can configure packagekit to not start again. The procedure is
    different in KDE or Gnome. I don’t remember where exactly to do it.
    Right click on its applet icon, perhaps.

  • You can remove the package, but for this you need access to yast or
    zypper or rpm.

  • You can kill it.

There are several methods for doing it. If you know the exact name of
the program to kill, “killall programname” does it. If you don’t know
the name, you have to find out:


ps afx | less

will list all the running programs. You can find the name or the PID.
With the PID number, you can kill it this way:


kill PID

Sometimes a process refuses to die - in this case you can force it to die:


kill -9 PID

or


killall -9 ProgramName

> I tried to do a Skype install…went to many webpages…tried many
> commands…the same runaround.

Don’t.

There is just one page you have to read, a wiki page at opensuse.org.
Just that one page. But first you have to solve the packagekit issue.

>
> Spent a lot of time searching and trying different commands,
> etc…all a dead-end…I’m tired…Is there any way to get
> OpenSuse 12.3 up and running correctly? I am new to all this and I am
> trying not to get discouraged.

Be patient, you are getting there. It is different system than Windows
and it takes time to get used to it and learn its tricks.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

I want to thank all of you for responding to my last post #28 and I am late in responding because I have been working on this problem all afternoon and I made a little headway. I found one webpage that gave very clear information. It said

“Apper can be turned off in the KDE “Configure Desktop” utility, under System Management-> System Monitor>Apper Software Management-> Settings-> Check for new updates-> (drop down menu) Never”.

After fiddling around and clicking buttons, I found my way to a button called Apper install or something like that. I clicked it and I didn’t see the “Never” option, but I did see “install updates”….so I had nothing to lose and I clicked it. It took about 3 hours or more to download and install that horrendous list of packages. I thought my laptop cpu would burn up it was so hot. Haha. But anyway…after installation complete, I went back to terminal and, copy and pasted (finally got that working) “su -c ‘zypper install libqt4 libqt4-x11 libqt4-dbus-1 libsigc++2 libpng12-0’ “…It worked. Then I downloaded skype and Apper opened it and I was all happy:) until a pop up appeared saying install failed:(. So that is the situation now. I am clueless as to what is the next step.:\

I tried so many….for example

sudo zypper in xorg-x11-libXv-32bit libqt4-32bit libqt4-x11-32bit libpng12-0-32bi

zypper in skype-4.1.0.20-suse.i586.rpm alsa-plugins-pulse-32bit

su -c ‘zypper install libqt4 libqt4-x11 libqt4-dbus-1 libsigc++2 libpng12-0’

nothing worked…very discouraging

See my last post…….explains a lot.

I wish I would have known about this before…I have yet to find…and I have been searching a lot, for a step by step…and I mean written like this "Step one…click download button on this link and copy MD5 also…Step 2…,etc). not something that leads you to one link then another then another, etc …This is the first time I see this info you are giving me. Why didn’t something popup on my screen after my installation to tell me this. Don’t think that I am angry or anything like that, I am just saying that there is a lot lacking here. I did my own installation of windows XP on my new computer last year and I was done in one hour including the download and installation of drivers. And I am no computer geek who is fiddling with this stuff every day. Now OpenSuse and other distros have been around for 20 years or more and still so many problems. It is clear to be seen all the questions and problems from disenchanted people I see on the forums and this experience that I am having, I am very disappointed. I think that it may be too late to do what you recommend. I don’t know. Thank you for your assistance but please read post #6 and keep me from having to repeat it.

I tried to kill it using some similar command…not sure…it spit out the same that Packagekit was busy etc. Read post # 6 I believe so I don’t have to repeat it all again. Thanks Carl

On Mon, 04 Nov 2013 06:32:42 +0000, jimhebert wrote:

> nothing worked…

“Nothing worked” is not specific enough for us to help you, Jim. We need
to know:

  1. What command you entered.

  2. What the specific output of the command was. Specific means more
    than “it didn’t work” - it means "I ran:

zypper in skype-4.1.0.20-suse.i586.rpm alsa-plugins-pulse-32bit

And the output was:


Root privileges are required for installing or uninstalling packages.

(Which is the actual output if you run the command as non-root).

I’ve tried to explain this to you before, I believe - we can’t help you
if you don’t provide us with specific information. Generic descriptions
of error messages are not useful. Specific error messages are.

I understand that you’re frustrated and you’re being persistent, but you
will get far, far better help if you provide specific information about
what happens, and rather than provide guesses (like “my Linux system was
infected with a virus”), provide facts and specific information.

You will find the quality of help you receive increases dramatically.

Now…

If you’ve downloaded the RPM skype-4.1.0.20-suse.i586.rpm, the following
command (assuming you’re not running as root) is:

sudo zypper in ./skype-4.1.0.20-suse.i586.rpm

Zypper will figure out the dependencies and install them. That’s its
job, so you don’t need to guess that you need alsa-plugins-pulse-32bit,
qt, or any of that stuff. It should figure it out on its own, as the
package is an RPM built for SUSE.

If it doesn’t, then we’ll need to know the specific messages you get back
so we can advise how to work around the issue. It may be necessary to
install some packages “by hand” like that, or to tell it to ignore
dependencies for the skype package, depending on where you got it from
and for what version of SUSE/openSUSE it was built.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  1. What command you entered.

sudo zypper in xorg-x11-libXv-32bit libqt4-32bit libqt4-x11-32bit libpng12-0-32bi

zypper in skype-4.1.0.20-suse.i586.rpm alsa-plugins-pulse-32bit

su -c ‘zypper install libqt4 libqt4-x11 libqt4-dbus-1 libsigc++2 libpng12-0’

  1. What the specific output of the command was.

If “root” means su then Pswd, then I was in root.

“PackageKit is blocking
> zypper. This happens if you have an updater applet or other software
> management application using PackageKit running.
> Tell PackageKit to quit? [yes/no] (no):”

I downloaded what you told me then did the following:

jimhebert@linux-cbiz:~> sudo zypper in ./skype-4.1.0.20-suse.i586.rpm
root’s password:
Specified local path does not exist or is not accessible.
Problem retrieving the specified RPM file:
Malformed URI:

Please check whether the file is accessible.
Problem with the RPM file specified as ‘./skype-4.1.0.20-suse.i586.rpm’, skipping.
No valid arguments specified.
jimhebert@linux-cbiz:~>

I have lost my the copy/paste feature from Host to guest now also. So it is taking me a bit more time to type in the terminal. I can still copy/paste from guest terminal to host.

Also not getting anymore e-mails from the forum when a new post is made to me. checked my settings and is checked to receive mail from adminstrator.

You cannot use zypper like that to install downloaded rpm packages.
Use rpm or yast:

sudo rpm -i ./skype-4.1.0.20-suse.i586.rpm

or

sudo /sbin/yast -i ./skype-4.1.0.20-suse.i586.rpm

or right-click on the package in a file manager and select “Open With”->“Install/Remove Software”.

On Mon, 04 Nov 2013 18:46:05 +0000, jimhebert wrote:

> 1. What command you entered.
>
> sudo zypper in xorg-x11-libXv-32bit libqt4-32bit libqt4-x11-32bit
> libpng12-0-32bi
>
> zypper in skype-4.1.0.20-suse.i586.rpm alsa-plugins-pulse-32bit
>
> su -c ‘zypper install libqt4 libqt4-x11 libqt4-dbus-1 libsigc++2
> libpng12-0’
>
>
> 2. What the specific output of the command was.
>
> If “root” means su then Pswd, then I was in root.
>
> “PackageKit is blocking
>> zypper. This happens if you have an updater applet or other software
>> management application using PackageKit running.
>> Tell PackageKit to quit? [yes/no] (no):”

OK, we told you that PackageKit does this - and if you wait, this problem
will clear itself up when PackageKit has finished doing its thing.

> I downloaded what you told me then did the following:
>
>
> jimhebert@linux-cbiz:~> sudo zypper in ./skype-4.1.0.20-suse.i586.rpm
> root’s password:
>
> Specified local path does not exist or is not accessible.

You didn’t run this command from the path where you downloaded the skype
RPM to.

I have to disagree with wolfi323, though - I use this type of command
regularly to get dependency resolution for downloaded RPMs, and it works
fine. You do not have to use YaST or rpm -i to install packages -
zypper works in this manner.

> I have lost my the copy/paste feature from Host to guest now also. So it
> is taking me a bit more time to type in the terminal. I can still
> copy/paste from guest terminal to host.

In VirtualBox, make sure the “shared clipboard” setting is set to
“bidirectional”. It sounds like it’s not.

> Also not getting anymore e-mails from the forum when a new post is made
> to me. checked my settings and is checked to receive mail from
> adminstrator.

Make sure you’ve subscribed to the thread - using “receive mail from
administrator” doesn’t subscribe you to individual threads or forums.

Jim

Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

On Mon, 04 Nov 2013 18:54:33 +0000, wolfi323 wrote:

> You cannot use zypper like that to install downloaded rpm packages.

Respectfully, you can - if you specify the path and filename in the way I
specified. I’ve been using zypper this way for years:

For example:


[jhenderson@brequinda ~/Downloads]$ sudo zypper in ./
unetbootin-0.0.583-10.1.x86_64.rpm
Loading repository data...
Reading installed packages...
'unetbootin = 0:0.0.583-10.1' is already installed.
No update candidate for 'unetbootin-0.0.583-10.1.x86_64'. The highest
available version is already installed.
Resolving package dependencies...

Nothing to do.

(I already have it installed, obviously, but unetbootin isn’t in any of
my enabled repositories, just in the local directory)

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

It tried in root and out of root and this is the result;

jimhebert@linux-cbiz:~> /Downloads]$ sudo zypper in ./unetbootin-0.0.583-10.1.x86_64.rpm
bash: /Downloads]$: No such file or directory
jimhebert@linux-cbiz:~> ~/Downloads]$ sudo zypper in ./unetbootin-0.0.583-10.1.x86_64.rpm
bash: /home/jimhebert/Downloads]$: No such file or directory
jimhebert@linux-cbiz:~> su
Password:
linux-cbiz:/home/jimhebert # ~/Downloads]$ sudo zypper in ./unetbootin-0.0.583-10.1.x86_64.rpm
bash: /root/Downloads]$: No such file or directory
linux-cbiz:/home/jimhebert # /Downloads]$ sudo zypper in ./unetbootin-0.0.583-10.1.x86_64.rpm
bash: /Downloads]$: No such file or directory
linux-cbiz:/home/jimhebert #

I am not familiar with repositories and local directory. I am new.

You’re right of course. Sorry, I didn’t know that.
I always use rpm directly for installing downloaded RPMs.

You are trying to install unetbootin now, is that what you really want? I doubt so, and you haven’t downloaded either have you? :wink:

You have to change the current directory to the one you downloaded skype to, if you’ve used Firefox that’s most likely “Downloads”:

cd ~/Downloads

Then install the package with that line from above:

sudo zypper in ./skype-4.1.0.20-suse.i586.rpm

or however that file is called. Use “ls” to check.

Or as I already said, just enter that directory in a file manager, right-click on the package and select “Open With”->“Install/Remove Software”.

And btw. it doesn’t make sense to use both “su” and “sudo”.
If you changed to root using “su”, all commands you enter will be run as root.
“sudo” is for running single pograms as root, no need to change to root first.

“you haven’t downloaded either have you?”

No, I couldn’t do it. I went this page to download Skype

Download Skype on your computer - Windows, Mac, and Linux - Get Skype

then I got this message

There is not enough room on the disk to save /tmp/U1m6M+H2.part.

Remove unnecessary files from the disk and try again, or try saving in a different location.

???
I wanted to point out that you tried to install unetbootin with the commands you posted in your previous thread, not skype.

then I got this message

There is not enough room on the disk to save /tmp/U1m6M+H2.part.

Remove unnecessary files from the disk and try again, or try saving in a different location.

Well, try to save it in your home directory.

But if your disk is that full, you won’t be able to install it anyway, and maybe will even have other problems…

Please post the output of “df -h”.

linux-cbiz:~ # df -h
Filesystem Size Used Avail Use% Mounted on
devtmpfs 487M 32K 487M 1% /dev
tmpfs 502M 176K 502M 1% /dev/shm
tmpfs 502M 4.4M 498M 1% /run
/dev/sda2 5.0G 4.7G 2.8M 100% /
tmpfs 502M 0 502M 0% /sys/fs/cgroup
tmpfs 502M 4.4M 498M 1% /var/run
tmpfs 502M 4.4M 498M 1% /var/lock
/dev/sda3 1.6G 93M 1.4G 7% /home