Package needs php-cli, it is not present

I’m trying to install a rpm package, obtained from its website because it is not on the repo, and it has php-cli as a dependency.

Apparently it is not present either. Are per chance its contents packaged with a different name? Can I safely ignore this dependency?

As this is very vague, how do you think people can make any intelligent guess?

You are right, I’m sorry, I wrote in a haste.

It is Dolibarr , there is an old version on the repo but it doesn’t build for Tumbleweed; I’ve tried to contact the maintainer and he said that there are some conflicts with Apache on TW that apparently don’t appear on Leap repos. I’m not able to give you more details about this.

Anyway, I was more interested about the php-cli dependency. It is not a problem for me to install the rpm from my machine instead of getting it from the repo.

Thank you.

Looks like someone created a Dolibarr docker container on the Docker Hub. In fact, it looks like several people have created images but the one you should use is the one created by and owned by noophq.

I haven’t tried it, but there is no reason to believe that it won’t work immediately “out of the box.”

FYI - The reason why docker solutions you download and use avoid any dependency and prerequisite issues is because the app is built on the distro of the creator’s choice, for instance you could be running a stub of debian in the container, all running on your openSUSE.

If you haven’t used Docker before, you can install and run through a few quick exercises I’ve written on my Wiki. If you’ve used any virtualization before, you’ll notice some similarities.


Thank you for the suggestion.

My laptop is a bit old, how will Docker will affect my overall performance?

One of the nice features running docker is that everything runs as “just another app” on your machine.
In other words, there is no difference except for the stub OS which would ordinarily be considered next to no difference.

Docker can be used in places where virtualization cannot or with issues…
Like on 32-bit machines (you need 32-bit libraries), machines with CPUs that don’t support hardware assist, and with limited resources.


Ok, I’ll give it a try.

Maybe this is a temporary issue, but when I try to install the “docker” package, I get this:

Problem: nothing provides containerd = 0.2.5+gitr608_03e5862 needed by docker-1.13.0-2.2.x86_64

Are you still available to help me with Docker?

I’ve pulled the image from here and linked to a mariadb container

I’ve created the containers, and everything seems to be running, but I’ve got some problems with the login.

When you have a new problem, it is best to start a new thread with a good title that has the keywords to the problem. That is the best way to draw attention of potential helpers.

Hanging your new problem at the end of an old one will likely not be seen by many.

I’ve been trying to get dolibarr to work, but both the packages from their site, and the packages from OBS are horrible, require a lot of manual work after the install, so docker should be your best option. What I don’t understand is why you’re not using the openSUSE mariadb packages …

I’m not that expert about Docker and database management, I’m just trying to follow the instruction found here
It is said that it must be linked to a database container and that’s what I’m trying to do.

But I’m juts trying to make this work, if there are better ways to do it, I’m listening.

I’d setup mariadb first, and locally. The instructions given to me seem a bit of a mess: different DB name, user, password in the instructions f.e.
So first create a mysql admin ( root, which is not your linux root user ) password. Next install phpMyAdmin, and use it to create a DB + user for dolibar. Next install and run the dolibar docker container and configure it to use the newly created DB+user.
Mind, it’s been a while since I tried ( and succeeded ) to get dolibarr to work.

The docker compose file in the documentation referenced is supposed to download and configure access to mariadb in its container automatically. But, to my eye the mariadb in its container may not be set up (unless I’m missing something). When I get some time, I’ll try this on my own to verify whether it’s set up to run automatically or not.

It should also be noted that this is only a component of a much larger CRM solution (link on the reference) at

In fact,
I’d highly suspect only by installing the full “dolibarr” that everything including populating the mariadb database is done for you.


Tony, just have a look at the differences between the defaults given re. the instructions. My 2 cents: the software may be a beautiful solution, the documentation IMHO sucks. No other word for it. The one thing the should include in the ERP is the first three weeks sysadmins need to get it in a proper working condition i.e. actually repackage it,. F.e. this is a webapplication where all the files land outside the webroot.

Instead of the docker container you’re trying to set up, I’d recommend one of the following instead. Note that each contain an entire PHP environment, so you’ll have to select according to which PHP you wish to run.

If you have problems selecting one, post again.


It was just a bad selection, if you follow the link to the main project it becomes somewhat clear what is happening.
As I suspected, by itself the selected docker container is incomplete, and would be set up properly if you set up the entire project.

Confusion and frustration by the doc incompleteness is only because those containers aren’t supposed to be run by themselves only.


Just for the sake of completeness: openSUSE ( like other distros ) doesn’t have php-cli, we have /usr/bin/php

Thanks for your effort and support guys, I’ve found a Virtualbox image here and it seems to work without too much problems.

It is not the most straightforward solution, but at least now I can try and use this program without getting crazy by unsuccessfully trying to set it up.

Good for you.
Whatever works you, go for it.


php and php-cli aren’t the same.
If you look up the php-cli project, it’s separate functionality and is currently in beta (so you may not see it as part of a main distribution).

Also, it doesn’t have a database requirement, it does in that dolibarr app only for the author’s own reasons.