Package kit @ boot - Can I delay it for a time?

Package kit wins the race over internet connection when booting up, and one or both, laptops always ‘Fail to get Updates’
Is there a method to delay Package Kit for a few seconds(15,20,30…) when initially booting up?

TIA
Bill_L

Is this a WiFi connection?

Are you using KDE?

Yes & Yes
The desktop Ethernet connection rarely if at all have this problem.

Go into the NetworkManager settings for your WiFi connection.

Go to the security settings, where you set the password.

There should be an option on where the password is stored. The default is for it to be stored encrypted (that’s in KDE-wallet). But there is also an option to store it unencrypted in a file. Choose this option. It is actually in a file owned by root and not readable by anyone else, so it isn’t risky.

To test that, you can reboot. And it should connect without prompting for your kwallet password.

Once you have that set, then on the general settings for the connection, there is an option to share this connection with all users. Select this option. You will probably be asked for the root password for this.

Once that is done, it should solve your problem. The WiFi connection will be made before you login. So you should already be connected by the time that packagekit wants network access.

Thanks! I will try all that but AFAIK, neither WiFi laptop is using KDE Wallet. Not 100% sure, but when I open NM, it doesn’t bring up KWallet.

If you happen to have installed “pam_kwallet” then it will be opened behind the scenes without you noticing it. Or you could have set “kwallet” to use a blank (empty) password, and again you would not notice it. Or you might have disabled “kwallet” and I’m not sure what is the effect of doing that.

In any case, the changes that I suggested will have the WiFi password stored outside your session settings, and will get you connected before you login.

Another approach would be to disable the automatic updates check and just do an updates check when you want

Go one small step further and remove PackageKit at all :wink:

Run: ‘systemctl status NetworkManager-wait-online.service’ and show the output.

Good advice. I use…

sudo zypper refresh; sudo zypper up

at my convenience rather than having PackageKit interruptions.

Not bad. I use YaST > Software > Online Update, because then I can easy see what will be done before I say Continue.
When e.g. a kernel update is waiting, I may postpone to a later point in time, because a reboot may disturb ongoing activities. Of course zypper can also give you a list of what is waiting for you.

And IMHO, looking once a week is really frequent enough in normal circumstances. No need to have an applet shouting “UPDATE!” to my innocent users whenever they are concentrating on their work with the system. :wink:

Everything in NM had already been set as your instructions indicate. So I didn’t have to change things there.
my laptop sporadically will ‘error’ in package kit, but it is using the onboard WiFi.
my wife’s laptop has onboard AND a USB WiFi dongle. I put it in because her onboard WiFi is ‘iffy’ at best. The ‘onboard’ still shows up in NM, and I can’t find where to ignore it. AND YES, I have tried to disable it in the BIOS. No disable to be found there.
So her machine may be having these update hiccups because of that. Don’t know?

Also, to everyone that responded, thank you for your input.
I am just going to have to update her machine weekly manually.
I do mine using zipper, but she doesn’t want to have to remember or look for a note that has the CLI input and remembering a root password(I am root on her machine BTW).

again, thanks to everyone for per usual excellent responses!

Your wife is correct. She has a system manager to do the job. No need what soever for her to know the root password.

I assume you get duly paid for the job. lol!

Refer ‘man NetworkManager.conf’

KEYFILE SECTION
This section contains keyfile-plugin-specific options, and is normally only used when you are not using any other
distro-specific plugin.

   hostname
       This key is deprecated and has no effect since the hostname is now stored in /etc/hostname or other system configuration
       files according to build options.
   path
       The location where keyfiles are read and stored. This defaults to "/etc/NetworkManager/system-connections".
   unmanaged-devices
       Set devices that should be ignored by NetworkManager.
       See the section called “Device List Format” for the syntax how to specify a device.
       Example:
           unmanaged-devices=interface-name:em4
           unmanaged-devices=mac:00:22:68:1c:59:b1;mac:00:1E:65:30:D1:C4;interface-name:eth2

‘nmcli connection delete new-eth1’: https://www.thegeekdiary.com/how-to-configure-and-manage-network-connections-using-nmcli/

OH YEAH! In many ways! She is my Life!