Package 'desktop-data-openSUSE' broke my kickoff menu

Package ‘desktop-data-openSUSE’ broke my kickoff menu

I removed package ‘desktop-data-openSUSE’.
I installed package ‘desktop-data-openSUSE’.

Kickeoff, the traditional menu and lancelot all show no applications in applications category.

I tried: ‘restore system menu’ from kmenuedit, I tried rebooting.

I was just trying to have a more vanilla menu layout…

Please help me!

Why do you not tell what level of openSUSE you use?

Do you have any other repos except the standard one (OSS, nonOSS, Update and Packman)?

And when no, what is the use of deinstalling and installing the same package from the same stabile repo?

And when yes, why do you not tell us which repos you use (especialy thos containing other KDE version then the standard OSS repo?

Sorry, I’m a liltle stressed out.
Opensuse 11.4 kde 4.7.2
I tried reinstalling both default (11.4-13.16.1) and extra (11.4-13.18.1) repository versions.

Hi
If you create a test user and login, is the problem duplicated to the test user?

menu works fine to other users

Hi
So I would assume it’s a config file that’s corrupted for the user.
Hopefully a KDE user will offer some pointers, probably down in
~./.kde4


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
up 5 days 9:31, 4 users, load average: 0.14, 0.05, 0.05
GPU GeForce 8600 GTS Silent - Driver Version: 285.05.09

Try deleting|moving ~/.kde4/share/config/kickoffrc. Then logout, login.

This is getting funny…

I completely deleted my user from yast, and the /home/nikos folder.
I then rebooted, found no ‘nikos’ user.
I then created a new user named again ‘nikos’
Menu under ‘nikos’ user is again broken (!)
Menu under new user ‘nik’ works fine

I’m a little to angry right now to open a bug report, I’ll probably do it some other day…

Hi
When you rebooted, did you check that the /home/nikos folder was actually gone? Also check the UID for the new user nikos, is it still at 1000, I’m assuming nik is 1001.

Solved.

I deeply thank you, changing the user ID fixed the problem. I guess uid 1000 is now cursed or something…

Will open bug report soon.

rename ~/kde4 that will remove all KDE settings and will create the defaults at next KDE start.

It is possible I guess that the settings you messed up are in /etc or some other location under your 1000 UID In fact it may be certain because removing and re-adding a package should not normally mess with anything in home. DOn’t know where that might be though seems there are some kickoff files deep in /usr/share but the file themselves are not user specific.

I am with you. This is very strange. A removal of ~/.kde4 should destroy all user configuration. And a complete removal of that users ~ must certainly do that.

So it sounds like a bug, but I am afraid it is very difficult to file this with enough evidence :frowning:

Hi
Wonder if the OP allocated the default user (UID 1000) to also use as
the password as the admin password? Changing the UID to anything but
would probably account for this…?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
up 6 days 6:48, 4 users, load average: 0.04, 0.13, 0.10
GPU GeForce 8600 GTS Silent - Driver Version: 285.05.09

Sorry, I do not get you here. Do you mean that he mixed up somewhere between his normal UID (1000) and that of root (0)?

Hi
No, when installing, checked the box to use the same user password as
root for administration.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
up 6 days 7:15, 4 users, load average: 0.19, 0.16, 0.17
GPU GeForce 8600 GTS Silent - Driver Version: 285.05.09

That would only give you two different users (0 and 1000) with the same password. Not a real problem (except from the point of view of security of course). You and I could on any system have the same password by incident. That is not even to be detected in the encrypted passwords as stored on th system, they will be different.

Looking at the kickerrc in ~/.kde4 there is a lot of missing info I see only lists of the shortcuts to the menu items. So additional info must be stored elsewhere as metadata it is possible that it has user associations. one of those compressed files in /usr/share/kde4 probably???

I actually kept the same ~/.kde4, so problematic settings wasn’t there.

https://bugzilla.novell.com/show_bug.cgi?id=728576