package dependencies

How can I find what packages are required for another?, if I type:


rpm -q --whatrequires libselinux1

it say that nothing require libselinux1, but when I type:


zypper rm libselinux1

it ask me to uninstall 4.5 GB


VampirD

Microsoft Windows is like air conditioning
Stops working when you open a window.

OpenSUSE packages have a lot of dependencies.

I think you are best using the gui version of yast, then click on remove libselinux1 and see what yast says, it will list all the packages that depend on libselinux1.

Unless someone could point us towards a better method.

VampirD wrote:

> How can I find what packages are required for another?, if I type:
>


> rpm -q --whatrequires libselinux1
> 

it say that nothing require libselinux1, but when I type:


> zypper rm libselinux1
> 

> it ask me to uninstall 4.5 GB
>
I think the command you really want is

rpm -q --requires libselinux1

FizzyFanta wrote:

>
> OpenSUSE packages have a lot of dependencies.
>
> I think you are best using the gui version of yast, then click on
> remove libselinux1 and see what yast says, it will list all the packages
> that depend on libselinux1.
>
> Unless someone could point us towards a better method.
>
>
Again the command mentioned in the original post is simply the wrong one to
see the packages which require libselinux1.

The correct command shows the following dependencies

rpm -q --requires libselinux1
/sbin/ldconfig
/sbin/ldconfig
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
ld-linux-x86-64.so.2()(64bit)
ld-linux-x86-64.so.2(GLIBC_2.3)(64bit)
libc.so.6()(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.3)(64bit)
libc.so.6(GLIBC_2.3.4)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libc.so.6(GLIBC_2.8)(64bit)
libdl.so.2()(64bit)
libdl.so.2(GLIBC_2.2.5)(64bit)
rpmlib(PayloadIsLzma) <= 4.4.6-1

And ALMOST EVERYTHING you can think of depends in turn on libc!

man rpm

gives more info.

> The correct command shows the following dependencies
>
> rpm -q --requires libselinux1
> /sbin/ldconfig
> /sbin/ldconfig
> rpmlib(PayloadFilesHavePrefix)<= 4.0-1
> rpmlib(CompressedFileNames)<= 3.0.4-1
> ld-linux-x86-64.so.2()(64bit)
> ld-linux-x86-64.so.2(GLIBC_2.3)(64bit)
> libc.so.6()(64bit)
> libc.so.6(GLIBC_2.2.5)(64bit)
> libc.so.6(GLIBC_2.3)(64bit)
> libc.so.6(GLIBC_2.3.4)(64bit)
> libc.so.6(GLIBC_2.4)(64bit)
> libc.so.6(GLIBC_2.8)(64bit)
> libdl.so.2()(64bit)
> libdl.so.2(GLIBC_2.2.5)(64bit)
> rpmlib(PayloadIsLzma)<= 4.4.6-1
>
> And ALMOST EVERYTHING you can think of depends in turn on libc!

So, I need libselinux1 to use libc?


VampirD

Microsoft Windows is like air conditioning
Stops working when you open a window.

VampirD wrote:

> So, I need libselinux1 to use libc?
>
>
Sorry I am an idiot I gave you the command in the wrong direction, just wait
a moment I post the correct one, I should not post when I am too tired.

On 2010-08-10 21:58, VampirD wrote:
>> The correct command shows the following dependencies
>>
>> rpm -q --requires libselinux1

>> And ALMOST EVERYTHING you can think of depends in turn on libc!
>
> So, I need libselinux1 to use libc?

So forget your idea of removing libselinux1. >:-)


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” GM (Elessar))

Martin Helm wrote:

> Martin Helm wrote:
>
>> VampirD wrote:
>>
>>
>>> So, I need libselinux1 to use libc?
>>>
>>>
>> Sorry I am an idiot I gave you the command in the wrong direction, just
>> wait a moment I post the correct one, I should not post when I am too
>> tired.
> Ok you have to query what the libselinux1 provides first:
>
> rpm -q --whatprovides libselinux1
>
> libselinux.so.1()(64bit)
> libselinux1 = 2.0.80-5.2
> libselinux1(x86-64) = 2.0.80-5.2
>
> and then query for that capabilities which is are often shared objects not
> the package names, for example
>
> rpm -q --whatrequires libselinux.so.1
>
> libgio-2_0-0-32bit-2.22.4-0.1.1.x86_64
>
> This is just an example from my suse 11.2.
And again a typo the first command is of course

rpm -q --provides libselinux1

Going further and looking on the packages which are dependent on libgio, I
find that it is nearly all of gnome at least.
I did not check now evrything because it is tedious this way.

If you go into yast you can check the same in a simpler way (the search
function has the option to search for requires).

In fact as you already noticed uninstall of libselinux will nearly
completely uninstalls your system (I did not know that).