P5Q PRO lan drivers

Hi there,
I have downloaded some drivers for the lan controller on my P5Q pro. But when i tried to run make install i got prompted for not having version.h
After running make /include/linux/version.h in /usr/src/linux i tried installing the drivers again, but got prompted for not having autoconf.h =\

I tried running make /include/linux/autoconf.h, but got an error saing my kernel is not confiured…
Im lost at this, any help?

Thanks in advance

Anyone? im really stuck here as i really need internet.

To explain better, i stole an ethernet card from somewhere, opened up software management and installed the kernel source development thing (from in the patterns menu). I then installed make and gcc, and then closed software manager.
I then cd’d to the directory where i had extracted the drivers, and ran “make install”. This is when i was prompted with “missing version/h”

Anyone have any ideas as to why this is? Im running suse 11 installed from the DVD if this helps… =(