ownCloud 6 and Thunderbird Lightning not syncing

Does anyone else here use Thunderbird with the Lightning add-on to sync their calendars with owncloud 6?

It used to work well for me a few months ago. Then I stopped using owncloud for a while as I was moving to a new host and due to time constraints just didn’t set owncloud up on the new host.

So last weekend I decided to install owncloud 6 on the server and set up all my calendars again. However, for some reason when I try to connect to those calendars from Lightning they remain greyed out. Nothing I’ve tried will allow me to connect to my remote calendars. I can go through the motion of setting up the remote calendar but as soon as I OK it, it becomes greyed out in Lightning.

I’ve tried a new clean Thunderbird profile, I’ve tried it from another PC with identical OS and TB versions but I just can’t connect to those remote calendars. I’ve tried various combinations of checking / unchecking offline support, alarms, etc but nothing works. I can however connect to them just fine using the KDE Korganiser calendar and my android calendars via caldav-sync so owncloud seems to be set up fine. I can also connect to them via the caldavzap web client so the fault seems to lie with TB and Lightning.

I’ve been through the Mozilla forums and it seems to work fine for others so I would like to know if this is specific to openSUSE - perhaps it’s the way TB packaged for openSUSE? The TB error console seems to throw up a a lot of warnings similar to the ones below.

Timestamp: 24/02/14 18:51:02
Warning: Error in parsing value for ‘text-align’. Declaration dropped.
Source File: about:blank
Line: 0, Column: 205
Source Code:
border-collapse: separate; color: rgb(0, 0, 0); font-family: Chalkboard; font-style: normal; font-variant: normal; font-weight: normal; letter-spacing: normal; line-height: normal; orphans: 2; text-align: -webkit-auto; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-border-horizontal-spacing: 0px; -webkit-border-vertical-spacing: 0px; -webkit-text-decorations-in-effect: none; -webkit-text-size-adjust: auto; -webkit-text-stroke-width: 0px; font-size: medium;

Timestamp: 24/02/14 18:51:34
Warning: Unknown property ‘mso-style-priority’. Declaration dropped.
Source File: about:blank
Line: 72, Column: 20
Source Code:

Does anyone have any ideas?

I’m using oS 12.3 with TB 24.3.0 (I’ve tried from both the Mozilla and openSUSe repos) and Lightning 2.6.4.

I am running TB 24.3.0 on oS 13.1/KDE 4.12.2

I can report that Lightning 2.6.4 does connect and sync with my Google Calendars (with the help of Provider for Google Calendar 0.25 add-on).

I have never tried the arrangement you have with OwnCloud

Just an thought - can TB make any connection to your OwnCloud, e.g. can you attach a file from your OwnCloud to an email?
That would seem to check connectivity (and perhaps permissions) between the TB process and OwnCloud.

I’ll be interested to see what you finally figure out here.

So, after a bit more experimenting I found that I cannot sync my remote address book with TB using the sogo connector if lightning is installed. If I remove lightning then the address books sync fine. Install lightning and they stop syncing - I see no error messages. I’ve tried with older versions of lightning going down 2.6.0 and TB 23.0 and it makes no difference.

I tried, as you suggested, attaching a link to a shared file from owncloud and that works. I can’t attached a file directly from a remote folder on owncloud. I can browse to the file when trying to attach it but when I select the file TB says only local files can be attached.

I’m going to try setting up TB in a windows VM and see if I see the same problem.

Just a quick update. I haven’t had much time to investigate this further but I did try installing TB in a Windows XP VM and I experience the same problem so it’s not OS specific. I suspect it may be a problem with the ssl certs. I don’t have any evidence of that it’s just a hunch but I need to do some more testing.