OVH bridge client config

Hi all. I have been trying to get the ovh bridge client to work properly in opensuse to no avail. I have used ovh’s guide to successfully configure debian, ubuntu, centos, and windows. I have also found tutorials for ipcop and pfsense and also got them working. However, opensuse is baffling me. I am not a noob but I also am certainly not an expert either so I usually just follow the instructions or tutorials but I haven’t found any for opensuse or Novell Suse. You can find OVH’s guide online using your favorite search engine very easily. From experience, posting links in your first post is usually not a good idea.

Thanks

Baruch

Hello and welcome here.

We are always interested in the openSUSE version you use

It is version 13.2 running as a virtual machine in esxi.

Would help if you didn’t mis-spell OVH in your subject line…

Without digging into any possible pecularities of its services,
As you describe it looks like they deploy based on VMware.

There shouldn’t be any diff deploying openSUSE than any other OS so whatever your problem might be is probably something simple and possibly easy to overlook. In fact, it’s likely that anyone familiar with VMware in general might be able to identify and fix your issue.

You’ll have to be descriptive, the usual

  • Give the URL to the specific guide you may be following
  • Describe exactly what error you are getting by stdout or dashboard or log
  • Post the exact network configuration (ip addr) in the Guest
  • Have you tried to replicate the situation locally? Can you deploy a local esxi (or maybe on Workstation)?

TSU

The problem isn’t really the os. I have used opensuse in a dhcp setup just fine as a test. The problem is just where and how to set the various config files. The guide I use is below.

OVH Bridge Client Guide

Sorry I didn’t address your other requests.

No error per se. I just don’t have internet on the guest. If there is something I can post then tell me. Like I said, I am not a noob but I am far from a Linux expert. I do have a very strong feeling that the problem is rooted in the routes file since ovh’s required route has the gateway on a different subnet than that of the ip and it’s the only non straight forward part of the configuration.

I really would prefer not to post the ip as it is static but the setup is the same regardless of the ip. I already have it working in centos and windows 7 on 2 other guests with different ips.

There really is no point in trying to replicate it locally because my local setup is nothing like the ovh setup. I have a dynamic ip while this is static and I already know dynamic ips will work.

I can now say with a 99% certainty that the problem is with the ip routes so I will post here the instructions for centos and maybe someone will know how to convert it to opensuse. The reason for using centos is that centos has a separate file for the routes like opensuse and debian has the routes in the interfaces file which has all ip information for all interfaces and for all routes in one place.

In centos, here is what the route-eth0 file will look like. I am assuming that the interface is eth0 and that the ip address is 10.10.10.10.

10.10.10.10 dev eth0
default via 10.10.10.10 dev eth0

The reason for my certainty is that I set up a static ip using my virtual ipcop router. All I did was change the ip to 192.168.1.200/24 instead of 192.99.xxx.xxx/32 and then I commented out all lines in the ifroute-ens32 file and added the line

default 192.168.1.1 - -

This made it work with the router’s static ip but I need the external ip. I then commented out the new line in the ifroute-ens32 file to be sure it wasn’t pulling that route from somewhere else and sure enough there was no internet. To cement things even more I set up another machine to be on that same virtual network and i was able to ping the opensuse machine. All this basically giving me 99.9% certainty that the issue is the route. So now I know where the problem is and I just need a little help trying to turn that centos file into a opensuse file. To help people point me in the right direction, I would like to volunteer the information that I have read in the past that the issue is that the ip block of the gateway and the ip block of the ip address are totally different. My gateway for example is 198.27.xxx.xxx and my ip is 192.99.xxx.xxx. Windows will give you a warning but it will work but linux doesn’t like it and you must force it. How to do this in opensuse is the issue imo.

If what you say is true that the DG address are what you describe when you changed to a Class C private network (192.168.y.z), then the solution likely is to just change your subnet mask from the default 255.255.255.0 to 255.0.0.0. That places your machine in the same network as your DG.

You should also understand if the guide you’re following is intended to set you up for a bridging network connection, a private address space is probably wrong, more than likely you need to configure a public address. If the Class A and Class C private addresses you’re describing are purely for sanitizing a public post in this Forum, OK. But if those are actual values you should re-consider. Any private addresses pointing to your router are probably there only to manage those devices safely but shouldn’t work for setting up a typical machine on your network.

Also, some things have changed recently regarding where network configuration files are located.

  • Instead of modifying config files directly, use YAST to ensure all files are correctly configured.
  • Always doublecheck the results of your network configuration with common tools like ip addr, ifconfig and route.

TSU

Ok first of all, I have it working. I am writing this post to help other ovh customers in the future. The main issue is the routing as it always is with ovh ip addresses. No I did not make a typo. Here is the config you must have in your ifroute-ens32 file.

[ifroute-ens32]
server_gw - 255.255.255.255 ens32
server_network - 255.255.255.255 ens32
default server_gw

As an example assuming ens32 is adapter name and 198.5.5.55 is the server ip. Note that this is the server ip and not the vm ip.

server_gw=198.5.5.254 your server ip but with 254 as the last section. This part most ovh customers should be familiar with.
server_network=198.5.5.0 your server ip but with 0 as the last section. This is where things were not correct.

[ifroute-ens32]
198.5.5.254 - 255.255.255.255 ens32
198.5.5.0 - 255.255.255.255 ens32
default 198.5.5.254

Ovh also went onto add that in the /etc/sysconfig/network/config file the following line should be changed or added to the following

NETCONFIG_DNS_STATIC_SERVERS=”213.186.33.99”

They also gave me the config for the file /etc/sysconfig/network/ifcfg-ens32. I did not have to make any changes but just so all the info is out there, I will put it.

[ifcfg-ens32]
DEVICE=ens32
BOOTPROTO=static
ONBOOT=yes
ARP=yes
USERCTL=no
IPV6INIT=no
TYPE=Ethernet
STARTMODE=auto
IPADDR=IP.FAIL.OVER
NETMASK=255.255.255.255
GATEWAY=GATEWAY_VM
HWADDR=MY:VI:RT:UA:LM:AC

I made a mistake with my post. No edits allowed after 10 minutes therefore this is a fix. The ifroute-ens32 file should be as follows:

198.5.5.254 - 255.255.255.255 ens32
198.5.5.0 - 255.255.255.0 ens32
default 198.5.5.254

This of course assumes that your server ip is 198.5.5.55.