Overwriting 10.1 with 11.1

I am determined to overwrite my Suse 10.1 with 11.1. I acquired a DVD from ebay with 11.1 on it, but have absolutely no idea how to go about the overwrite. I put the DVD in the computer, rebooted, but nothing happened.
So, what is on the DVD? Well there are a series of folders and executable files, including a BOOT folder and openSUSE11_1_LOCAL.exe and openSUSE11_1_NET.exe files.
But what do I have to do with all of this to achieve an overwrite?
My original 10.1 was a disk plus book package, but this time around I acquired the DVD with the download to as not to spend money I don’t have.
If anybody can give instructions, I would be very grateful. Please treat me as though I were four years old (I’m actually 51 and determined never to use anything by MS ever again) and, if giving instructions, give them step-by-step, since I made no alternations whatsoever to the original 10.1.
Sorry to sound so stupid!

Hello Crossbone and welcome to the forum.

determined never to use anything by MS ever again

That’s good and I am convinced that you will find many helpful people here.

If this is an installation DVD it must be bootable. It should boot a kernel and present you with a menu where you can select a fresh install.

As a first step reboot your computer, enter the BIOS and check that your DVD is the first item in the boot sequence. Then try to reboot from the DVD. In case it does not boot come back here.

Hi Vodoo,
I think I have done this correctly, but please remember I use computers, but never look under the bonnet!
I hit F2 during the boot, which I think is what was required and got to a page where there is a BOOT tab. Under this there was the following list:
1st: Floppy Drive
2nd: HDD: PM-Excel/Stor T
3rd: CV/DVD: SM-TSST corp

There will probably be a function key which allows you to highlight the CD/DVD and move it to the top of the list.

When you have done that, save and exit and it will boot from the CD.

Incidentally, unless you have a very old machine, you have probably been wasting time waiting for it to check the floppy drive every time you switched on.

When you are asked to restart after the installation, put the HD as number 1.

And, if you have any personal files you want to save from 10.1, copy them to a CD/DVD or USB drive because 10.1 did not install a separate /home partition and so this will be overwritten when you install 11.1.

11.1 will install a separate /home partition, allowing you to upgrade/re-install without touching /home.

Thanks everybody!
Now, could you help me with another problem I have never been able to solve.
I have a Brother MFC-640CW printer, but the system does not have this in its list nor are their appropriate drivers.
On 10.1 the problem was the same, so I had to run the printer from a MS computer (hiss!). Could you talk me through the process of getting the printer to work with 11.1? Please assume total ignorance in how I might do this…!http://forums.opensuse.org/images/smiliesnew/sad.png

Drivers/instructions are here:

Brother Solutions Center : Brother Driver for Linux Distributions

For scanner:

BSC: Brother Linux Scanner driver /Scan key tool download

OK.Found the Brother page. It refers me to driver for the MFC210C. There are four: two are LPR drivers and two cupswrapper drivers. Which should I choose and, if I hit download, should I save them or run them? In the case of the former, where will they be stored and how can they then be added to the drivers menu?

You’ll want the rpm packages for openSUSE, (not the deb format). Download the MFC-210C LPR driver first. Your bowser will give you options to open using (Install Software) or save file. I usually download rpm file to a suitable directory, and then use terminal commands to install (rather than right-clicking on file and choosing ‘Install software’ or similar).

cd /home/joe/where/file/downloaded
su (to become root user)
rpm -ivh name_of_package.rpm

Then do the same with the CUPS driver and install.

Once the 2 packages have been installed, you should be able to configure your printer via CUPS web interface.

OK. Successfully downloaded both files, but both were placed automatically on my desk top, which probably isn’t the best place for them!
Could I therefore continue to strain your patience by requesting where they should be placed and how I do that. Plus, how would the command suggested above therefore be written?

The desktop location is fine. Now, you could right-click on the files and choose ‘Open with Install Software’ or similar ,(or use terminal method I outlined earlier).

I knew something was going to go wrong! I used install software and the first file was fine. The second, the cupswrapper generated the following error message:

/cupswrapperMFC210C-1.0.0-1.i386.rpm could not be installed.

So what next?

Subprocess failed. Error: RPM failed: error: Failed dependencies:
csh is needed by cupswrapperMFC210C-1.0.0-1.i386

Help! I’m losing this…

/cupswrapperMFC210C-1.0.0-1.i386.rpm could not be installed.

So what next?

Subprocess failed. Error: RPM failed: error: Failed dependencies:
csh is needed by cupswrapperMFC210C-1.0.0-1.i386

Don’t be alarmed. I’ve found from experience that csh is not actually necessary. Anyway, there is a ‘dummy’ csh package for opensuse 11.1 available from here:


Install the package, and then the cupswrapper package should install ok.

Although, its generally not recommended practice, I know from experience you can also just do

rpm -ivh --nodeps cupswrapperMFC210C-1.0.0-1.i386.rpm

Well done Deano! It worked! The cupswrapper installed.
Now, where do I go from here?
Remember, spell out the steps; please don’t assume I know what you will be talking about…

Idling around, I again clicked on Printing in the Control Centre and got as far as the Printer Configuration box, where there is a little picture now of an MFC210C printer. Don’t quite know what to do with it, but we are getting tantalisingly close to an install, wouldn’t you say?

Yes, your not far away now. Good work. I know many use the yast printer tool for configuring, but I far prefer using the CUPS config interface. Connect your printer and turn it on, then open a browser and enter


This will give you CUPS config page (from your local CUPS server). Click on ‘Administration’. You may find ‘Find New Printers’ works for usb printer. Just follow the prompts. Alternatively, use ‘Add Printer’. Give your printer a name (from memory other fields are optional), then ‘Continue’. Again follow the prompts, until finished. If you need to enter password (use root user and password).

OK Deano, edging closer. I followed the Administration option, which worked. Went back to printers and the MFC210C driver was in the option list, selected it and got the actual MFC-640CW printer that I am using in the Printer configuration-Local host box as an icon. What next?

PS. It has a tick/check against it!

However, Houston we have a problem, because if you look under printers, the following message is displayed:

MFC-640CW (Default Printer) “Filter “brlpdwrapperMFC210C” for printer “MFC-640CW” not available: No such file or directory”

Hmmmm… somthing we should have checked earlier. You don’t have a 64-bit system (with 64-bit OS install) do you?

  1. Post output of

cat /proc/cpuinfo |grep model

We’ll worry about what needs to be done here, if 64 bit applies.

Now, I dug up this old thread concerning similar problem. Please read through that. In particular, post #16 onwards.

  1. I would try to see if you can see the printer listed here. If so, can you print a test page ok? Forget yast (or control centre for the moment).

3) Post #19 deals with a 64-bit user, who had to make a symbolic link to 64-bit libs to get the printer driver operational. I can explain in further detail if this applies but not clear to you.