Overall slow performance of 11.2

First of all, apologies if this is not the correct place to post this.

I recently installed openSUSE 11.2 (Gnome, 32bit) on my newish PC. It is an Acer Aspire X3200 (AMD Phenom X4 Quad-Core, 1.8 GHz, 4096 MB, NVIDIA GeForce 8200 Integrated, can provide detailed specifications if needed). I’ve to say I am very disappointed with the results so far! Sorry to say this but I’m having a whole load of problems that I never had when I had Vista or with current Win 7. Here are the issues:

  1. Slow network performance. I’ve disabled ipv6 but it is still the same. Not only when I use Firefox, it is also slow when I use console based programs.
  2. Instability - Gnome system monitor crashed 6 (or more) out of 10 times I use it. System Monitor users more CPU resources than anything else! Also when I started the PC this morning, I only had the desktop wallpaper. No icons, no taskbar, no mouse movements or menus, nothing. I had to force shut down it after a while. I’m sure we all are familiar with this on XP but I’ve never seen something like that on Linux!
  3. Annoying noise coming every time I move mouse (mainly when scrolling) and even if I’m not doing anything. I suspect it is coming from my HDD indicator as it always blink even when nothing is running. This can’t be a hardware issue as I’ve never had this on Vista or Win 7 (it is virtually silent on Vista and XP but not on SuSE) This noise is driving me totally mad.
  4. Slow performance in general. No matter what I do, even typing this on this text window, it seems everything is running so slow. I never had this problem when I was running 10.x on my 6 year old PC. CPU is always running around 20%-30%, when I don’t run any other applications but just Firefox (I have Foxclocks, Delicious and FEBE as add-ons and I don’t have any problem using them on Vista or Win 7). I am using Compiz, not sure if this has got anything to do with that.

Booting also takes a lot of time compared to Win 7.

SuSE has been my favourite distro for many years but I’m so disappointed with 11.2,as all the other versions worked really well out of the box on all my PCs/laptops. I don’t want to move to something else so it would be great if someone can help me to sort these issues out.

Many thanks in advance!

Can you tell us what graphic driver?? The driver you have selected can make a massive difference in performance. More specifically, the proprietary nVidia driver is significantly faster than the openGL radeon/radeonhd drivers. The radeon/radeonhd drivers are signficantly faster than the vesa driver. The vesa driver is significantly faster than the fbdev driver. Omitting that information makes it very difficult (ok, makes it impossible) to do any sort of decent evaluation of your post.

There is a bug in openSUSE-11.2 that often when one thinks they have ipv6 disabled, it is NOT disabled. What is your criteria for saying it is indeed disabled?

My experience is new users have incredibly ugly stability problems because they have added way too many repositories.

It is impossible to evaluate your comment on stability, unless you provide us the output of:

zypper lr -d

so that we can get an idea as to where you are getting your applications from. PLEASE provide that output. Note that I recommend users ONLY use OSS, Non-OSS, Update and Packman. That recommendation is also in our installation stickie as clear as I can make it.

Please, you need to provide the output of “top” so we can see what process is consuming CPU resources. Its difficult, no its impossible, to evaluate that statement, without posting what is consuming the resources.

Please read my post about “zypper lr -d”.

Hmm … strange … I’ll be curious to read what others say about that.

I think you stated this. Note not disabling ipv6 (when you think you have disabled it) and NOT having the proprietary graphic driver, can cause this impression. In addition having processes running that should not be running (which are surviving from boot to boot because they were not closed properly) can be a cause, and there can be other causes.

I don’t have Win7. I’ve read it boots pretty quick. I do have winXP and there was a time when WinXP supposedly booted faster. No longer. openSUSE boots faster than WinXP.

I also note winXP will “fool” a person, … one may think it has finished booting but then find it impossible to do anything under WinXP for another minute while it boots some more in the background, making the keyboard/applications useless. Hence when evaluating the boot time, one must take that into account. But again, I have no Windows 7 experience.

On 3 of our 4 desktop PCs, openSUSE-11.2 is the best Linux distribution we have had yet. On the 4th, openSUSE-11.1 (because of a superior radeon driver) was slightly better. On our two laptops, openSUSE-11.1 was superior, again because of a graphic driver issue with 11.2, where the graphic driver issue is not SuSE-GmbH’s fault, but rather its an ugly characteristic of the new 2.6.31 kernel.

Lets hope so!

pradeepm wrote:

> I recently installed openSUSE 11.2 … never had this problem when
> I was running 10.x … SuSE has been my favourite distro for many
> years

what ID did you formally use in either this forum or other Linux fora…

i ask because this is your first post here…

and it is just packed with problems which most people have not had…

i wonder how you got along so many years happy (without ever sticking
your head into here) and suddenly have this huge pile of problems that
you suddenly can’t figure out…

i mean, your post reads so much like one of several pesky folks (or
one person pretending to be many) that drops in here every couple of
weeks with years and years of happy SUSEing but not enough experience
to trouble shoot the latest and greatest…

so, introduce yourself…tell us how you checked your install media
to make sure it was 100% perfect before you began installing…tell
us, it seems you are triple booting (Vista, Win7 and openSUSE), how
much space did you allot each? you say booting “takes a lot of time
compared to Win 7” since i’ve read many accounts that Win7s boot time
is measured in minutes and openSUSE in seconds i would like to hear
exactly how many seconds to take you to boot all three…

then, we can go from there…


This should read the proprietary nvidia driver is signficantly faster than the openGL **nvidia **driver.

< sigh > Let me try this again. :slight_smile: Correct above to read:

More specifically, the proprietary nVidia driver is significantly faster than the openGL nvidia drivers. The openGL nvidia driver is signficantly faster than the vesa driver. The vesa driver is significantly faster than the fbdev driver.

I’m using the proprietary nVidia driver. I tried the openGL driver but it didn’t recognise the resolution correctly so I went for the nVidia driver.

I did that via YaST Network Settings but then I read somewhere earlier that removing the ipv6 from there alone will not work. I guess that is what you are referring to.

Here is the output:
1 | 11.2 - VideoLan | 11.2 - VideoLan | Yes | Yes | 99 | rpm-md | http://download.videolan.org/pub/videolan/vlc/SuSE/11.2/ |
2 | Main Update Repository | Main Update Repository | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/11.2/ |
3 | NVIDIA Repository | NVIDIA Repository | Yes | Yes | 99 | rpm-md | ftp://download.nvidia.com/opensuse/11.2/ |
4 | X11:XGL | X11:XGL | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/X11:/XGL/openSUSE_11.2/ |
5 | home:broumbroum23 | home:broumbroum23 | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/broumbroum23/openSUSE_11.2_non-oss/
6 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/distribution/11.2/repo/oss/
7 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/11.2/repo/non-oss/
8 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/11.2/repo/oss/ |
9 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | http://download.opensuse.org/source/distribution/11.2/repo/oss/
10 | repo-update | openSUSE-11.2-Update | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/11.2/
11 | subpixel repository | subpixel repository | Yes | Yes | 99 | rpm-md | http://opensuse-community.org/subpixel/openSUSE_11.2 |

Yes hopefully someone will share their experience as it is driving me mad.

I agree. All my previous SUSE versions were way lot faster than XP. This is something I can live with though as as long as I can sort the other issues out.

That is what I call a service! Thank you so much for the prompt, fast response mate! I really appreciate it.

A note: constant hard disk ticking can indicate a bad sector on the hard drive. This will cause very slow operation. Run a low level disk scanner. I use Spinrite(not FREE) or you can usually get one from the Disk manufacturer. If you can not recover the sector’s data you will need to rebuild the file system with fsck. If the file is an important file the package may need to be reinstalled. Since this is a new install I’d recommend simply reinstalling the os after running the low level scanner and finding bad sectors.

Honestly I don’t know why I am even bothering to write a reply to such a petty-minded post, when someone else has genuinely trying to help me. But here are the answers you are looking for:

Have you never heard this saying, “it is not broken, don’t fix it?” As I’ve written in simple, plain English, I never had any problems before with openSUSE. But in your opinion, even if I don’t have a problem, I should log into a forum and fill it with posts to waste someone’s valuable time that they can use to help someone who genuinely need help, like you do?

In your opinion, everyone on this planet trying to work with openSUSE should have the same problems because the millions (may be billions) of PCs and laptops out there have identical specs! Is that what you are trying to say? Next time when you go through all the forums to find out all the problems everyone has, you might find, one or two of those problems are common to others too! Like the network performance for example.

I have already answered this!

Every night before going to bed, I come here and read those pesky posts. That should explain the influence.

Tell me you were joking, after you find the decency to post under your username!

I don’t have time to go through all the forums in the world to find out out all the problems everyone has, but in my semi-decent PC, Win 7 boots within seconds and SUSE is about 5-10 seconds slower. That’s why I’m here, as it shouldn’t be the case.

With that attitude, you will go nowhere!

Hi mate,
Can that effect only one OS? I have a dual-boot system with Win 7 (I’ve had Vista before) and I only get that noise when I use SUSE. Any thoughts?

Bad sector on a Suse partition. If you see the hard drive light constantly blinking and hear a tick sound that is the hard drive trying to read a sector that is corrupted. Linux apparently will try the read forever or at least nearly so. This may or may not indicate a drive going bad. It could be just one of those things. Doing a low level scan and repair may recover the data it may not. If not then the file system will be in a corrupted state and need fixing. If the sector is physically damaged (head crash) A repair will include using a spare sector in place of the damaged one. The HD keeps a table for such things. If there are no spares then chances are very good that the HD is on it’s last legs.

If the file system ends up corrupted ( the data not recovered by a scan) you would need to rebuild it using fsck. Any pieces of files that the fsck can’t piece back together ends up in Lost&Found. You can then attempt manual recovery there. If the file(s) in question are binaries it is pretty much a lost cause. If a program it is best to simply reinstall it.

I don’t know off hand the correct way in openSUSE-11.2 to disable ipv6. This will require a bit of surfing. But IMHO its highly likely yours is not disabled.

ok, some comments on this.

  • Repos #1 (videolan) is not the way I would go. I note you have no Packman in your repos. Fair enough. But please note Packman are the largest 3rd party rpm packager for openSUSE, and they are NOT compatible with videlan packaged apps , where videolan is a much smaller repository. Hence I think going with videolan as your multimedia repos was a mistake. But its either Packman or Videolan, not both, and changing horses in midstream is potentially fraught with breakage and problems. So you may now be in for a penny and in for a pound.
  • Repos-2 : update. What is the difference between this and repos-10 ?? You only need one update repos. Not both. Having both will slow things down. Sound familiar?
  • Repos-3 : This is for the nVidia driver. What if you do not want to use the nVidia driver? You have it setup as enabled. IMHO its better to leave disabled, and only change to enabled with there is a bug free driver available. Else you risk installing an rpm from nVidia that is unstable.
  • Repos-4. XGL . This is real bad news. This repos is famous for causing breakage. IMHO this is the culprit for your lack of stability, and also possibly for the slow running of your PC. And I do not know how to fix this. It may be too far gone now. You may need to get others to help you to figure what you have installed from this repos.
  • Repos-5: broumbroum23 - this appears to be some sort of wireless repos. IMHO you should disable it. Only enable when you know for certain there is an update you need. Else you risk installing an unstable driver that will slow or break your internet access. … sound familiar ?
  • Repos-10 : update. What is the difference between this and repos-2 ?? You only need one update repos. Having both will slow things down. Sound familiar?
  • Repos-11 : subpixel - this is some sort of font repos? IMHO download what you want and disable this. For all I know they could add a font back that is badly setup that will cause desktop instability.

I always recommend ONLY OSS, Non-OSS, Update and Packman. No others. None. Keep it lean and mean. Adding others can cause problems that takes an average to advanced user to sort.

Can you also advise what application(s) are running when you see the high CPU load. Look at top, and list them, and the CPU% they are using.

Thank you so much for the descriptive reply mate! Are you aware of any free tool that I can use for this scan under Linux? Sorry for being a pain. I’ve done some googling but couldn’t find a reasonable solution.

Hey thank you so much! I never knew all those repos can have such an affect on performance. If my memory is correct, all except VLC repo were got installed through openSUSE One Click Install. I’ve now disabled everything but the recommended ones. Lets see how it goes.

About the CPU load, npviewer.bin and Firefox are the main resource users. Firefox I can understand as I always have 5-6 tabs open. Now I’ve to find out something to do for the Flash application (npviewer.bin). I’ve found a few forums so I’ll go through them tonight and see if I can find anything important.

Go to the web site of your disk drive manufacturer they should have a free scanner. Note low level scans are never done in the OS you make a boot disk from the ISO or whatever and boot to that. Also they generally take a massive amount of time. Something to do over night.

It’s a Seagate HDD so I downloaded SeaTools and ran all available tests, this morning. HDD passed all tests successfully :-\

I’ve to say after I switched off smooth scrolling in Firefox, things are a lot better. I’m starting to wonder if this is something to do with a Compiz setting.

Happy New Year everybody! Hope everyone had a good Christmas break. Back to business now :wink:

I was so wrong when I said removing smooth scrolling made things better. It certainly made the Firefox experience better but the rest of the issue remains the same (ticking noise).This morning I experienced that ‘no-desktop’ issue again (wallpaper coming up without any desktop icons or panel - only thing I could do was force shutdown). I think I should reinstall everything while following the advices I’ve received so far (adding only necessary repos etc)

Don’t have the time to read all in this post, but I have a question:

Why install 32bit openSUSE on a 64bit system? There’s no reason to do this today. So take installing the x86_64 version into consideration as well.

As for the performance of the desktop: this is about the ATI X1100 isn’t it. Wait for the newer kernels, install one, build one, they should do better with your card.

I DID install the 64bit version first but it had a problem identifying my monitor so I went for the 32bit (I know, I should’ve spent some time to get that corrected). Other reason was the impression I got from the majority of the countless number of articles I’ve read, which says there is not much advantage of going for a 64bit version so for day to day use. Sure I will give a try.

Not sure if I understood correctly but I don’t have an ATI card on my PC. It has a GeForece 8200 iGPU. But I can give a try to recompile a kernel after I reinstall everything.

Hello all,

I think it’s my ‘responsibility’ to post an update, as I owe you all for the support you gave me.

As per Knurpht’s advice, I installed the 64bit version on my PC. Strangely (or may be not!) it works far lot better than the 32bit version. Along and after the installation, I followed others’ advices too and now I have a stable installation without any issues I used to get with the previous 32bit version.

About that ticking noise, I believe it has nothing to do with openSUSE. It is definitely something to do with the motherboard so apologies for asking help on something which has nothing to do with this forum.

Thanks again for all the comments and advices.

Best regards,

Glad you got it all sorted. Enjoy your openSUSE.