OSX install breaks connection to grub on EFI partition--TW rescue doesn't rescue??


I’ve got a multi-boot set up on two HDs with a number of OSX partitions and some LEAP’s and some TW’s and some Gecko’s just to keep it interesting. A couple weeks back I installed the latest OSX system 10.13 and as it has in the past, OSX doesn’t play well with others and it broke grub . . . . So I went through my usual “repair” disks, SuperGrub2, Boot-Repair, and RescaTux . . . and this time it seemed like RecscaTux was able to get my TW partition on my newer HD to load and one of the older LEAP’s on the older HD, but not all of them.

So I searched through the forum a bit and found a thread for “grub-customizer” and I installed that, but, as with the others it can’t seem to “find” the efi partition, in this case “sda1” . . . . I tried the “grub2-mkconfig -o /boot/grub2/grub.cfg” and it finds the TW kernels, but then reports “/boot/efi/efi/opensuse” “not found” . . . .

I found this thread which is not too far down in the list https://forums.opensuse.org/showthread.php/528262-GRUB2-Reinstall and I followed the commands from the #2 post . . . which shows how to use the “rescue system” to “mount” the root partition as well as the efi partition . . . took awhile to get to an open TTY shell, before that the “rescue” seemed to be going well, until it got to “download file_0010” which brought a 404 not found error and a blinking cursor, that blinked for about 45 mins before I figured it was “stuck” or the “rescue was lost” . . . tried to bring up an open TTY, and there was stuff “going on” on some of them but finally got to the basic “rescue” login, and when I did the various “mount” commands on “return” each line brought a “item can’t be found” type of response, I went through the whole list and each time it “failed.”

Back when I was in Ubuntu and had this problem we could use an editor to open the grub.cfg file and repoint the various efi and root partitions, but apparently from what I read in the SUSE forums, that isn’t done . . . . O, yeah, I used YAST to try to fix the Bootloader, but, that also “failed” . . . GRUB is not finding the efi partition and seems to be showing an empty partition as a “TW” or “LEAP” . . . maybe because it isn’t “seeing” the efi partition, all of the partition numbers are “off by one”??

I also did a number of upgrades on the TW system, including the kernel, and that also didn’t seem to get the efi partition to show up so that GRUB can list all approx 6 linux/OpenSUSE installs . . . . I have found in previous episodes that doing a fresh install of linux will “over-ride” the OSX damage to grub/efi, but, somewhat trying to save the time of nuke n pave if at all possible?? Any thoughts would be appreciated . . . .


If you press the option key at boot should get an option to select and efi file to boot from? If not boot from an efi install medium in rescue mode and then run efibootmgr -v to see what boot options are present, and set default as required.


Thanks for the reply, I’ll check on it tomorrow when I get a moment . . . and I’ll post back.


If your running multiple openSUSE’s then you could wind up over writing /boot/efi/EFI/opensuse if they exist on the same ESP (ef00 partition).

I’ve never used grub for osX, just press the option key when wanted to boot into it, else let openSUSE take control… but mine was only one osX and Tumbleweed…


Well, we’ll have to see how it goes later on today; I’ve done the edit grub.cfg thing one time previously with ubuntu and that “worked” and I’ve done the “nuke n repave” fresh install of a linux system numerous times to “override” the OSX damage to its fellow OSs . . . which seems “intentional” and “mean spirited” . . . when, as you mention, I also haven’t taken the time to connect grub to the OSX partitions, so I use the alt/option key when I want to select OSX, and, when grub is working right, on restart the various linux options show up, with one at the top as default boot . . . .

But, right now, the grub page is showing some options where the partitions are empty, and so forth . . . . I’ll try out your suggestions in a few hours and see what comes of it.


So I booted the TW install disk and got to a TTY “rescue” shell and logged in–running “efibootmgr -v” shows roughly

Boot current: 0000
            Boot order: 0001, 0080, 0000
            Boot 0000 *ubuntu HD (1, GPT) xxxxxxxxxxxx
            Boot 0001 *opensuse HD (1, GPT) xxxxxxxxxxxxxxx
                 "   0080 * Mac OS X  (PCI Root) xxxxxxxxxxxxxxxxxxxxxx
                  "   0081  * Mac OS X   "
                   "  0082  PCI Root (0 x 0 xxxxxxxxx
            Boot FFFF   PCI Root (0 x 0) xxxxxxxxxxxxxxxxxxxxx

Which is all a bit “odd” in that “ubuntu” was erased months back to make room for one of the LEAP installs, and now the “default” is TW, which is on the new HD, and that HD is in the “number one” slot, and also never had ubuntu installed on it. And, not understanding the various “OS X” options, as there are “two” OSXs on the old HD, and two on the new . . . so, as I was saying, all of the various “optional” systems are not showing up here, although many show up using the mobo alt key boot manager, they don’t seem to “work” via selecting one of the “EFI boot” disk options.

And, other question would be why the “boot current” is set for ubuntu, which is on HD2 (sdb according to GParted schematic) and then it shows “0080” for one of the OS X boots, but grub of course is only showing the LEAP & TW options . . . . I tried to “edit” the various options, putting “pluma” and “nano” in front of the “efibootmgr -v” but that brought “command not found” . . . . So, I’m needing some further data on how I could edit and then it seems like the efibootmgr is only seeing “one” HD and not the two, whereas previous to the OSX install GRUB would show both “sda” and “sdb” partitions of the various OpenSUSE systems??

Seems like something is being “missed” . . . and somewhere there is a “ubuntu” .efi file that is still showing up, even though that filesystem disk was erased and repaved, etc.


I have;

efibootmgr -v
BootCurrent: 0000
Timeout: 5 seconds
BootOrder: 0000
Boot0000* opensuse    HD(1,GPT,xxxx)/File(\EFI\opensuse\grubx64.efi)
Boot0080* Mac OS X    PciRoot(0x0)/Pci(0x1f,0x2)/Sata(0,0,0)/HD(2,GPT,xxxxx64800,0xc800000)
Boot0082*     PciRoot(0x0)/Pci(0x1f,0x2)/Sata(0,0,0)/HD(2,GPT,xxx,0x64800,0x71fa0d8)
BootFFFF*     PciRoot(0x0)/Pci(0x1d,0x0)/USB(0,0)/HD(1,MBR,xxx)/File(\EFI\BOOT\BOOTX64.efi)

ls /boot/efi/EFI/
boot  opensuse


sda      8:0    0 119.2G  0 disk 
├─sda1   8:1    0   260M  0 part /boot/efi
├─sda2   8:2    0    40G  0 part /
├─sda3   8:3    0    75G  0 part /data
└─sda4   8:4    0     4G  0 part [SWAP]

I only have openSUSE Tumbleweed on my old MacBook these days…

Unless you delete, old nvram entries remain… you can delete the non-present ub* one via;

efibootmgr -b 0 -B 0

So you need to mount your efi partition(s) in rescue mode, eg;

mount /dev/sdXN /mnt

ls /mnt/EFI

What files and folders are present? Repeat for your ESP’s as required after unmounting the previous…

 @192:~> sudo ls /boot/efi/EFI/
ls: cannot access '/boot/efi/EFI/': No such file or directory
@192:~> lsblk
sda       8:0    0 931.5G  0 disk 
├─sda1    8:1    0   200M  0 part 
├─sda2    8:2    0   234G  0 part 
├─sda3    8:3    0 619.9M  0 part 
├─sda4    8:4    0   234G  0 part 
├─sda5    8:5    0 619.9M  0 part 
├─sda6    8:6    0 261.3G  0 part 
├─sda7    8:7    0  48.8G  0 part 
├─sda8    8:8    0  48.8G  0 part /
├─sda9    8:9    0  97.7G  0 part /home
└─sda10   8:10   0   5.4G  0 part [SWAP]
sdb       8:16   0 931.5G  0 disk 
├─sdb1    8:17   0   200M  0 part 
├─sdb2    8:18   0 210.1G  0 part 
├─sdb3    8:19   0 619.9M  0 part 
├─sdb4    8:20   0 280.6G  0 part 
├─sdb5    8:21   0 619.9M  0 part 
├─sdb6    8:22   0 297.9G  0 part 
├─sdb7    8:23   0  45.6G  0 part 
├─sdb8    8:24   0    46G  0 part 
├─sdb9    8:25   0    46G  0 part 
└─sdb10   8:26   0   3.7G  0 part [SWAP]
sr0      11:0    1   112M  0 rom  /run/media/Zer0/openSUSE-Tumbleweed-NET-x86_64
@192:~> sudo efibootmgr -b 0 -B 0
BootCurrent: 0001
BootOrder: 0001,0080
Boot0001* opensuse
Boot0080* Mac OS X
Boot0081* Mac OS X
BootFFFF* ]

So, right now I have just time to try the commands from the TW Terminal, and some things worked, and some, like the “efi/EFI” command–did not work. The lsblk shows the two drives, and I ran the “-b” command and that seems to have removed the ubuntu item, so thanks for that.

As far as the “mount” from rescue method goes, I did try that following the other threads suggestions, and that didn’t seem to work . . . going through their whole list of suggestions . . . each line “failed” . . . . I’ll be back at this tomorrow pm . . . .


Based on past experiences I would gues your ESP’s are /dev/sda1 and /dev/sb1. You can confirm with;

gdisk -l /dev/sda
gdisk -l /dev/sdb

 gdisk -l /dev/sda
GPT fdisk (gdisk) version 1.0.1

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 250069680 sectors, 119.2 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 250069646
Partitions will be aligned on 2048-sector boundaries
Total free space is 2014 sectors (1007.0 KiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048          534527   260.0 MiB   EF00  EFI System
   2          534528        84420607   40.0 GiB    8300  Linux filesystem
   3        84420608       241707007   75.0 GiB    8300  Linux filesystem
   4       241707008       250069646   4.0 GiB     8200  Linux swap

Type ef00 is /dev/sda1 in my case, so this is the one you want to mount…

If you inspect both, hopefully one or the other contain the efi files… then it’s pretty easy to create the nvram entries via efibootmgr.

@MalcolmLewis: So I checked the “gdisk” from the TW booted system Terminal and as I figured it is “sda1” and “sdb1” that would contain or “be” the "EFI partition. Then I logged in as “root” and ran:

192:/home/ # mount /dev/sda1 /mnt
192:/home/ # ls /mnt/EFI
APPLE  boot  opensuse

And that’s what it shows . . . would that be different if I booted into the “rescue” terminal? Bit of a pain to get the “rescue” shell to show up, as various TTY shells seem to be running simultaneously “doing stuff” . . . seems to take a few minutes to get the “rescue” shell to become available???

Doing it this way as “root” seemed to work, whereas when I did it before from rescue it did not bring anything back, here it shows “APPLE” “boot” and “opensuse” . . . which must be “directories”???

And, now, I guess if I have to “unmount” sda1 I would run

                                                                                                 umount /dev/sda1 /umnt

??? Or vice versa? I haven’t done this “mount” and then “unmount” process before . . . .



To unmount either device or mount point;

(make sure your not at the mount pint)


umount /dev/sda1

umount /mnt


OK, thanks for those commands, I searched around on google and nothing “clear” showed up on how to do that . . . just on how to “mount” . . . . So I ran your suggestions, and got

# cd
192:~ # umount /dev/sda1
192:~ # umount /mnt
umount: /mnt: not mounted.

So, I’m assuming sda1 is “unmounted” . . . but, what about the data from the “ls /mnt/EFI” from the mounted sda1 item? Would that be it for the info that we could see?? Now that sda1 is unmounted I will run “sdb1” and maybe that will show something more??

Edit: ran that and it shows

192:~ # mount /dev/sdb1 /mnt
192:~ # ls /mnt/EFI
APPLE  boot  openSUSE  ubuntu


So now/how to figure out which is which… :wink:

You have an openSUSE and an opensuse on two different esp’s…

Since you don’t have ub* anymore you could delete that directory, now need to see what files are in the opensuse/openSUSE directories, unless you can think which OS installed in which esp?

If you run the following command to identify which disk is using your entry 0000

efibootmgr -v

Compare the PARTUUID against the efi 0000 entry, which disk (sda1 or sdb1)?


Hmmm . . . I tried to delete the “ubuntu” in sdb by mounting and then trying that -b -B gambit . . . said “not found” or something. as far as the UUID numbers and the choice of two opensuse or OPENsuse . . . ?? None of the numbers seem to match the “Boot current: 0001” option of:

# efibootmgr -v
BootCurrent: 0001
BootOrder: 0001,0080
Boot0001* opensuse    HD(1,GPT,7f39c61b-b9d1-4378-8478-a5e99ae6079d,0x28,0x64000)

I’m looking to match the number starting with “7f39c61b-” to the listed partitions UUID numbers? Some seem “close” but none are a match. My “guess” is that on grub it is showing a “LEAP” option up top, and all of the LEAP options are on sdb, the TW options are on sda. I’d have to restart to check what is showing on top of GRUB, as before, one of the grub options is pointing to the empty “sda6” partition, which boots to nothing. I was trying to get “sda7” as the top choice to go to TW . . . . Have a couple other things to do right this moment though . . . .


OK, so sounds like easier to delete the current 0000 one create some new ones… (see efibootmgr --help for all the commands…)

efibootmgr -b 1 -B 1
efibootmgr -c -d /dev/sda -L "openSUSE sda" -l "\\EFI\\opensuse\\grubx64.efi"
efibootmgr -c -d /dev/sdb -L "openSUSE sdb" -l "\\EFI\\openSUSE\\grubx64.efi"

Reboot, press the option key and should see two efi entries to boot from?


Thanks for those commands, however discretion is the better part of valor . . . if I restart and hold no key I get to a grub menu listing some, but not all of the numerous opensuse & OSX options. If, on restart I hold the option key, that goes to the apple boot manager and that shows more of the disks, the three OSX options, and 4 or 5 opensuse LEAP options, but going the option key way is right now the only way to get to OSX; AND there are now two “EFI boot” options that show there, but, from recall, neither one of them works to boot anything . . . .

So, the problem with multi-boot is there are a lot of things to boot, not sure if I/we can confirm the differences of where “opensuse” and “openSUSE” reside? I didn’t post the “blkid” data to try to save “space” . . . I think you are trying to make two new .efi files, but not sure what that will do? Is this a “wipe” of the existing grub files, and then we are just putting “opensuse” in “sda” & “openSUSE” in “sdb” as a way of starting fresh with grub?? And on reboot, the grub “analyzer” will find all of the many partitions??

I’m just trying to understand more what the goal is . . . and usually reading the “man” pages doesn’t provide the “what is this going to do” in a way that makes sense–it usually just seems like reading a dictionary to learn how to write, etc??


No, nothing is changing on the disk, or files, it’s the BIOS nvram contents we are adding via efibootmgr.

To boot via efi, two things are looked for a gpt disk and on that gpt disk a partition on type ef00, if these exist check the nvram for an entry to boot from, it then hans of to the efi file which then heads off to /boot directory for the grub files…

So if your getting to grub, one of the entries is working… if the UUID’s don’t match…then not sure.

Can you post the full output from both blkid and efibootmgr -v output. Also the full file listing (ls -la) from the boot and opensuse/openSUSE directories on sda1 and sdb1 to compare filenames sizes and dates.


Thanks for the details . . . I had most of that data on the terminal, but then I went through a bunch of restarts to try to see what was where, and learned a few things, but, then it doesn’t exactly make sense how it’s “working” . . . . So, I’ll either post that stuff or try to do those commands, but, busy day tomorrow . . . . I’ll get back to it . . . .



This is the output from what should be TW on sda . . . have to reboot to sdb partition to get “ls -la” ??? Later today . . . for now:

Zer0@192:~> su
192:/home/Zer0 # ls -la
total 176
drwxr-xr-x 22 Zer0 users  4096 Nov 27 18:20 .
drwxr-xr-x  5 root root   4096 Nov 22 02:32 ..
-rw-------  1 Zer0 users   828 Nov 27 15:51 .bash_history
-rw-r--r--  1 Zer0 users  1177 Oct  2 16:55 .bashrc
drwxr-xr-x  2 Zer0 users  4096 Oct  2 16:55 bin
drwx------ 20 Zer0 users  4096 Nov 27 14:45 .cache
drwx------ 14 Zer0 users  4096 Nov 27 16:02 .config
drwxr-xr-x  2 Zer0 users  4096 Oct  2 16:58 Desktop
drwxr-xr-x  3 Zer0 users  4096 Oct  2 17:03 Documents
drwxr-xr-x  2 Zer0 users  4096 Nov 26 09:23 Downloads
-rw-r--r--  1 Zer0 users  1637 Oct  2 16:55 .emacs
-rw-------  1 Zer0 users    16 Oct  2 16:58 .esd_auth
drwxr-xr-x  2 Zer0 users  4096 Oct  2 16:55 .fonts
drwx------  3 Zer0 users  4096 Oct  3 07:28 .gnupg
drwxr-xr-x  2 Zer0 users  4096 Nov 24 17:38 .gphoto
-rw-r--r--  1 Zer0 users    73 Oct  2 16:55 .i18n
-rw-------  1 Zer0 users  8056 Nov 27 18:20 .ICEauthority
-rw-r--r--  1 Zer0 users   861 Oct  2 16:55 .inputrc
drwx------  3 Zer0 users  4096 Oct  2 16:57 .local
drwx------  5 Zer0 users  4096 Nov 23 11:26 .mozilla
drwxr-xr-x  2 Zer0 users  4096 Oct  2 16:58 Music
drwxr-xr-x  3 Zer0 users  4096 Oct  2 17:03 Pictures
drwx------  3 Zer0 users  4096 Nov  4 14:16 .pki
-rw-r--r--  1 Zer0 users  1028 Oct  2 16:55 .profile
drwxr-xr-x  2 Zer0 users  4096 Oct  2 16:58 Public
drwxr-xr-x  2 Zer0 users  4096 Oct  2 16:55 public_html
drwx------  2 Zer0 users  4096 Oct  2 17:45 .ssh
drwxr-xr-x  2 Zer0 users  4096 Oct  2 16:58 Templates
drwx------  4 Zer0 users  4096 Nov 27 14:45 .thunderbird
drwxr-xr-x  2 Zer0 users  4096 Oct  2 16:58 Videos
-rw-r--r--  1 Zer0 users  1951 Oct  2 16:55 .xim.template
-rwxr-xr-x  1 Zer0 users  1112 Oct  2 16:55 .xinitrc.template
-rw-------  1 Zer0 users   128 Oct  2 17:32 .xsession-errors-:0
-rw-r--r--  1 Zer0 users 36738 Nov 24 17:48 .y2log
-rw-r--r--  1 Zer0 users   282 Nov 24 17:48 .y2usersettings
192:/home/Zer0 # efibootmgr -v
BootCurrent: 0001
BootOrder: 0001,0080
Boot0001* opensuse    HD(1,GPT,7f39c61b-b9d1-4378-8478-a5e99ae6079d,0x28,0x64000)/File(\EFI\opensuse\grubx64.efi)
Boot0080* Mac OS X    PciRoot(0x0)/Pci(0x1f,0x2)/Sata(2,0,0)/HD(4,GPT,7420b4c3-007e-4b98-b566-eaa4ebf5e403,0x1d5a9f00,0x1d40da70)
Boot0081* Mac OS X    PciRoot(0x0)/Pci(0x1f,0x2)/Sata(2,0,0)/HD(4,GPT,7420b4c3-007e-4b98-b566-eaa4ebf5e403,0x1d5a9f00,0x1d40da70)
Boot0082*     PciRoot(0x0)/Pci(0x1f,0x2)/Sata(2,0,0)/HD(4,GPT,7420b4c3-007e-4b98-b566-eaa4ebf5e403,0x1d5a9f00,0x1d40da70)
BootFFFF*     PciRoot(0x0)/Pci(0x1f,0x2)/Sata(3,0,0)/HD(1,GPT,36faabea-42fb-40d1-b88b-fb254febf542,0x28,0x64000)/File(\EFI\BOOT\BOOTX64.efi)
192:/home/Zer0 # blkid
/dev/sda1: LABEL="EFI" UUID="67E3-17ED" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="7f39c61b-b9d1-4378-8478-a5e99ae6079d"
/dev/sda2: UUID="632a31b3-7430-3c28-a992-c92271adfa58" LABEL="1Macinto" TYPE="hfsplus" PARTLABEL="1Macinto" PARTUUID="3447e9e0-204a-414f-a226-9f19fa88ef29"
/dev/sda3: UUID="1a310fad-e2fe-3a5b-a264-95c1669cca26" LABEL="Recovery HD" TYPE="hfsplus" PARTUUID="a326238f-c7d8-46f9-a734-357e51125980"
/dev/sda4: UUID="93f0ad8c-baed-3a31-8811-56b4a5cc6765" LABEL="2Macinto" TYPE="hfsplus" PARTLABEL="2Macinto" PARTUUID="7420b4c3-007e-4b98-b566-eaa4ebf5e403"
/dev/sda5: UUID="11b8a168-b278-3d38-8df7-daee4fec3d35" LABEL="Recovery HD" TYPE="hfsplus" PARTUUID="618fbd06-c98c-4a41-b268-eaf839f5e8d5"
/dev/sda6: UUID="4bc32144-c9ad-3c87-9b64-44e2f89dd31b" LABEL="3Linux" TYPE="hfsplus" PARTLABEL="3Linux" PARTUUID="6338840f-e675-49aa-a1be-578801195095"
/dev/sda7: UUID="1f3b03ef-9729-4d0f-8204-036adebde082" TYPE="ext4" PARTUUID="46d32a98-d9ef-4b37-b535-fbca90902517"
/dev/sda8: UUID="c6795cc7-5a44-4e1e-969d-28389e8c8c67" TYPE="ext4" PTTYPE="dos" PARTUUID="481536f7-6b9e-42a1-a2c2-c32e6efae3d3"
/dev/sda9: UUID="64c5dba2-bacd-4459-9904-6bda0fbe24e7" TYPE="ext4" PARTUUID="16858b01-4a16-4123-936d-73b985d1cb09"
/dev/sda10: UUID="d1c6e7f1-cb1b-4d28-ac0b-9c3b0d112ef5" TYPE="swap" PARTUUID="0fd89fb8-5385-4de4-9cf1-e5e300f8958a"
/dev/sdb1: LABEL="EFI" UUID="67E3-17ED" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="36faabea-42fb-40d1-b88b-fb254febf542"
/dev/sdb2: UUID="101f0c22-51eb-3de9-8b2c-71994769c98b" LABEL="MacintoUno" TYPE="hfsplus" PARTLABEL="Untitled 1" PARTUUID="87366958-562e-4c46-bd7e-7ff0c69f65ab"
/dev/sdb3: UUID="7fe5967b-c9a3-3bda-bac2-b082ec930c5e" LABEL="Recovery HD" TYPE="hfsplus" PARTLABEL="Recovery HD" PARTUUID="b918c071-3c00-4d0f-a919-1c9750b077a4"
/dev/sdb4: UUID="ea62cdd6-c700-3668-b872-850e9aa03865" LABEL="MacintoDos" TYPE="hfsplus" PARTLABEL="MacintoDos" PARTUUID="ef3a76a2-921c-424a-a3c4-38c1bd9b8cce"
/dev/sdb5: UUID="231a3e98-f8c1-3021-9761-9ffd2e0a25a0" LABEL="Recovery HD" TYPE="hfsplus" PARTUUID="830893e4-4c7f-45af-b7e6-2801995fc8a4"
/dev/sdb6: UUID="9a13b42f-9b6d-34cf-9dd6-fe427574b2f1" LABEL="MacintoTres" TYPE="hfsplus" PARTUUID="fa6952ef-93bd-438e-b74b-263725630595"
/dev/sdb7: UUID="1ef871cc-3c9f-4fee-ba75-ac8fd9c40c11" TYPE="ext4" PARTUUID="43a85571-d16d-4142-a581-85e74b5c2200"
/dev/sdb8: UUID="42c78901-85a4-40f3-95ce-d2e3ba53e5c4" TYPE="ext4" PARTLABEL="Windows_NTFS_Untitled_2" PARTUUID="7f47c88e-6463-4640-b711-36ce7a4e1514"
/dev/sdb9: UUID="9c939b5e-d872-4e72-832a-bf764d7108dc" TYPE="ext4" PARTUUID="dfa33e17-6723-46c8-a137-60a18aca7e1e"
/dev/sdb10: UUID="ea799dfc-04eb-47f0-a7e8-b645cae8daab" TYPE="swap" PARTUUID="f17fc88f-6eb0-4229-b925-f49320ee86a3"
/dev/sr0: UUID="2017-06-01-16-47-54-00" LABEL="openSUSE-Tumbleweed-NET-x86_6400" TYPE="iso9660" PTUUID="5d2a6c32" PTTYPE="dos"
192:/home/Zer0 # 

Thanks, kindly . . . no screaming rush on it, as the next 7-9 hours will be occupied with busyness . . .


You need to mount the sda1 as /mnt and cd into the directories and run the ls -la command, then repeat for sdb1 :wink: