OST Freezing Completely


I had mentioned this is another post and it was recommended that I start a fresh thread for this issue. I’m not sure where to post this exactly but I was told to list my hardware and thought perhaps here. If it’s better in another location, please feel free to move it or let me know and I can delete and repost.

I installed OpenSUSE Tumbleweed about a week ago. I’ve noticed that on average, about once a day, the entire system will freeze or lock up. I can’t repeat it. It’s not when something specific is happening. Sometimes, nothing is actively happening. I’ve also had it lock up when the only thing the unit is doing is “serving” media (and of course, that comes to a complete end when this happens). I’ve tried multiple key strokes to try to get a tty session started (ctrl alt F2/F3/F1 were the main recommendations, if I remember correctly) or anything that will give me some way into the system. Nothing works that I’ve tried. The only thing I can do is to use the power key (long press) to force a shutdown, then power on the unit again. I can’t seem to pinpoint what’s happening. I’ve tried a few journalctl commands but I can’t ever seem to view the log at the time of the lockup I’m sure it’s a deficiency on my side that I can’t navigate (for lack of a better word) to the journalctl section that shows the right time frame or time stamps.

I’m running the latest OpenSUSE Tumbleweed (and kept the packages up to date) using KDE. My hardware is:
Intel NUC 8i7BEH
Intel Core i7 8559u 4 core/8 thread processor
16gb RAM
Intel Iris 655 Graphics
m.2 NVMe SSD 512gb (this is a recent addition and where OpenSUSE is installed)
2.5” SATA SSD 256gb (this is what I’ve used for nearly two years and have had Mint installed on this SSD)
I also have various external HDDs - not that it would make a difference on this issue
8gb of the RAM is new. Intel specifically said that it didn’t matter if the make/timings/speed, etc were the same on the memory that it should just match the RAM amount of the first stick for dual channel speeds. Having said that, I did match the RAM amount and speed of DDR4 2400.
Oddly, Mint hasn’t shown any of these issues. I only say that because I would have thought that if it were a graphics/video cable or something hardware related, that both distros would be equally affected. I also wondered if it might be an issue with KDE/Plasma itself. I don’t want to run Mint, I want to run oST which is why I’m working to try to figure it all out.

If you need any more system info or specs, please let me know.

Any help would be most appreciated. Thank you SO much!

My new OpenSuSE Leap 15.2 install on a new hardware system also had ‘freezes’ at all kinds of strange times. Usually I could still move the mouse pointer around, but nothing else was happening. Attempting to go to a console (`Ctrl-Alt-F2’) allowed me to enter the username, but not the password. I couldn’t find a very helpful log in OpenSuSE but…

…a Ubuntu 20.04 LTS install on the same machine, which had ‘updated’ over the Internet during the install, had even a worse time, failing to reach the login screen. The Ubuntu log showed some sort of NVME error.

Problems with Ubuntu and some Samsung NVME drives are described on https://askubuntu.com/questions/905710/ext4-fs-error-after-ubuntu-17-04-upgrade/906105#906105It appears that my NVME drive, a Kingston SA2000 1TB enters some sort of deep low-power state from which it will never recover.

Adding the kernel parameter


fixed the problem.