oss 11.3 does not update

I am doing a test run on Open SuSe 11.3 and really like the looks. I have used synaptic, deb pkgs etc. for the last 5 years. Gave up on redhat rpm’s and mandrake stuff years ago.

If I could get the oss package manager to work Yast looks like an easy alternative for me.

Problem: Upon boot I receive the info message “updates available” . When the machine attempts to update, it always fails. I tried yast, package manager, etc. they all fail with the error “(-30987)” RPM failed requested page not found.

It looks like I do not have the required repos enabled, so I enabled each listed one at a time and tried to load software (vlc). No success.

If someone could point me to the needed repos it would be really appreciated.

So I am thinking I would open up YaST / Software Repositories. If you have added anything since the install, this might be the problem. I would pick the bottom right button that says “Refresh” and pick “Refresh All AutoRefreshed” If you loaded openSUSE from a CD, I might select the CD entry, and disable it first. You can get all of the standard repositories that are added for you at the following Link:

Package repositories - openSUSE

You could remove everything and start over if something is messed up. Once you have repositories and they give no errors, then the update should work.

Thank You,

Bear in mind that OSS is one core repository and may not have many updates. If you want to update all your repositories at once, open YaST>Online update>View and click on repositories. A repositories tab will appear with @system (all your current packages) as the first choice. Select Package>All in this list>Update if newer and you can get all the updates in one fell swoop. (There are also zypper commands to do this). I find there is something most weeks when I do this. For this to work you need to keep all your repositories active, something not recommended by all users but something which has not so far caused me problems, perhaps because I do not have an adventurous selection of repositories.

Thanks for trying guys, but…I disabled all repos except “updates” and got failed…

Subprocess failed. Error: RPM failed: error: package dhcp-4.1.1.P1-3.2.i586 is not installed

Don’t really know what this means.
With all repos enabled I get the same error. BTW I did select ignore along the way…If I select ignore now I get the same RPM fail error again.

How can I install dhcp and get back to the original failure???

You can find the package dhcp-4.1.1.P1-3.2.i586 on the following web page:

software.opensuse.org: Search Results

I suggest that you click directly on the rpm package, instead of using the 1-click install option. Once the file is downloaded (normally in the folder /home/user_name/Downloads) open up a terminal session like konsole and execute the following commands:

cd ~/Downloads
rpm -ivh dhcp-4.1.1.P1-3.2.i586.rpm

This should directly install this file and does not use YaST for the process. The dhcp file is normally loaded in your default installation and indicates something went wrong during the install process, as might be caused by a bad installation disk or other disk issue. See if this helps you in any way.

Thank You,

@James: I tried direct install of the dhcp rpm. and got:

# rpm -ivh dhcp-4.1.1.P1-3.2.i586.rpm
error: Failed dependencies:
        libc.so.6(GLIBC_2.1) is needed by dhcp-4.1.1.P1-3.2.i586

Looks like I got more problems, or created problems by clicking ‘ignore’ randomly… Will take your advice and reinstall. I am running 11.3 on a vbox and all looks great except no software updates. Will more carefully look at errors after clean install and post back. Just call this ‘ended’ for now.

ps: may not get back for a week. we are headed for Tunica (n. Ms.) for reunion in Tn. I have to install new tv in old moto home before this weekend.

Update: Re-installed 11.3. First boot;popup (kupdate applet) notice that updates available. I clicked on that and it hung up. Tried to open yast and it burped on ''something locked by process 91??, etc." Instead of relearning how to kill pids etc. I re booted and opened yast, selected on line update, and it ran to completion.

Would mark this thread solved if I knew how… Blame it on the operator.

I like to hear that a problem is solved no matter why or how. Happy to hear of your success.

By the way, when you first start openSUSE, the update applet will try to run. If you open Software Management or Repositories, just before it starts, you can get an error from the update applet. The same thing will happen the other way as well. If the update applet starts first, you can get an error message from YaST Software Management or Repositories as only one of them can be used at the same time looking at the single software database.

I normally wait a little while after openSUSE is started, to allow the update applet to run, then I can go into the Software Management without getting an error messages.

Thank You,