osprober does not detect all other Linux versions

I installed OpenSuse 12.3 and was not able to see my Fedora system listed in the grub.cfg file. Fedora is installed on this same system, along with Ubuntu.

However, with Fedora, OpenSuse 12.3 is listed in the Fedora version of grub.cfg.

With Fedora 18, during the beta and release candidates, an updated version of osprober was distributed. Fedora shows all operating systems.

Perhaps its time for a fork of the Fedora source be used to update the Suse version.

Mint showed Fedora, but not Suse.

I write software and that is why I have multiple versions of operating systems. I test live, not via vm systems.

And your bug report number is … ?

It also happend to my dual-boot of win7 and openSUSE 12.3. I found os-prober of this version could not detect any foreign OS automatically, unless the partition was mounted by hand. Then I run grub2-mkconfig to generate the proper grub.cfg to replace the one in /boot/grub2 directory. Now it works fine.

Look at /etc/default/grub. There is an entry GRUB_DISABLE_OS_PROBER. If it is set to “true” change it to “false”.