osc revision not working

I tried to use osc revision to take older revision of my package. But it doesn’t work. I am a novice, so need some help-
Here is how I did it-
Approach 1:
kusvii@kusvii-desktop:~$ osc co --revision r1 home:kusvii pckg1
I get this message “your revision ‘r1’ will be ignored” and the latest version of pckg1 is checked out

Approach 2:
I check out the latest of pckg1 and update it with earlier revision like this
kusvii@kusvii-desktop:~/home:vkusvii/pckg1$ osc up -r r1

I get this error message -

*Traceback (most recent call last):
File “/usr/bin/osc”, line 21, in <module>
r = babysitter.run(osccli)
File “/usr/lib/python2.6/dist-packages/osc/babysitter.py”, line 50, in run
return prg.main()
File “/usr/lib/python2.6/dist-packages/osc/cmdln.py”, line 308, in main
return self.cmd(args)
File “/usr/lib/python2.6/dist-packages/osc/cmdln.py”, line 331, in cmd
retval = self.onecmd(argv)
File “/usr/lib/python2.6/dist-packages/osc/cmdln.py”, line 447, in onecmd
return self._dispatch_cmd(handler, argv)
File “/usr/lib/python2.6/dist-packages/osc/cmdln.py”, line 1177, in _dispatch_cmd
return handler(argv[0], opts, *args)
File “/usr/lib/python2.6/dist-packages/osc/commandline.py”, line 2963, in do_update
if not checkRevision(pacs[0].prjname, pacs[0].name, rev, pacs[0].apiurl):
File “/usr/lib/python2.6/dist-packages/osc/core.py”, line 4279, in checkRevision
if len(revision) == 32:
TypeError: object of type ‘NoneType’ has no len()

Can anyone help me in this?

I think, you should use ‘-r 1’ (without ‘r’).

Worked Thanks:)

I am using obslightgui.
when I do commit, it says "commit fails because osc locav ver “-1” does not match with obs ver “1"”
error image attached.

error image attached

No images we see. Please, upload the image somewhere and post the link.