OSC behind a firewall

Is there any way to specify a proxy for OSC to use?


So … the question is old, but I had the same problem and it takes me some time to fix it, so I describe what I did… because it seems that not a lot oft people fix it yet//

My problem was that I’m behind a https- proxy (and was not allowed do go around it) and in this case, the python-lib urllib2 is the main problem, because it can not deal with it.

So first you have to patch the urrlib2 (and the httplib) - the patch can be found here:
Issue 1424152: urllib/urllib2: HTTPS over (Squid) Proxy fails - Python tracker

Next, you have to comment out some lines in the osc-lib, in the conf.py file
(I found the file in /usr/lib/python2.6/osc/conf.py)
comment out lines 204 - 207

if ‘https-proxy’ in os.enviro:
del os.environ[https-proxy]
if ‘HTTPS-PROXY’ in os.enviro:
del os.environ[HTTPS-PROXY]

I did it that way and now everything works fine…

I got to retrigger this issue: I’m also trying to connect to OBS using the osc script (OpenSUSE 11.2). If I look at the patch above, I don’t want to patch some packages and destabilize my system for that.

Playing around with setting and unsetting proxy environment variables did not have any effect, but I don’t want to patch some packages and destabilize my system for that.

Is there a way to use osc behind a proxy WITHOUT patching of some system packages?

Yes, same problem here. Could someone please help?


OK, I found the problem. This works fine using OSC version 0.125 on Ubuntu 9.10 (but not the version provided in the ‘universe’ repository of Ubuntu 9.10). The trick was to define the environment variable ‘https_proxy’ as:

% export https_proxy=$http_proxy