oS11 RC1 - opensuse updater

Please, can you tell me what applet/application should be used for automatic checking of new updates, specially patches and security?

Thank you,


If you’re familiar with SuSE/openSuSE, it’s still Online Updater (which can still be configured to run in the background). To configure it, run (in a terminal window):

sudo YOU

I started with 11.0 RC1, but did upgrade to the GM bits yesterday (thank heaven for CHSI Blast!). Because 11.0 RC1 and Vista refused to play nice together, I’ve gone really old-school and have them on separate hard drives (not merely separate partitions) and am using the boot-selection switch in the BIOS to switch between the two.

I’ve used openSuSE before, but sheered away from it due to time constraints imposed by other projects (including helping shake down Wubi, Ubuntu’s slick Linux-within-Windows installer) and openSuSE’s failure to support certain hardware I had at the time.

There’s actually one running in the RC, but it crashes after every login.
Now there are quite a lot of updates in the OSS and NON-OSS repos,
to get them do as follows:

Goto Yast>Software>Software repositories, disable the DVD-repo,
enable Automatically Refresh for the OSS and NON-OSS repos and
then click the Refresh button. That finished open up a terminal,
su to root and issue the following command:

    zypper dist-upgrade -l

Now beware, it was a whopping 1+ GB this morning, so you’ll need
a fast and stable connection. All finished, reboot and you’ll
have an updater running, though this one won’t show up in the
panel until there are updates.

This worked for 32-bit, but it shouldn’t be different if you
are on 64-bit. And what you get should be very close to
the final release.

Yup; it was indeed Rather Large (over a thousand packages!), and it changed so much (included was a kernel update) that I had to rebuild my Catalyst drivers (I’m using the closed-source Catalysts for a reason).

One thing I got seriously addicted to with openSuSE 11.0 RC1 was Compiz (and Compiz-Fusion); however, because of my graphics card (X1650PRO AGP), I couldn’t use the open-source driver (no 3D support for R5xx yet). However, if you follow the linked walkthrough on using the Catalyst drivers in 10.3 (you have to use the hard way, as beta builds aren’t supported targets, naturally), you’ll have 3D/DRI (and thus Compiz) support in jig time (and with surprisingly little effort). However, the hard way isn’t really that hard (I’ve had to do more fiddling at time to get hardware working in Windows). In fact, this is the first distribution I’ve been able to get any DRI support working in with this particular ATI card (and that includes the last three versions of Ubuntu). Once you see what you can do with Compiz, you’ll wonder why you chose to go without!

I’m waiting for the official repos for 11 to go live after this update.

Hi all:
I have just finished a download of 1+GB update of 11RC1. My question is:
Could I safely reboot my system now? Or is there any reconfiguration required before rebooting?
I mean do I have to rebuild the “initrd” or edit menu.lst?
I am a bit apprehensive now to shutdown the system lest not being able to get back on.
Thank you in advance!

I just rebooted my system and all went smoothly, but do note
that’s my system, which was pretty much plain vanilla at that
moment, and we are on a beta!
So go give it a try!

If you just updated from factory your running the gold internel release. Assuming no major bugs pop up, you are most likely running final release.

same here - all went well

… again … and again … and again … and again, and if you say cancel, it even comes harder. For the moment, I deactivated the Packagekit Update Applet.

Oh yes, it happened after updating it (and the kernel to - two hours ago.

Or better to say for understanding, after I was asked the third time for the same gpg-key, I said cancel, went over to my chincilla, and coming back to the pc, I had more then 30 questions for the gpg-key, and more coming.

New to openSUSE here…

I had some initial trouble with the package management system… couldn’t run yast, for instance. Googled my error message, and as per Accessing The Package Management Failed - SUSE Forums, I deleted in /var/run/zypp.pid and then that worked.

I’m running your suggestion (zypper dist-upgrade -l), and it seems to be going fine.

Moreover: I’ve noticed there’s a ‘Update System’ under ‘More Applications.’ This looks like a GUI for the same thing. However… this asks me for the root password to authenticate, and won’t accept the password!

I’ve tried changing the root password. No luck. This displays a different kind of authentication dialogue than anywhere else; I’m sure this has something to do with it.

Is this a known bug? If not… how can I report it?

If you use a novell.com Account to login the Forum then you can use the same account to report a bug in bugzilla.novell.com

I did reboot my system after that very long 1+gb update. It booted ok with a new kernel. However, it messed up my menu.lst file which, I manually edited it to enable the booting of my suse 10.3 on another partition. But the main problem so far is that the konqueror crashes right before start, it does not open and i get the crash message dialog screen.

I just installed opensuse 11 rc1 and then upgraded all packages. I’m running KDE4 and it’s updated thinngy in the tray won’t work properly. After a while it shows question mark and asks that if I want to install upgrades, I choose yes and it tries to configure updatesource again, it’s already configured and working. If i choose to check updates it does it and currently as there is no updates available it won’t offer them, but again after a while it asks that if I wan’t to install them.
Is there a quick fix or do I need to wait update?

I just ran the huge update to RC1, didn’t go too well for me however. On reboot my system just goes to a black screen and sits there. It stops when it gets to an area of PCI setup. Gladly the installer is fast and pretty pleasant so I just reinstalled. I’m probably going to avoid updating again until I install the full release, hopefully won’t be a problem there.

Solved my problem with the failing update. When I installed I had a USB hard drive plugged in, for some reason the installer thought it was a good idea to put boot info on this. Which is why rebooting kept failing.

Since installing without the USB drive everything seems stable and the update worked.

You said “asking for safety gpg-keys”; wouldn’t that just be some key that you can download from somewhere official, and it helps verify every package?