os11.2 install failed, how to proceed?


Tried to install 11.2 over suse 9.1. It is a 17gb partition w/ 1gb swap. I used the CD to install and it went out to various sites and downloaded a lot of packages. The screen said > 2hrs to go so I left the room & let it run. I came back several hours later and the screen was blank, no action from keyboard/mouse so I powered down.

Booting of 11.2 seems to hang with the initial boot screen displayed.

Booting to failsafe goes as far as:

Loading required kernel modules
Then it adds the swap file
Sets the time to the hardware clock
rtc0: alarms up to one day, 242 bytes nvram, …

And it stops there.

How should I best proceed? Try the dvd download instead (I don’t have a dvd burner so would have to use someone else’s computer)? Or restart fresh install? The grub loader doesn’t have a repair option which existed in the v9.1 kernel I was using.

Thanks, Jon

6520302 wrote:
> How should I best proceed?

i think that depends on what you meant by “Tried to install 11.2 over
suse 9.1”…

that is, after booting from the 11.2 CD (you don’t say if it is the
KDE or GNOME Live CD, or ???) did you do this
http://tinyurl.com/yajm2aq before install attempt?

then on the second step after beginning the install process (first is
language select and license agreement) you are asked to select between
“New Installation” or “Update”? which did you choose?

and, did you leave “Use automatic configuration” checked, or not?

actually, i kínda wonder if you happened to notice below the
“Download” button (on the download page
http://software.opensuse.org/112/en) the section of instructions
titled “How to Proceed” and its link to “Step-by-step installation guide”

i ask all these silly questions because there is no upgrade path to
11.2 from any former S.u.S.E., SUSE or openSUSE system other than
openSUSE 11.1, cite: http://en.opensuse.org/Upgrade

if you selected “New Installation” as is directed by the “Step-by-step
installation guide” then you did a drive format and install, and it
should pretty much work…without the data you had on that drive, or

but if you selected “Update” i wouldn’t have a clue what you have now…

on the other hand, google for “alarms up to one day, 242 bytes nvram”
gives almost 200 hits, were any of those useful?


Further to palladium’s suggestions, …noting the pc had 9.1 on it previous, makes me think this may be old hardware. Can you tell us anything about the hardware? CPU ? graphic card? RAM ? Note that old CD/DVD readers can be out of calibration, meaning they may fail to read properly during an install with a CD/DVD burned on a newer computer.


Thanks for the responses.

I did do a media check of the CD, it showed no problems.
The CD image I choose was the “network” selection, and I chose KDE as the gui since that is what my 9.1 install was. In light of my problems I’ll download the live KDE install instead and try that as new install.

On the 2nd step I chose ‘update’ rather than ‘new install’ because I figured it would overwrite the 9.1 install (I know there is no direct path to update 9.1) and more importantly, I am concerned about maintaining my option to have grub run from / rather than MBR in order to preserve an existing OS/2 partition. I took the word ‘update’ to mean update Linux when I guess it is more appropriate to say update the 11.x system. This morning I looked at log files on my system and there are indications that certain directories could not be found. Probably specific for 11.x that didn’t exist in a 9.x install.

My hardware is old, but I don’t think it is ‘too old’. It’s a Dell Dimension 3000.

Rather than continue with this reply to your queries I’ll just start all over again as it’s likly that the problem is that my choice of ‘update’ was inappropriate.

Rgds. Jon

Just be careful with the install and read the screens. Don’t blindly click next/continue.