OS11.2 and vmware?

I don’t know if this is a problem for non-vmware folks - I installed 11.2 under vmware 2.0 and it appears 11.2 already has vmwaretools built in - but I can’t figure out how to configure them… It always comes up in 800x600 resolution no matter what I do, and when I resize the desktop to native res (1920x1200) the fonts are several sizes too big. And all settings go away upon a reboot… Maybe vmware tools will uninstall under YaST? I remember that when configuring vmware tools, it asks for the default native resolution it should run…

EDIT: Just tried to remove openvmware tools via YaST, and it won’t let me (if you can believe it) - I was going to install vmware’s version which will let me set a default resolution.

openSUSE 11.2 does seem to include a version of vmware tools, but I believe that this is a minimal version and doesn’t include the tool that lets you change the dimensions of your guest machine window. However, you can install the proper version of vmware tools that comes with your vmware program. You need to install a few programs that vmware will use to build the tools, along with the tools themselves. See this thread for instructions. With the proper tools installed, you won’t have to mess with the resolution setting to get whatever window size you want, although I did have to go into a GUI configuration file (might have been “appearance”) and check the 96 dpi resolution box to keep the menu text in programs like openOffice write and Amarok from being overly large.

I successfully installed 11.2 as a guest on my Macintosh using Vmware Fusion 3.0. I believe it should also work under the previous version of Vmware, but I haven’t tried with it.

It might be graphics related. You could try to remove from the shell, i.e., boot to init 3 and use the ncurses yast version.

Thanks for the reply! Dont’ really know how to do ncurses… I have all the dependencies installed as I normally install my NVidia driver from source.

I guess you mean that I could log out and do a console logon - and from there do something, I’ll see if I can find anything about the “ncurses yast version…” Maybe I could just do an RPM ininstall somehow from a console logon?

OK, in ncurses it tried to load the “debug” version of openvmware tools, but I was able to tell it not to, but it still downloaded a new kernel (“default”) - then it went ahead and downloaded vemware-guest-kmp-default and the same thing but with “preload-”

Well, no matter what I do, YaST refuses to remove vmware tools. Sigh!
A “feature” of 11.2?

OK, maybe solved - I didn’t keep careful notes, but the version of vmware tools (the “debug” version?) seems to let the vmware-install.pl script modify it, rather than requesting I remove the existing version of vmware tools first. I ran that script and it seems to be doing the normal compile, and the tight host mouse-pointer integration is gone. So, I’m compiling it… and yes there’s the query of what screensize xorg.conf should use… hooray! Now rebooting the client… Hmmm… some strangeness, but at least it’s not coming up in 800x600 any more.


Yay! That seemed to work. I guess there’s a problem with removing openvmwaretools because of kernel dependencies. But after compiling and setting to 1400x1050 - it seems to work well. It seems faster than with the open tools, also.

I just got done installing OS11.2 in a VMware Player machine. I also did the normal install of the tools. It told me something already existed and asked about overwriting, which I told it yes. Works fine.

The debug, devel and doc packages of a software are not necessary to run the rpm-installed binary package, which is what we normal end-users do.

devel packages are needed if you are compiling the software, debug if you are a developer (I think, not my area of expertise) and doc packages use is obvious.

I’m surprised you had to install the debug package. I never had to, even when compiling stuff.