OS will only boot in text mode and shows errors

I am a new user and use opensuse for school projects. I’ve had problems with it since the beginning when the screen resolution was locked at 800x600. After installing nvidia drivers I can get into OS only in secure boot. Could anyone help me based on a picture of the error message I get when trying to boot into normal mode? As someone from my last thread asked, the fans do work.


Thanks in advance.

system: i7-8650h with intel uhd graphics 630
gtx 1060
18 GB ram

You have a dual graphics setup, a so called Optimus configuration. This won’t work with the NVIDIA drivers, unless you are able to disable the Intel graphics in the BIOS ( some laptops can ). If not, you should use suse-prime

Is this a specific case for OP’s computer? I am just curious because I have bumblebee working for Optimus systems (https://forums.opensuse.org/showthread.php/537906-Cuda-Nvidia-bumblebee-codecs-quot-safe-quot-way).

No. Bumblebee ( if that is still actively developed ) is another option the OP has.

Thanks for the suggestion. I already tried suse-prime but to no effect. You got any other ideas how to get the os to work? Im completely fine with it working just on the intel graphics.

To that end what I would try is keeping suse-prime, blacklisting nouveau, uninstalling nvidia drivers, and for good measure including nouveau.modeset=0 on kernel cmdline. If i915 wouldn’t load automatically I’d try it manually, though I’d expect suse-prime to be handling this. If it didn’t work, I’d report a suse-prime bug so as to get Stefan Dirsch (suse-prime maintainer) to look into it.

Hey, so I tried what you said. in recovery mode I blacklisted nouveau, uninstalled nvidia drivers and did the nouveau.nomodeset=0 and it looks like the system broke down completely. KDE wont load because of failure of drivers. Im completely lost. Any ideas?

Needless to say that I’m a total newbie when it comes to linux in general, so if you have suggestions I’d kindly ask you to explain it in more detail please. I have some important school work i need to finish before sunday so I’d be really grateful if you helped me with this problem.

You should be able to boot to a login screen or a black screen. If a black screen, wait a minute or two, then try Ctrl-Alt-F2. That should bring up a login prompt from which you can run text mode yast to remove the blacklisting and remove nouveau.modeset=0. This should reenable use of the NVidia GPU and Plasma as long as uninstallation of NVidia drivers was complete. It’s possible /etc/X11/ could still have xorg.conf or files in xorg.conf.d/ left behind and blocking the FOSS drivers. If NVidia driver uninstallation failed in any way, you might be forced to reinstall them or reinstall Leap.

Personally, as an active CUDA user, I would install bumblebee. I think it is still being developed. If you want to try it, I compiled my notes in the previous link I discussed.