os-prober not finding windows 10

I just did a fresh install of Leap42.2 with the root partition formatted as btrfs. The grub menu did not contain an entry for my Windows 10 system.

Both Win10 and Leap42.2 are installed as EFI. Lead is on /dev/sda8 and Win10 is on /dev/sdc3. There is a EFI partition on both sda and sdc.

I started going through backup to find the menuentry for Windows. I had to go back to a backup dated 04/21/2017.
The os-prober from that backup is dated 10/5/2016 and the grub.cfg is dated 03/21/2016.

I have added the menuentry to /etc/grub.d/40_custom as a work around, but os-prober still needs to be fixed.
I found some posts about a fix to os-prober in Tumbelweed, but that does not help Lead.

If you run os-prober what does it tell you? What does efibootmgr say?? (show your work)

Have you tried Yast-bootloader checking the prob for foreign OS box??

If you run os-prober what does it tell you? What does efibootmgr say?? (show your work)

Ray-AVA:~ # os-prober
Ray-AVA:~ # 
Ray-AVA:~ # efibootmgr
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0000,0003,0004
Boot0000* Windows Boot Manager
Boot0001* opensuse
Boot0003* CD/DVD Drive 
Boot0004* Hard Drive 
Ray-AVA:~ # 

Yes I tried the yast boot loader panel with the “Probe Foreign OS” box checked. The result was a grub.cfg with no reference to Windows 10.

Thinking that you installed openSUSE in legacy mode and Windows in EFI mode or vis versa. If so that won’t see each other to chain.

They are both installed in EFI mode as evidenced by the EFIvar output above and the datetime on the directory /sys/firmware/efi

Ray-AVA:~ # ls -ld /sys/firmware/efi
drwxr-xr-x 5 root root 0 Aug 15 13:55 /sys/firmware/efi
Ray-AVA:~ # uptime
 14:19pm  up   1:16,  1 user,  load average: 0.12, 0.30, 0.22
Ray-AVA:~ # who
ray      pts/0        Aug 15 13:53 (:0)
Ray-AVA:~ # last reboot | head -1
reboot   system boot  4.4.79-18.23-def Tue Aug 15 13:02 - 14:24  (01:22)    
Ray-AVA:~ # 

Show ls /boot/efi

Is fastboot off in Windows? that can make the file system invisible?

Are you using Dynamic disks in Windows? again makes it invisible