OS hangs after an hour or so of non-use, OpenSuSE 13.1 KDE, 64b

OpenSuSE 13.1 KDE hangs after an hour or so of non-use. The system is a quad-core desktop. I went into configure desktop → power management and unchecked everything. With about 5 minutes or so of non-use, the screen switches to the Gecko and beanstalk screen. At some point the screen goes blank. If I move the mouse after about an hour or so, the screen turns on, displaying the Gecko and beanstalk screen and nothing else. There is no way to return to the session. I’ve tried numerous key commands and eventually have to resort to pushing the reset button. Any help would be appreciated.

you can disable the screenlocker in (KDE)

configure desktop > Display and Monitor > Screenlocker

This will stop your screen blanking after a set period of time.

Hi Parthenolide,

I have a quad-core myself, but that doesn’t say much.
A dual-core should do the job as well.
I currently even still have an old 2nd PC with Pentium III (single-core),
which I use from time to time, that now has openSUSE 12.3 installed.

Even on the old PIII PC, the screen goes black after some time,
but I don’t have a problem returning to the session.

In your situation this seems logical.

You mean black, don’t you?

Which ones?
Did you try ctrl-alt-F1 etc. to at least get to a text console, login as root, and say ‘shutdown -h now’, for example?

Not good.

I’m not a guru, but if you would like to get help, then not only on this forum you’ll probably need to tell more about your system.

Which graphics hardware do you have?

Which BIOS or motherboard or brand PC (Dell, HP, Lenovo, …) do you have ?

In my eyes, your problem most probably is caused by eiter:

(1) a problem with the graphics hardware, or

(2) a problem with the drivers for that graphics hardware, or

(3) a problem with your BIOS dealing with power save, or

(4) an improper installation of openSUSE 13.1 - which in your case seems
less likely, since, based on the number of your posts and your join date
you seem to be a more experienced openSUSE user.

Good luck !

After turning off the screen locker the system now hangs showing the desktop screen.

I’m using a wireless Microsoft ergonomic keyboard and mouse. Sometimes after the system hangs, the mouse cursor moves, but there is no response when clicking, and the start menu doesn’t pop up when hovering. Resetting the mouse doesn’t help. Resetting the keyboard doesn’t help (the system doesn’t respond to ctl,alt, del; esc, are any of the function keys). The wireless system doesn’t use bluetooth, but some other proprietary standard. Pulling the dongle out and re-inserting it also doesn’t help.

I’m wondering if the system is hanging because its not responding to the USB ports. I tried to wake up the system with a usb mouse. That didn’t work, either.

This is not a major problem, just annoying.

On 2014-01-30 23:46, Parthenolide wrote:

> I’m wondering if the system is hanging because its not responding to the
> USB ports. I tried to wake up the system with a usb mouse. That didn’t
> work, either.

If you have access to another machine, leave an ssh session connected.
Look at the system time at that moment. If the ssh session also locks,
the problem is not the keyboard. You can try to restart the graphica
session, too.

Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

The hang ups are getting worse.
I wonder if there isn’t some kind of memory bleed issue, or some background program is hogging up too many resources.

A couple days ago, I was running just kontact, and Kinfocenter. The total memory in use started at 26% and slowly increased. After an hour or so of non-use, the total memory in use went to 96%, and the system was hung.
The system also seems to hang up when there are about 6 or more applications running. Sometimes if you just wait, the machine starts to respond, most times, its the reset button.

Right now I have kinfocenter, firefox and kontact running. 77% of the physical memory is in use, 12% is used swap and 9% is free. However, these were about the same memory usage before I opened firefox.

Thanks in advance for any help.

You could at least Ctrl-Alt-F1, login as root, and say ‘shutdown -h now’.

What graphics hardware are you using, and which drivers for it ?

You didn’t tell yet.

I don’t think the problem is with the graphics engine, but here are the specs as requested:

Graphics card:
AMD/ATI Barts PRO [Radeon HD 6850] Gigabyte Technology Co.

Vendor: X.Org
Renderer: Gallium 0.4 on AMD BARTS
OplenGL/ES version 3.0 Mesa 9.2.3
Kernel Module: radeon

version 11.0

Note that simultaneously pressing ctl, alt, and F1 does nothing. The system does not appear to be responding to the USB ports.

You might try the proprietary AMD driver.