OS gone bad

I was using openSuSe and when i restarted the computer instead of loading the graphical interface it loaded the kernal/Terminal only. Any help would be greatly appreciated in reverting it back to graphical interface

AMD Processor 9500
Radeon 4850
4 gigs of ram

You probably need to install the radeon (ati) drivers from the ati repo.
Login as normal and run the terminal version of yast. Add the ati repo and then update the ati drivers from the repo.
You should then be able to get a gui login again.

do you have a more detailed version of what you said because im new to linux

Does it load runlevel 3 or 5?
If it only boots into runlevel 3 (for reasons we don’t know yet), log in with your user name and password (don’t worry, the password will not be shown in the terminal interface, your keyboard works lol!)
Then type the following commands…

init 5 & exit

First command will give you root accses, type in your root password.
Second line loads the mode for graphical interfaces and if X11 is working correctly, your graphical system should start. And it too log you out of root accses.

If you want to shut down the PC using the command line interface get root and type halt, You can also get a YaST interface by typing yast as root if you want to install the ATI drivers from the ATI repository first befor switching to runlevel 5.

greeting Kump

If you look in the hardware section, there is a detailed thread on ati installation in case it foesn’t work from the repo.

These are extra software stores for software that is not included in the standard setup or for updates, etc.

Since opensuse could breech some commercial copyrights by supplying some somftware in its distro, they (and most other linux distros) get around it by adding repositories that are maintained by 3rd parties.

To add these, when you open yast, you will see a ‘Filter’ option. you can either type in part of the name (like firefox) to find firefox related files or you can change to one of the other options.
In your case you want to look at the ati repo, so change this to ‘repositories’ and choose the ati repo.
Now choose the x11-fgl… file.

garfinkel wrote:
> I was using openSuSe and when i restarted the computer instead of
> loading the graphical interface it loaded the kernal/Terminal only.

when you say “I was using openSuSe” can you tell us how long you had
used it? that is, had you completed the installation successfully and
used it a few hours (or more) and shut it down correctly…

then used it the next day (or so) with no problems and then, suddenly
the next time you started it you got the terminal?

OR you were installing, and the FIRST time the system booted you
went from a GUI environment to the terminal/black screen??

big difference in how to solve the problem, depending on when/how the
problem arose…


First of all, Thank you all for your help.

I tried what you mentioned above and nothing changed.

Also to answer conflicters question. I was using it and i had rebooted it many times. Then an update occured on my machine and when i rebooted again it didnt load the gui.


Seems to me that you took a kernel update, and now your graphic drivers need to be recompiled with the new kernel.

If you are new to Linux, I’m going to assume you don’t know very many CLI commands. So lets start off easy. Do you currently have a copy of the driver for your ATI 4850?, If you do you need to locate it, and execute it with the following command:

sh packagename.run

When installation finishes:

init 6

If you do not have a driver laying around for your card, try the following:


This will bring up the CLI version of yast, which you can navigate using your tab keys, and arrow keys, as well as ALT+the highlighted letter of any command you see on screen. Use Yast to goto the software section, and use the repository manager to add a new community repository. Select the ATI repository, confirm your changes.

Once you have done this, open up the SoftwareManager, and under filter, select repositories, under repositories, select the ATI repository. Once you have this selected, on the right hand side, you should see a driver for your card model. Install that driver, once finished, exit yast and init 6.

This should fix your problem, if you have any questions, feel free to ask.

sadly when i went the ati repository everything was already installed. Also in yast2 when i went to graphics option the screen came up really wierd colours which makes me believe that you were right and it was the graphics card.


Everything is supposed to be already installed, just uninstall it, than re-install it. This will force the module to recompile under the new kernel. Should fix your problem

I did what you said but it didn’t work.


Ok, Lets try it the “hard way”. Try this:

Login as normal and execute the following command

wget https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/ati-driver-installer-9-3-x86.x86_64.run

When it’s finished downloading execute the following:

sh ati-driver-installer-9-3-x86.x86_64.run

When the install finishes:

init 6

This will manually reinstall and rebuild the graphics kernel module.

so i did as you told me and when i restarted i was greeted with weird scanlines & boxes in purple and such and no terminal/kernel.


Sounds like X is starting now, which is a semi good thing, however the corruption sounds like it may be caused by a botched xorg.conf file.

To get back to your terminal use ctrl+alt+f1 after the computer shows the lines.

Execute the following command to configure your xorg.conf file:


This should hopefully fix your problem.

i did as you told me but it said that the command does not exist.

By the command not working could it mean that i dont have the xorg.conf file and is their a way to get it.