OS cannot boot. My Leap system somehow has tumbleweed installed

Who can help?

I have Leap 15.0. Last night during a software update, the internet connection was lost before completion and the update failed.

Since that time I noticed I had no internet connection and couldn’t even access Network Manager. At that point I rebooted the computer but was surprised that the selection on boot was titled Opensuse Tumbleweed (5.1 I think).

I’ve never installed tumbleweed and have no clue how my system has that media installed now.

Anyways, it fails to boot, probably because there is a mix of the 2 distros. I am able to get into the command line using a USB with Leap 15.0. But it’s beyond my skills to like how to proceed from here to fix this from there.

Any ideas?

This thread describes what happened and what you need to do (snapper rollback).

I can guess what happened (because it has happened to other folk). You probably installed some additional software with a “One click install”. And that added a Tumbleweed repo. Then a later update took your system to Tumbeweed (well, broken Tumbleweed).

What to do about it? Try booting to a command line. On the grub menu, hit ‘e’. Then scroll down to a line that begins “linux” (or “linuxefi”). Hit the END key to get to the end of that command line. Append " 3" to that line. Then continue booting (there should be a message on the screen on how to do that).

That should take you to a command line. Login as root.

Check whether you have a network. You can try to ping google.com.

If you have a network, then you should be able to fix the problem.

First use:

zypper lr -d

to list your repos. Then delete any repos that have “Tumbleweed” or “Factory” as part of the name or url.

To delete a repo, use

zypper removerepo #

where you can replace the “#” by the number of the repo in the list that you got with the previouse command.

Once your repos are cleaned up, then use

zypper dup

That should restore you to a working 15.0 system. Then reboot.

If you don’t have a network after that boot to command line, then we will need to follow a different approach, so report back what happens.

You nailed it. A couple days ago I did attempt a one click install. I cancelled it, but apparently the repos were added.

So I followed you first steps. Pressing e and going to the end of the line. I added a 3 to the end of that line, with no spaces. Just a 3. Is that what you mean by append? Or are there some characters in addition to the 3?

I am asking because when I press F10 to boot, it freezes up and I cannot get into the command line.

How to proceed from here?

Yes, just the 3 – no other characters.

Since that did not work, your next best option might be to use the DVD installer to reinstall on top of what you have. Or maybe use the 15.1 DVD installer, and update to 15.1 while you are about it.

Update: I’m pretty sure I don’t have an internet connection.

I used a bootable usb drive and went to the rescue mode. There is we able to get to the command line and log in as root. In the command line I pinged Google. I tried a couple code variants, but they all resulted in the same error message:

Temporary failure in name resolution.

Plan B?

Good idea. But if I install on top, will I lose everything I had? As far as all the configurations I did? Or will it preserve things more or less?

That was my first idea, but I was worried it would erase everything.

I should have been clearer. When you boot the installer, select “upgrade” rather than “install”. That should keep anything that does not cause dependency conflicts. But it should replace the Tumbleweed packages with packages from Leap.

So I’m thinking I can do the install, as long as I chose the right partition. Here are my existing partitions. Maybe someone can help me. I have a good idea, I’m not wanting to guess in this one:

sda1 1GB EFI system partition FAT
sda2 200GB Linux Native XFA
sda3 27.47GB Linux Native BtrFS
sda4 8GB Linux Native XFS
sda5 2GB Linux Swap Swap

I created the 200GB Partition separately so my data would get saved in this event. I’m thinking I want sda4 for the install.

Is that right?

When you choose Upgrade from the installation media rather than Installation, existing filesystems are reused, the installed software is upgraded if it still exists, system settings are undisturbed except as necessary, and /home is left untouched. IOW, preservation is good to excellent, depending much upon whether and which optional repos are enabled on 15.0.

Ok. That’s important, lol.

I’m in the upgrade now. sda3 has Opensuse Tumbleweed. Can I upgrade on top of that? Or choose a different partition?

Ok. Great. I’m ok board with that.

Can you help me choose the correct partition?

Opensuse Tumbleweed sda3 btrfs
Unknown Linux sda2 xfs
Unknown Linux sda4 xfs
Unknown sda1 EFI system partition

I presume the sda2 type is a typo that should be XFS.

When you choose Upgrade rather than Installation, the installer should figure out sda3 is the current 15.0 target and ask you to confirm before proceeding. If you choose Installation instead of Upgrade, you will be provided the option to repartition or reuse some other partition and leave sda3 intact. 27GB BTRFS is really too small for a normal installation except for experts or other who don’t mind extra administrative effort in keeping the / partition from exhausting freespace. Wherever your personal data is located now should be backed up and a new installation with repartitioning performed.

Probably best to get /etc/fstab for us to look at before proceeding. Overall that partitioning does not look like I would expect from an openSUSE installer.

Yes, that is a typo for sda2. It is xfs.

The upgrade is by far my preferred option. It takes me a couple days to configure everything from a fresh install.

The problem is, it doesn’t automatically recognize sda3 as the target, probably because of the tumbleweed repos. I even have to click “show all partitions” to see any of them. I’m pretty confident that sda3 is the correct choice, but not sure the upgrade will be successful, because of the different repos.

I tried getting /etc/fstab but it says permission denied despite being logged in a root.

Update:

I selected sda3 in the upgrade and when I click next it tells me that the system is different, and asks do I want to proceed. I clicked yes.

Then it gives me a list of existing repos, one of which is Factory, so there is the source of this problem. It recommends removing all and then installing the upgrade.

Can anyone confirm that action?

I’m tempted to just have it remove the one tumbleweed repo, because I’ve added some other ones multimedia that I don’t want removed. Will the upgrade process recognize if the existing repos are the same as the ones it wants to install and correctly handle that? Or is out best to remove and let it install the repos clean?

I’ve identified the exact repo that is causing problems. What do you think is the best way to fix it?

  1. Delete it via command line, which I can access through rescue mode with the USB.

  2. Upgrade the system using the USB drive? If so, please look at my previous post and tell me how to proceed at that step.

I think this problem is close to being resolved.

I suggest continuing with that upgrade. Let it clean out the repos. It won’t remove existing applications from those repos, unless they cause a conflict. And you can add repos back later. So this seems like a good way to proceed.

Yay! Problem solved.

That fixed it. Working just like it used to.

It gave me some warnings, that fortunately weren’t valid. Saying that the existing parition had tumbleweed and that the upgrade may not work. Plus it wanted a network connection, which I didn’t have. I ignored them, pushed forward it it was successful.

There was only one small problem. The system couldn’t connect to the server, despite the wifi connection being good. I found the solution here:

https://www.reddit.com/r/openSUSE/comments/8qaywo/opensuse_leap_15_connects_to_router_but_cannot/

These are the exact steps I took:

This happened to me when I upgraded to Leap 15 from openSUSE DVD. After the upgrade, DNS resolution did not work at all. I could ping Google DNS server 8.8.8.8 successfully, but I did not manage to open any website. Solution: my /etc/resolv.conf file was empty. I had to add a line “nameserver 8.8.8.8” to this file manually.
P.S. I use a static configuration and wicked service as default

I’m glad to hear that.

P.S. I use a static configuration and wicked service as default

You can use Yast Network Settings to configure DNS settings. That way your changes will be remembered across reboots.