OS 13.2 - Network config file backup.


I ran into problems when configuring dnsmasq on my linux server.
I was forced to use a laptop under MS windows, to access my NETGEAR router.
I was unable to connect to its address
What are all config files should I backup so I could restore a working network config.

Any help is welcome.

Depending on what you did,

  • If you once had a working configuration without dnsmasq and you now wish to not use it, maybe it would be simpler to simply uninstall dnsmasq and configure your Network Device in YAST appropriately (DHCP Client or with a static address) (Configuring in YAST should restart your network services automatically)?
  • If you are still trying to configure dnsmasq for some reason, you should probably describe your problem and maybe post your dnsmasq configuration.

If you are simply unable to “connect” to your openSUSE server using its address (did I understand that correctly?) then you still need to describe what you meant by “connect” (app used, protocol) and what you might have done to test network connectivity (did probe a port using something like telnet or did you simply ping or did you simply give up after trying something like a web browser?).

If you make changes on a computing system (not just Linux or openSUSE) ordinarily a backup does not automatically get made when you make changes.
If you want to have a fallback or “undo” you have to almost always have to create one yourself (well, now with BTFRS, ZFS and similar file systems this is beginning to change but recovery is not necessarily defined atomically to what you want restored).

There is no way to know what a proper network configuration is for your openSUSE server without details about how it’s supposed to be set up on your network, eg

  • dhcp or not?
  • network security or not?
  • single or multi-homed?
  • what kind of name resolution on network?
  • etc.


My question is very basic.
Dnsmasq is configured to act as dns server and as a dhcp on a subnet
My problem with dnsmasq configuration in not in the scope of this thread.

The Linux server should have fixed address :
The gateway have fixed address :
The netconfig program resolve nameserver address as


NETGEAR Router for test on subnet

Internet Port side

IP Address
DHCP Client
IP Subnet Mask
ISP Router Access

LAN Port Side

DHCP Server
IP Subnet Mask
DHCP Server address range
Starting IP Address
Ending IP Address

When trying to remove dnsmasq config I have set manually my linux box IP address to :

ifconfig eth0

I tried to restore /etc/resolv.conf by hand :


and with this command :

netconfig update -f

But does not help.
got error

network unreachable

As I dislike to use MS Windows to access again to my Netgear router,
when things go wrong, what files I must restore ( from a working set of files ) to access again my Netgear router. During my test on dnsmasq my Netgear router is in standby mode as dhcp server functionality is set to off.

The simplest way to accomplish what I think you want to do (restore working name resolution after removing dnsmasq) is simply regenerate /etc/resolv.conf with the settings you configure in YAST.

Are you running a Desktop?
Use YAST2 > Network Settings > Hostname/DNS tab
Verify your DNS is either set by DHCP or specified.

Remove your current resolv.conf as follows and restart your network services as follows

$ rm /etc/resolv.conf && systemctl restart network

If not running a Desktop, you can still perform the above but instead of verifying your DNS configuration using the GUI YAST, run ncurses YAST at the command line

$ yast

and then run the same command above to delete the resolv.conf file and restart networking.


Thank you very much.

Have a try very soon.