OS 13.11: Problem with Cups: VirtualBox Windows7 works with Printer but not OS 13.11


I wanted to let our gateway PC (2 network cards, Firewall, DNS, DHCP, SQUID) , named ‘OBELIX’ ,also handle the printing of our laser printer (Samsung CLP-310)
After the installation of the unified Samsung driver I could print immediately content from OBELIX onto the printer of OBELIX.
I allowed shared access to the printer over the internal network card and blocked the external one.
After rebooting all PC’s/systems in out network I could see the printer on the others PC’s Virtualbox Win7 installations and could connect and print the testpage.
I then tried the same in OpenSuse: The printer appears in “Printer Configurations” as ready and everything seems to be ok. BUT(!) whatever one tries to print will be automatically accepted and then wiped below the Linux Nirwana Carpet (LNC). :wink:

This is strange as I had the same configuration before on the normal PC ‘GANDALF’ and it worked, the only difference is that OBELIX uses a 32bit OS and is only used as a gateway and offers the above mentioned services.

I actually have no idea what’s going on there. On both OS 13.1.10 systems, the printing one and OBELIX, everything seems to work, the content is transmitted and no error message or what so ever raises to inform about a problem. The content simply gets never printed … and the Linux world looks rose red as before. :beat-up:
The Samsung driver also shows no entry in the queue.

Anybody has an idea ?

TIA, Joe

From the thread title:

OS 13.11

Fr om the post:

OS 13.1.10

Is it save to assume that you mean openSUSE 13.1 in both cases?

In both cases I meant OS 13.1. Version 13.1.10 . Sorry for the confusion.


Hi there,

after making intense use of the Yast2 GUI I was now finally able to crash the entire Cups system on this computer…

Fortunately the rest of the system is still working - don’t know how secure though - the system only says, that it can’t read the “/etc/cups/cupsd.conf” (the file exists and it’s not empty, so obviously that is just a generic error message for something serious enough thats not covered by its own error message, but too important to put it under the Nirwana Carpet) and then it tells me that there is no more locally running cups daemon. That was all !!!

With lots of frustration,


Oh yes, and reinstalling Cups does also not help …
Where does that Cups keep its data /history ? Wan to wipe it out.

Any other idea how to glue these broken cups :wink: ?

No, reisntalling OS 13.1 is NO option. Well, not yet, if more functions break, I my reconsider.

With frustration, yours Joe

Why the data/history?
I thought your config is broken?

Re-installing does not help of course, because your configuration is not replaced in that case. And that’s a good thing: you wouldn’t want to have to reconfigure all stuff after installing updates.

So remove /etc/cups/cupsd.conf and re-install cups to get the default configuration.
Or copy /etc/cups/cupsd.conf.default to /etc/cups/cupsd.conf .

Then cups should start again.

Or run “sudo systemctl status cups.service” to find out what’s wrong with your cupsd.config. If that doesn’t help, /var/log/cups/error_log should tell.