OS 13.1 / Virtualbox / Win7 Guest / Guestadditions: Resolution Problem

Hi there,

since the last update of GuestAdditions I have problems to display my Guest OS Win7 on both monitors, which worked before without any problems!

It always opens the guest OS with a resolution of 3421x965 (far too much for one monitor), but only makes use of one monitor (both monitors are 27" / Resolution 1920x1080) . If I try to manual expand the window to the second monitor, the window starts to flash (window-background-window and so forth…) and jumps in around 80% of all cases back to the old size. If I have luck and the window stays in the new position the Guest OS then reports a resolution around 3807x965. Unfortunately after each restart of the Guest OS the window opens again on one screen and I have to try again to expand it onto both monitors … sometimes a real pita.

I have defined in the virtualbox the monitor setup as 1 monitor - automatic resolution - no success. Defined 2 monitors - still the same problem.

Any ideas ?

TIA, Joe

Recommend re-installing Guest Additions again. Make sure the Guest Additions are consistent with the VBox version and sourced the same as what you’re running.
The exact procedure depends on whether you installed your VBox from openSUSE repositories or downloaded from the Oracle website.


Hi Tsu2,

thanks for your reply.

I got the VB automatically from the OS update and soon after the old GA suggested to update to the new GA and then I got the mess.
Loks like both the Virtual box and the Guest Additions should fit :

VB - VirtualBox: 4.3.18_OSEr96516
GA - Guest Additions: 4.3.18r96516

I uninstalled the GA in the Win7 guest and reinstalled it … still the same behaviour.

Found out that if I expand the windows in one move and keep the mouse position without releasing the button, it flashes 3 times (The sequence is expand to mouse position - shrink to old win size - expand - shrink - expand - shrink) and then windows shrinks back to the old win position. If I move the mouse again the guest window sequence restarts . One has to try to release the mouse button while the windows expands the 2.time. Then it will stay at the mouse pointers position. It’s a real pita. Especiall as it worked before.

Is it possible to write a bug report and if yes where / to whom ? Who is responsible for it ?

Thanks, Joe

For any issues (or requests) related to packages downloaded from the openSUSE repositories, you can submit at the following bugzilla. Use the same login credentials you use for these Technical Help Forums.


Be detailed, and include any logs or screenshots.


Hi there ,

have registered it as a bug on the 4.11.2014 : Bugzilla

As this will probably will take some time, I would like to know, whether it is possible to fall back to the last version of virtualbox and the last guest additions, as it is really annoying to work with this new “feature”.

TIA, Joe