OS 12.3 x86_64 yast qt gui not found

Wondering if anyone has the same issue in OS 12.3 x86_64, when I try opening yast2 I get the following error:

qt gui wanted, but not found, falling back to ncurses

I seem to remember this happening an earlier version but can’t remember where there was a ‘fix’ I used or if it just sorted itself out

zypper in yast*qt*

Thanks for the reply vazhavandan

I was pretty sure I had all the yast qt stuff in place but I tried your suggestion anyway:

zypper in yast*qt*
Loading repository data...
Reading installed packages...
'yast2-qt-branding-openSUSE' providing 'yast*qt*' is already installed.
No update candidate for 'yast2-qt-branding-openSUSE-12.3-6.7.5.noarch'. The highest available version is already installed.
'yast2-control-center-qt' providing 'yast*qt*' is already installed.
No update candidate for 'yast2-control-center-qt-2.22.2-4.1.2.x86_64'. The highest available version is already installed.
Resolving package dependencies...

Nothing to do.

I’ve looked on another 12.3 system where Yast works as normal and can’t see any dependencies for yast2-control-center-qt that aren’t met so I don’t really know where to look next

Check YaST==>/etc/sysconfig editor==>System/YaST2/GUI/WANTED_SHELL and System/YaST2/GUI/WANTED_GUI

Both were set to ‘auto’

Tried changing them to ‘qt’ which I didn’t expect to have much effect as it’s already asking for qt gui and I was correct, same behaviour

I don’t think there’s an issue with ‘asking’ for the correct gui but rather in ‘finding’ it, at least that’s what the error message seems to indicate

I did try uninstalling the yast qt packages, rebooting the machine then reinstalling them but this also didn’t make a difference

Is there a difference between starting Yast from the KDE menu and from a terminal window

su -

Did you by any chance login to the desktop as root?
Have you tried if the issue exists for a new user?


exist? If so, delete it, reboot.

Knurpht the same thing happens from kde’s menu and from a terminal

Deleting trolltech.conf made no different

Same behaviour with a new user

I don’t usually login to a DE as root but I tried it as you suggested, Yast didn’t open but I got an xmessage dialog opened with the following errorsmsgs:

Qt Gui wanted but not found, falling back to ncurses
missing d /usr/share/man/man3/Yast::SCRAgent.3pm.gz
missing d /usr/share/man/man3/ycp.3pm.gz
package yast2-ncurses is not installed
package yast2-qt is not installed
package yast2-gtk is not installed
Something is wrong with the Yast user interface, NCurses selected but no terminal available

The missing man files I don’t know about, but the packages it’s complaining aren’t installed, since 12.3 as far as I can tell they don’t exist. This is from checking on a working system as well as the problematic one

yast2-qt seems to have been replaced by yast2-control-center-qt (I might be wrong about that)

I have the same problem when trying to build a Studio edition. I fixed the problem : I was missing **libyui-qt4 **
Please check if you have libyui-qt4 installed ? They may forgot it in the dependencies

Yeah¡¡¡ just i search a few time¡¡¡ thank. well now is libyui-qt5 and this lib was installed, i add devel and some one more, and my yast2 qt gui return.
newly thanks¡¡¡.