oS 12.3 --> Tumbleweed migration destroys vanilla OpenBox-LXDE system

I’ve tried migrating my freshly installed, freshly updated LXDE/OpenBox openSUSE 12.3 system to Tumbleweed several times. But it fails.

Here’s what I did, as per the instructions here:

Portal:Tumbleweed - openSUSE

  1. Disable all 12.3 specific repos.
  2. Enable and refresh these 4-repos: Tumbleweed, openSUSE Current OSS, openSUSE Current non-OSS, openSUSE Current updates.
    [These are the only repos used]
  3. sudo zypper dup

Upon restarting the system boots up with updated kernel 3.8.8-3. The LXDM login manager appears and asks me to login. After logging in, I get a blank canvas/screen with the openSUSE background image, mouse cursor but nothing else. LXpanel doesn’t load, and nor do I get any keyboard accelerator functionality in the DE (like Alt+F2). Same problem if I restart the system and login with OpenBox (no Right-Click menu).

I’ve tried emptying the /home folder just in case LXDE has (auto)startup issues and I also tried to follow the same procedure on a freshly installed, vanilla system but the problem remains. Even OpenBox fails to load in similar manner described above with empty autostart file. The only recourse is to reinstall the entire system starting from fresh.

Now I have reinstalled my system with only the standard 12.3 repos.

So anyone have any experience of this?

If anyone knows, which LXDE/Openbox log file should I be reading to troubleshoot this problem?
I’ve looked in /var/log but there is nothing obvious there related to the DE.

On 04/26/2013 10:56 AM, bananaosx wrote:
> freshly installed, freshly updated

by “freshly installed” do you mean you did a full disk format and
install of 12.3?

or, do you mean you ‘upgraded’ from some previous openSUSE version to
12.3 (retaining existing partitions, applications, home, configs
etc)? and if that is the case which supported upgrade path did you

or, did you format all partition other than /home and then “freshly
install”? in that case does /home retain any configs from any Linux
distro other than openSUSE?

once one of those things above occurred, then did you have a trouble
free, well running 12.3 before you began the migration?

moving to Tumbleweed in an attempt to ‘fix’ problems is probably not
gonna work and the permutations of possibilities of “the problem”
which underlies and produces “the symptoms” you describe are nearly


This is what I did. The remnants in /home were some insignificant personal tid-bits unrelated to the distro/DE. The (fully updated) vanilla system worked/booted/logged-in absolutely perfectly before that.
Only after setting the Tw repos and doing zypper dup did the problem occur. Tried it three time, all same result.
I could have done zypper dup --From Tumbleweed but seeing as I had no other repos Enabled this action was moot.

So clearly the system broke going to Tw.

I noted there are alot of Gnome packages in the Tw repo. As I try to minimise the Gnome clutter on my system I run other DEs. Maybe this has to do with it. Is Tw tested only for use with the Gnome or KDE DE?

I don’t have experience with the problem.

I do have experience with latest Tumbleweed and LXDE desktop on a rather ancient PC and it just works. Only default settings and mostly same repos as you note except I also have the Packman Tumbleweed repos added.

Its always possible the latest kernel has a hiccup with your hardware.

What can you tell us about your graphic device ?

Standard Intel graphics. Nothing special.

I installed the latest kernel from Tw repo last week into the stock oS 12.3 and there were no problems. So I’m still guessing a software issue.

Aren’t the Packman repos just Packman Repos, Tw or not? I know of the Packman Repos but never heard of Tw Packman Repos.


Take a look here: https://en.opensuse.org/Additional_package_repositories#Packman

Please post the output of the command:

zypper lr -d

and place the content in between code tags … ie between
code ]
some text
/code ]
except there will be no ‘space’ between " " and " c " … nor between " e " and " ] "

OK I see, Tw Packman repo.
Anyway I’ve only ever used the Tw repo, and never used the Tw Packman repo.

As I mentioned my system is running on standard repos now and these are the repos that the system is using.

# sudo zypper lr -d

#  | Alias                        | Name                                | Enabled | Refresh | Priority | Type   | URI                                                                          | Service
 1 | download.opensuse.org-Stable | openSUSE BuildService - LibreOffice | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/LibreOffice:/Stable/openSUSE_12.3/ |        
 2 | download.opensuse.org-lxde   | openSUSE BuildService - LXDE        | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/X11:/lxde/openSUSE_12.3/           |        
 3 | ftp.gwdg.de-suse             | Packman Repository                  | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_12.3/                     |        
 4 | openSUSE-12.3-1.7            | openSUSE-12.3-1.7                   | No      | No      |   99     | yast2  | hd:///?device=/dev/disk/by-id/usb-PNY_USB_2.0_FD_AA00000000007329-0:0-part2  |        
 5 | opensuse-guide.org-repo      | libdvdcss repository                | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/12.3/                                         |        
 6 | repo-debug                   | openSUSE-12.3-Debug                 | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/12.3/repo/oss/               |        
 7 | repo-debug-update            | openSUSE-12.3-Update-Debug          | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/12.3/                              |        
 8 | repo-debug-update-non-oss    | openSUSE-12.3-Update-Debug-Non-Oss  | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/12.3-non-oss/                      |        
 9 | repo-non-oss                 | openSUSE-12.3-Non-Oss               | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/12.3/repo/non-oss/                 |        
10 | repo-oss                     | openSUSE-12.3-Oss                   | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/12.3/repo/oss/                     |        
11 | repo-source                  | openSUSE-12.3-Source                | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/12.3/repo/oss/              |        
12 | repo-update                  | openSUSE-12.3-Update                | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/12.3/                                    |        
13 | repo-update-non-oss          | openSUSE-12.3-Update-Non-Oss        | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/12.3-non-oss/                   

From what I understand, when you re-installed 12.3 you replaced both / and /home with a fresh format. Is that correct ? If you did not try a fresh format of the /home, you could go into YaST > Security and Users > User and Group Management … and Add a new user, make that new user the default login and see if they have the problem.

IMHO the above repository is a bad idea. Its too cutting edge. Its just asking for your LXDE to be broken, which I observe is what has happened. This is VERY FAR from the ‘standard repos’ which you claim to have setup. It could be the cause of your problem.

I’ve noticed the 1-click-install YMP script here:



does not include the following repo:

zypper ar --refresh Index of /update/openSUSE-non-oss-current ‘openSUSE Current non-OSS updates’

I’ve been using the YMP script thus far.

The wiki mentions to load 5 repos. But the above script only brings 4.

These are the repos to load:

sudo zypper ar --refresh http://download.opensuse.org/distribution/openSUSE-current/repo/oss/ 'openSUSE Current OSS' 
sudo zypper ar --refresh http://download.opensuse.org/distribution/openSUSE-current/repo/non-oss/ 'openSUSE Current non-OSS' 
sudo zypper ar --refresh http://download.opensuse.org/update/openSUSE-current/ 'openSUSE Current OSS updates' 
sudo zypper ar --refresh http://download.opensuse.org/update/openSUSE-non-oss-current/ 'openSUSE Current non-OSS updates' 


Correct. A worthwhile suggestion. Because when I forcibly logged into LXDE as root I was able to get in.

This LXDE repo was only added later to the standard 12.3. Earlier testing with Tw was done only with the repos from Tw and that’s what failed/broke.
I was experimenting with bleeding-edge LXDE updates due to separate and unrelated issues I was having with LXDE.

So now I have two leads to go on, thanks. I shall report back.

I did a complete reinstall of the system and migrated to the 5-Tw repos (listed in my previous post). That 1-click-install script in the Wiki is erroneous as it only loads 4-Tw repos.
This I believe was the root cause of a broken system I was having.

I consider the issue resolved for now, certainly until such time there’s a similar instance of a freshly installed, broken system from another user (or me for that matter!)