oS 12.1 / KDE3 runs well and fast on an old Pentium III , KDE4 runs too, but a few issues remain

Hi all,

just installed oS 12.1 on my old Pentium III PC
(512 MHz, 0.5 GB RAM, intel motherboard, onboard graphics).
I ran the online update during installation,
and checked the installation media.

In general the resulting system works pretty well,
and under KDE3 and IceWM desktops it even feels quit responsive !

However:

Issue 1:
when the monitor turns dark after some idle time, the session is locked,
and I can’t change this.
Since I use this PC only in my flat and not in a public place, I don’t want to have this.
I thought that the settings for the screen saver would be the right place to change
this behaviour, but just this app (screen saver settings or more precisely the
desktop settings app as a whole) crashes notoriously under as well
KDE4, KDE3, and IceWM desktop.
Is there a different way to change this session lock behaviour ?

I really would like to change this, and any hint on this would greatly be appreciated :slight_smile:

Issue 2:
“sysinfo:/” doesn’t work under KDE3.
Workaround:
As I anyway installed KDE4 during installation from DVD,
I open a Dolphin window, enter “sysinfo:/” in the editable location,
and this then seems to launch the KDE4 version of Konqueror,
which knows very well about “sysinfo:/”, while the KDE3 version of
Konqueror apparently doesn’t any longer.

Installation history:

Installed oS 12.1 with KDE4 from DVD and NonOss CD,
the online update during installation has been done.

KDE4 did hang after the KDE icon appeared (at the end of the KDE4 startup).

Therefore I rebooted using IceWM desktop.

I ran YaST from IceWM to install KDE3
(not the one-click-install offered in http: //en.opensuse.org/KDE3
in order to save space, but otherwise following the instructions there).

I was working a bit with this,
e.g. removing the “splash=silent quiet” arguments from my /boot/grub/menu.lst (Grub1),
in order to get the startup messages back.

Finally I gave KDE4 another try,
and it started up without hanging, despite I didn’t do anything about that.
It works well, albeit with some lag here and there.

Best wishes to all here
Mike

On 2012-07-15 23:06, ratzi wrote:

> Issue 2:
> “sysinfo:/” doesn’t work under KDE3.
> Workaround:
> As I anyway installed KDE4 during installation from DVD,
> I open a Dolphin window, enter “sysinfo:/” in the editable location,
> and this then seems to launch the KDE4 version of Konqueror,
> which knows very well about “sysinfo:/”, while the KDE3 version of
> Konqueror apparently doesn’t any longer.

There is an specific kde3 mail list where you can ask those problems.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Hi Carlos!

I searched the KDE3 mailing list with respect to sysinfo.
But anyway, I have a workaround for this that works
(see 1st post).

Otherwise:
Don’t you have an idea about how to change the session lock behaviour
other than using the usual setup for the screen saver under KDE4, KDE3, IceWM
(which every time crashes in my case) ?
That would save me from having to enter the pwd 20 times or more a day … :slight_smile:

Yours
Mike