OS 12.1 & Inspiron E1505

Success! I wiped the Vista 32 off of this thing - I have to say Opensuse 12.1 is really sharp on this laptop and it is amazing, that the mediadirect button works! That is amazing!


Glad to read of a success with your Dell Inspiron E1505.

I installed openSUSE-12.1 on my wife’s Lenovo X220 laptop yesterday. In her case I left on win7 and I placed openSUSE in an extended partition (as the 1st three partitions were already in use by Windows7 and the Lenovo recovery partition). I backed up the MBR before installing (keeping a copy of original MBR on a USB stick) and when installing I deselected the option for openSUSE to replace the Windows7 code (in the MBR) with a generic MBR, but I did allow openSUSE to change the active partition from partition#1 (where win7 boot code is located) to partition#4 (the extended partition) such that Grub would be loaded.

Install took 90 minutes total, which includes the time to configure the sound (no configuration needed), network and scanning printing to HP C309a photosmart premium printer, and webcam. Skype ‘just worked’ using webcam and internal mic. The ease of the internal mic to work surprised me pleasantly, as I had read posts of users with problems getting that mic to work and I was expecting trouble, of which it turns out there was none. The 90 minutes also included the time to install MANY packman packager packaged apps. I do note, that we have a VERY high speed Internet bandwidth which makes such download/installations quick.

Also the Intel Sandybridge graphic hardware seems to be running well with the KDE4 desktop and 12.1, although I have not tried to play any HD videos yet. I’ve read of a few users complain about Intel Sandybridge graphics and I’m happy not to have encountered their problems.

So I do believe 12.1 works will on this Lenovo X220.

What type of BIOS/Hard Drive is installed in the X220? As you know already, I had troubles with the Lenovo V470, with its Toshiba GPT type drive.
Of course in my case, the UEFI BIOS may also play a role; here is a link to an interesting blog on GPT disks and its inherent issues with operating systems: GPT fdisk Tutorial .

Its funny how life works - I had originally planned on keeping the Dell Inspiron as the “Windows laptop” and using the Lenovo as the “Linux laptop,”
but look how it turned out - the Dell became the “Linux laptop,” and the Lenovo will most likely remain, at least for the next 2 years or so, the “Windows laptop.” It took the better part of 2 days to restore the factory issued Win. 7 and applications - not sure I want to risk doing that one again anytime soon,
when VMware 8.01 works very well on it.

With VT technologies enabled on the Lenovo, the VM capability is huge and honestly the VMware version of OS 12.1 reminds me of the old Memorex commercials, it is that good.

I don’t nomally have access to my wife’s Lenovo X220 laptop, … but according to the Internet it has a UEFI BIOS.

Note I not only backed up the MBR on her Lenovo BEFORE installing 12.1 but during install I also deselected any writing to the MBR. I also left win7 on her laptop. I had also read of other users being successful with openSUSE installs on this hardware before I installed. I guess one could say I was ultra conservative in my approach in addition to being fortunate.

VMware 8.01 for Linux installed flawlessly on this Dell and I now have the Vista 32 running in a 150 gig VM. Also MS reports the license as officially activated. So I guess that I am ok.

There were different hard drives available. My wife chose the 250GB HITACHI HTS54322. We made certain it was compatible with GNU/Linux before ordering best we could: Hitachi HTS54322 Benchmarks, Reviews, Open-Source Tests, Linux Information - OpenBenchmarking.org

Not so surprising really, as the marriage between Win7 and my lenovo (2 years old now) is very good with extra fast boot and every function key and hardware feature properly supported, so I kept Win7 installed. That is still not the case wrt function key support on linux/openSUSE 12.1 after that much time, since it relies on a limited resource for developing thinkpad_acpi module. However openSUSE provides smoother scrolling and touchpad support (OOTB), and overall I have preferred the KDE desktop experience.

Just to correct the thread, while the Lenovo X220’s BIOS is UEFI, it has a ‘Legacy Boot Mode’ option, and it turns out the BIOS was by default ( ? ) or at least as delivered ] set to Legacy Boot Mode as an automatic detection and that is likely why it worked for me. The UEFI boot was not being applied. My apologies for the confusion … I just learned about this myself yesterday when examining my wife’s Lenovo’s BIOS settings.