OS 11.3 RC2 - disable nouvou module permanently; use propietary NVidia drivers


I have compiled the proprietary nvidia drivers for 11.3. When I boot, even using the nomodeset boot option, the nouveau module still loads, causing gdm/X to fail. I am able to manually remove the modules with rmmod and restart gdm. Everything then works normally. I have added the line “blacklist nouveau” to both 50-blacklist.conf and 99-local.conf in /etc/modprobe.d.

Is this a bug or am I missing something?

So, I would wonder if indeed the nVidia driver really loaded. It can go through the motions, but abort at the last minute when it finds the nouveau present. Have you read through the fine article on the subject located at:

SDB:Configuring graphics cards - openSUSE

It does not hurt to try and reinstall the nVidia driver if it is already loaded. Don’t forget that you are modifying your /boot/grub/menu.lst file to add the command “nomodeset” without the quotes to your normal openSUSE kernel loading selection. Further, when you do the nVidia Proprietary driver installation, you need to be in run-level 3. Run-level 3 does not allow the nVidia driver to load if you do not have nomodeset specified when your kernel file is loaded.

Finally, you must have the kernel sources file loaded as well as the normal developmental stuff required to compile it. I might do a reinstall of the nVidia driver, paying very close attention to what the driver install program is saying. I have not found it necessary to blacklist the nouveau driver as long as nomodeset was specified on the kernel load line (every time you run openSUSE) and you were in run-level 3 to load the nVidia driver.

Thank You,


Thanks for the reply!

The nvidia proprietary driver is definitely loaded and working properly. The nouveau kernel module insists on loading at boot time, even though I have it blacklisted and have uninstalled the X11 nouveau driver package. “nomodeset” is in my boot options.

I am able to use the proprietary nvidia driver only because I manually unload nouveau with rmmod after the initial failure of gdm. I am convinced this is a bug; nouveau insists on joining the party uninvited :).


IMHO it may be a bug in the view of users like you and me, but the developers have a different view. This is clearly posted in the release notes for 11.3 . I tried to make that clear in the guide I wrote: SDB:Configuring graphics cards - openSUSE

I recommend if you can’t be bothered to read the guide that at least you read the release notes. You need to navigate to yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD and change it to “yes”.


YES! I just tried changing NO_KMS_IN_INITRD to ‘yes’ and rebuilding the initrd … and everything is as it was before KMS. I vaguely remembered reading something about it … probably in the release notes … and I fought with KMS a little on a different system with a newer intel graphics chip.

THANKS for the help!


P.S. I’m glad I didn’t submit a bug report … :wink:

I had no problems … downloaded latest driver from nvidia. modified grub to nomodeset… downloaded kernal source, gcc and make… then ran the install for the nvidia driver… and all was well with the world. no problems at all.

This setting was already set to “yes” for me, any other suggestions?

Edit: Uninstalling nouveau renders my consoles (ctrl+alt f1 etc) unusable with graphics that are scrambled.

Note as opposed to using ctrl+alt f1 etc, one can boot direct to run level 3 by pressing “3” during the grub menu boot, such that ‘3’ (no quotes) appears in the options line, and one boots direct to run level 3.

In addition to using ‘nomodeset’, one may also be required to navigate to yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD and change it to “yes”. I have a nVidia card where it was necessary to do both.