OS 11.3 M5 and nVidia

I have updated from Milestone 4 (which worked perfectly) to M5 but I haven’t managed to start in runlevel 5 since the update.
The nVidia driver was installed without a problem and it shows up in xorg.conf but it’s not detecting the screen on the laptop.
The system falls back to runlevel 3 on boot with messages that the screen can’t be found and that runlevel 5 failed to start.
Sax2 isn’t working properly either. I can’t make any changes using Sax2.

Anyone here having similar problems?

There is a big thread here on this , where the thread covers both M4 and M5:
Nvidia Driver and newest 11.3 MS4 updates - openSUSE Forums

I documented my M5 installation installation experience here: openSUSE Forums - View Single Post - Milestone 5 ISOs available for download … there are follow-on posts to that post in same thread.

Milestone 5 appears to be a total disaster particularly if you use 64 bit. I was trying it out as a dual boot with 11.2 but gave up on this latest update. I’ll try again on M6.
It’s such a shame too. I found it really stable up until M5 and could install nvidia driver easily.

Did you not try the 64-bit liveCD ? It should install. Try a text mode install (which should avoid that bug where the “configuration” part of the install fails). When the text mode install is complete you should have a 64-bit install in place.

This M5 was after a kernel update from 2.6.33 to 2.6.34 and in the past the 1st milestone after such an update has been historically rough, and this is no exception.

There is a lot of discussion about 64 bit and M5 on the openSUSEfactory mailing list and M5 should be considered a 32 bit only milestone. for 64 biters waiting for M6 is a wise decision.

As long as one does not want to install, I note the 64-bit openSUSE-11.3 M5 liveCD works well.

I ran the M5 liveCD on two 64-bit PCs and it worked well:

  • 64-bit Intel Core i7 920 w/6GB (Asus P6T Deluxe V2 motherboard) w/ PCI-e nVidia GeForce GTX260 graphics [age-1 year] - booted with nouveau driver on 11.3 M5. Sound worked.
    *]64-bit Dell Studio 1537, Intel P8400 w/4GB, w/ATI Radeon 3450HD graphics [age-1.5 years] - booted with opensource radeon driver on 11.3 m5. Special desktop effects worked well with the radeon driver. Sound worked. Intel Pro 5300AGN wireless worked better then it ever did under 11.1 or 11.2 (due to a patch in 11.3 M5’s 2.6.34 kernel)

Thanks for reminding me of that threas. I will try blacklisting nouveau and then tell you the result.

Blacklisting nouveau didn’t bring any changes. Runlevel 5 still can’t start.

I am actually using a 32 bit version but it seems to have the same problems.

I added this section to xorg.conf:

Section “ServerFlags”
Option “IgnoreABI” “True”

as suggested in the other thread and it’s now working.
I can start testing M5 now :slight_smile: