oS 11.3 freezes randomly on atom/intel 945

Bug case reopened: https://bugzilla.novell.com/show_bug.cgi?id=617530

See also this thread: KDE freezes completely (at random)

Finnally, after some days, I can say that the deano_ferrari’s fix (#4 in this thread) worked fine: I haven’t had crashes anymore. Also the alpha1beta advice (#18) was very useful.
With these two ideas, the problem was solved for me.

Well, finally I found 2 repos:
Index of /repositories/home:/Herbster0815/openSUSE_11.3 - kernel
Index of /repositories/home:/Warhammer40k:/x_org/openSUSE_11.3 - xorg and intel drivers
After updating kernel, X11 and drivers my HP530 (i945GM) pleases me with its unprecedented stability with OpenGL enabled :slight_smile: Many thanks to the creators of these repositories!

Hi maelstrom, hello everyone!

As I experienced very bad performance for my programmes using FLTK/Canvases compared to the the programme running under Win XP on the same computer, I decided to downgrade to 2.6.34 as suggested by maelstrom. AND I URGENTLY DISCOURAGE EVERYONE TO DO SO, at least until that problem has been finally solved!

My system settings: Asus Eee PC 1001HA, Intel Atom N270, Intel GMA 945.

I rebooted the system, choose the entry in GRUB with the older kernel. After the normal bootprocess the screen went black. I rebooted hard with the On/Off-Switch of the computer. Till now, I managed to figure out the following problems:

  • no output on notebook built-in monitor: output can only be seen on an external monitor. When restarting the system within GRUB with Ctrl-Alt-Del the built-in monitor’s backlight flashes shortly and then turns off again. Sometimes one can see the underline promt “_” for a second or so.
  • No recognition of input-devices: The system with the older kernel boots with its usual bootsplash. The resolution changes after a while and just the upper left corner of the screen is drawn - but this might be normal. The logon-screen then looks okay, but keystrokes as well as any mouse movements are not recognized, eventhough I could use the keyboard in GRUB’s menu. The only thing I can do is to shutdown the computer with the On/Off-Switch.
  • Old system/new kernel doesn’t know ext4 filesystem: Using the old installation with the newer kernel (2.6.35 as shipped with openSUSE 11.3) the bootprocess stops after a few seconds with the error “mount: ext4 unknown filesystem”. Having read the output I got errors that important modules cannot be found. I have only access on my boot partition but not any others I created during the first installation (eg /home).
  • Windows has no login: Starting Windows XP, which was preinstalled on my computer, I get the normal bootsplash on the external monitor but the logon-screen is just black.
  • Booting NET-Installation from USB-Stick: This seems to work so far, but I haven’t tried to get further than the oldschool text-menu as I haven’t got the drivers for the wlan-card and cannot remove my old monitor directly to the LAN-connection. But the keyboard works fine.

Any help is very welcome! I am very puzzled why also windows just draws on the external monitor. Do you think a complete reinstallation will help (I’ll try that tomorrow)?

Many thank in advance!

PS I am using Suse now for years and I never experienced such massive problems before. I always felt very confident with this distro as I had trouble with RedHat and Debian. It’ so annoying having all that fuss now…

Hello altogether,

just a short note. In almost five hours, I reinstalled the system today. Luckily I use a different partition for /home so that I hadn’t had to backup all my files. It’s now all working again apart from a few libraries that I still have to install from time to timer.

“Upgrading” the system with the NET-Installer didn’t work for me; the problems kept the same. Running the “Rescue” didn’t work either. After having done a complete new installation I though I could have installed the filesystem-drivers myself during an upgrade. But that’s not important anymore.

Windows is now also fine. I don’t have any problems with the monitor anymore. When KDE first started, the monitors switched back to their original behaviour.

I have now the intellegacy-drivers running again as suggested on the first page of this thread. So if someone has the same problems with the same hardware, you might be better of with using the old drivers.

Have a good night!

Hello SimonHeimbach

I think it’s a bit risky to try some special repos unless you are an expert. I have been using opensuse for quite a long time, but I’m not an expert. If you are, you don’t need my advice (sorry if that’s the case).

I found very useful this post by caf4926

I solved some problems after following that advice.

@ freezes

The bug was closed even with people complaining of continuing problems, and that’s not cool.

I could probably guess why. . .

A special disaster zone should be setup on bugzilla and the forums to handle the scope of these particular bugs. Maybe organize the bugs by

Hello Simon,
My recommendations relates to the stock 2.6.34 kernel, so you had to think thrice before downgrading kernel. And in my post #23 in this topic has a link to the repository provides 2.6.35 kernel, and the second link to the repository provides xorg, which works fine with this kernel. Be careful, please, I do not recommend downgrade kernel, but post resulted in a combination of drivers and kernel versions, where there was the most stable.
Eventually, it became clear that the error is not in the kernel, not drivers, but xorg, so nevermind it ))))

had a very similar problem.
I use HP 6730b and my KDE 4.4.4 crashed 3-4 times a day, then I updated to KDE 4.5.1, and then it crashed 1-2 times a day, regardless of what I am doing.
Since yesterday I’m using Gnome, and I’ve had zero problems, it work faster, it is stable, and I’m pretty satisfied.
I hope KDE will get it’s errors sorted out.

I’m having trouble with locks ups on a Thinkpad with oS11.3, KDE4.4.4 and Intel 945GM card. I’m seeing this problem with all kernel versions 2.6.34-x that have been released so far via the standard openSUSE repositories. On an identical system running oS11.2 there are no lockup problems at all.

I’ll try the solution given in comment #45 in the bug report and hopefully it will fix the problem. Does anyone know if this will filter down into the regular updates for oS11.3?

OK, I’ve applied the solution by polycarp in comment #13. The intel driver version that was being loaded previously was 2.12 so now I have 2.10 running on kernel 2.6.34-12-desktop and will see how it goes. Although I note there still seem to be users experiencing problems. I’m becoming a little unpopular with the user of this laptop for installing openSUSE 11.3 so hopefully this will fix a major issue for her otherwise I’ll have to install 11.2 which is working perfectly on another identical machine.

Well that was short lived. The system hung again. I’ve disabled desktop effects in the meantime to see if that helps. But it seems that the bug still exists. Can someone say if the kernel version have an effect on this bug? It’s quite confusing and difficult to decipher which solutions work from all the comments in the bug report.

Personally I’ve given up on that issue since a long time. I use Standard 11.3 with standard updates. I just disabled desktop effects and voilà, I can live without them. All other attempts have failed at a moment or another and, from my point of view, I prefer to have a usable system without candies than an unusable system.

After lots of searching, reading & frustration the ‘fix’ so far for my Intel 965 GM is to add


to ~.bashrc and reboot. A more detailed explanation is here

kde - What does LIBGL_ALWAYS_INDIRECT=1 actually do? - Unix and Linux - Stack Exchange

Its more of a workaround than a fix until the bug is resolved but no freezing since.