oS 11.3 freezes randomly on atom/intel 945

Hello altogether,

I just upgraded my system from oS 11.2 to oS 11.3 on Thursday. I’ve chosen the network-CD and booted from an USB-pen-drive, as my netbook doesn’t have a CD-drive.

I new experience that my computer freezes obviously randomly. It’s not just a programme crashing, but the whole computer just halts. Nothings working anymore - mouse is not moving, keyboard doesn’t respond, I can’t even switch to another tty.

I tried to remember what I was doing right before the crashes. Once I used the new netbook-desktop of KDE and had typed for an application in that “cool” new desktop. The desktop wend “blank” (the application folders disappeared and I was waiting till the results were shown) and then the computer froze. Just right now I used Okular, selected some text and opened the context-menu when the computer died, the other time I closed the Yakuake with F12 and the computer didn’t respond just right before the window was minimized at the top and last but not least I had that “Expose”-like window arrangement opened and clicked at the black background when everything hang up.

What could be the reason for it? oS 11.2 worked perfectly - I hadn’t had any crash during 5 months of intense use. I suspected the new graphics driver, but I can’t find any reported bug about the Intel 945 GMA* or anything about the new KDE 4.4.4 on atom processors.

I have added the output of “/usr/sbin/hwinfo --gfxcard” at the end of this post. Are there any other information you need? Can I actually help somehow?

Many thanks in advance!

08: PCI 02.0: 0300 VGA compatible controller (VGA)              
  [Created at pci.318]
  Unique ID: _Znp.h2UmIxANX76
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel 945 GME"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x27ae "945 GME"
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x8340 
  Revision: 0x03
  Driver: "i915"
  Driver Modules: "drm"
  Memory Range: 0xf7e00000-0xf7e7ffff (rw,non-prefetchable)
  I/O Ports: 0xdc00-0xdc07 (rw)
  Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
  Memory Range: 0xf7dc0000-0xf7dfffff (rw,non-prefetchable)
  IRQ: 16 (37396 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00008086d000027AEsv00001043sd00008340bc03sc00i00"
  Driver Info #0:
    XFree86 v4 Server Module: intel
  Driver Info #1:
    XFree86 v4 Server Module: intel
    3D Support: yes
    Extensions: dri
  Config Status: cfg=new, avail=yes, need=no, active=unknown

09: PCI 02.1: 0380 Display controller
  [Created at pci.318]
  Unique ID: ruGf.ZmLftePh3I8
  SysFS ID: /devices/pci0000:00/0000:00:02.1
  SysFS BusID: 0000:00:02.1
  Hardware Class: graphics card
  Model: "Intel Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x27a6 "Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller"
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x8340 
  Revision: 0x03
  Memory Range: 0xf7e80000-0xf7efffff (rw,non-prefetchable)
  Module Alias: "pci:v00008086d000027A6sv00001043sd00008340bc03sc80i00"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Primary display adapter: #8

This irritating issue has been reported in other threads, and is a currently assigned task
see https://bugzilla.novell.com/show_bug.cgi?id=615649

I have a Dell with the same card as you, and a few days ago, I implemented one solution proposed by Alex. I had only one freeze since that date.

I have the same problem om my two netbooks (Atom N270, N280). I hope this ugly bug will by fixed soon. I posted it to bugzilla. I m forced to use openSUSE 11.2 to this day…i can’t work on a system which has a crash everyday…


Did you try upgrading Xorg packages and configuring as suggested in the bug report? It might be worth a shot.

Well, there is the solution for kernel 2.6.34:

  1. Add X11 repo
    (Index of /repositories/X11:/XOrg/openSUSE_11.3) and update
    Mesa, libdrm and xorg-x11-driver-video-intel-legacy
  2. Edit /etc/X11/xorg.conf.d/50-device.conf:
    Section “Device”
    Identifier “Default Device”
    Driver “intellegacy”
  3. Reboot and enjoy legacy driver stability :slight_smile:

In fact, this solution allows to significantly reduce the number of freezes.
Yesterday, I got a new one. So far the bug reported in Bugzilla is not fixed.

The only solution is to stay with 11.2 and wait for update or a new version. I never had so serious system stability problems like with 11.3. Its like using 'milestone 3". I hope it will be better in future…

Yeah. Unfortunately every computer I own has an Intel 945, so this one is killing me.

No freezes yet with fix from bug page comment #45… self-compiled and installed intellinux driver v2.10. fingers crossed

Can any one confirm which comment #… works BEST with effects and no freeze for some time. I mean people who applied this some time ago.

I had problem with and without effects.

Just joining this thread. Same issue with my ASUS-PRO59L. It had been quite stable under 11.2. I haven’t tried any of the mentioned solutions yet, just gald to know I’m not alone.

Can anyone comment as to if/when an official fix will be made?

hwinfo --gfx
08: PCI 02.0: 0300 VGA compatible controller (VGA)
Model: “Intel 965 GM”
Vendor: pci 0x8086 “Intel Corporation”
Device: pci 0x2a02 “965 GM”

09: PCI 02.1: 0380 Display controller
Model: “Intel Mobile GM965/GL960 Integrated Graphics Controller”
Vendor: pci 0x8086 “Intel Corporation”
Device: pci 0x2a03 “Mobile GM965/GL960 Integrated Graphics Controller”

I got one crash after trying deano_ferrari’s fix. But I had not rebooted after applying it, so I suspect that’s why. Using that fix for 2 days now, and it seems to be working, sluggish at times, but not crashing. ASUS EEE PC 1000HE Atom 280


Solution #45 has completely solved the problem for me on my Intel 945G card. No problems at all since implementation. Just follow the straightforward directions given by that bug comment to compile the intellinux 2.10 driver. (He includes a step having to do with intellegacy that is intended for those who had followed an earlier fix that didn’t work, which can be ignored if you are just now working on it.)

The bug has been assigned last I checked. Bookmark the bug report and watch for a solution to move to the repos (so you can roll back the manual fix in the comment above - if necessary).

I saw that people were trying to patch the kernel, but as written earlier, at the moment can work correctly only 2.10.0 driver on kernels 2.6.34 and newer. It seems that just have to wait until the KMS will patched. Use 2.10.0 release or intel_legacy…

In the past 2 days this bug has been resolved and re-opened, but at least you know there is work being done to resolve the issue ASAP and the patch has been promised to hit updates also ASAP. Should be soon! fingers crossed

I also applied the deano_ferrari’s fix (#4 in this thread). Things seem to go better, but I had several crashes after trying to modify some system settings in kde 4.5: Window decorations, Multiple desktops, Effects, etc.

After some attempts, now I’m sure that the moment I click on the Apply button the computer will freeze; I can move the mouse around but to click has no effect, and also the keyboard is not working. My only solution is to switch off with the buttom and boot again.

Probably this doesn’t help anybody, because they already experienced the same, but just in case…

Obviously I won’t touch those settings anymore until the bug is fixed. In this way things seem to go fine. Let’s hope that they fix it soon.

I hope they will push the fix soon.
Work around for the reboot is to disable the desktop effects and then enable it using these keys, Shift+Alt+F12. A temp solution without restarting the system.

The system settings is a completely different bug, which, i believe is fixed in 4.5 now. There is a bug report in on novell’s tracker.

Thanks a lot!
I’ll try next time. Let’s hope there will be no next time…

Glad to know. But I wonder when was “now”. I updated kde 2 days ago… Was the fix done later?
Thanks anyway.