OS 11.3 freezes frequently

Since upgrading from opensuse 11.2 to 11.3 my system is no longer stable. It freezes frequently. I’ve tried reinstalling from scratch (instead of upgrading), installing all patches, … without success. It drives me nuts !!

I had an Intel Core i5 660 with integrated graphics and a separate Ati Radeon card. I’ve removed the Ati Radeon card because I’ve read that there were some issues with it. But even now, my system freezes frequently.

Any suggestions?

BTW I don’t know why I’ve combined the integrated graphics with the Ati Radeon card. I guess the sales person did a good job :wink:

Hey, try disabling all desktop effects as a workaround for the freezes.

I did the above for the built in nvidia driver with 11.3 and the freezes are fixed for the time being.

Update SUSE it will update automatically the kernel!!

Try the following:
yast=>/etc/sysconfig=>System=>Limits…
if “HARDLOCKLIMIT” set to “@256
changed to “@512”…OK finished.

cheers Otto

Updated the kernel, changed HARDLOCKLIMIT to 512 and disabled desktop effects.

The system still freezes 3 to 5 times a day. Very frustrating !!

Can you run memtest for at least 1 hour but if you notice the screen turning red with errors stop the test.

How should I run memtest? From a terminal? Which options?

Is it really “dangerous” if the screen turns red? If not, I can start memtest and come back in an hour or so.

Ivan

Run memtest by booting with the opensuse DVD or CD. The grub menu will have an option called memtest.

Its not dangerous, memtest simply writes data to the memory locations and compares the result, ie is the data written to memory the same as what was written.

I’ve ran memtest for 70 minutes, but it didn’t report any errors.

Any other ideas to solve this problem of frequently freezing (today I had to reboot 7 times).

Ivan

Freezing often indicates a hardware problem.

Can you list your system specification, this allow us to spot any known issues with your hardware or identify weaknesses.

Can you confirm if 11.2 still works fine without freezing?

Does it freeze and unfreeze? Or do you have to reboot?

  • Intel DH55TC
  • Kingston KVR1333D3N9/2G x2
  • Seagate ST3320418AS 320 GB
  • intel socket 1156 CPU CORE i5 660 3, 33GHz 4MB cache FSB1156 32nm

Because I’ve done a fresh installation of opensuse 11.3, I cannot test if opensuse 11.2 is still working. If my memory is still reliable, I thought I also had some problems the weeks before switching to opensuse 11.2 (but not during the first months). once a week the system freezed in opensuse 11.2 and I heard an alarm beep on the internal speaker! tuuuut tuuuut tuuuut tuuut …

In the current setup, the system freezes 5 to 7 times per day, but I don’t have any error beeps.

More than likely your looking at some sort of hardware failure.
Have you checked the temperature in your computer? Overheating can cause lockups.

That might not be the solution to all problems.

That could be any kind of hardware failure:- CPU to hot, faulty RAM, I/O error (HD, bus, cable). Here are a few things you can try - but you’ll also need some luck at some point:

  • After the system freezes, reboot immediately, call the BIOS setup and check the CPU and mainboard temperature. Also make sure that the CPU fan is running.
  • Remove one module of RAM and use your computer one or two days.
  • If it doesn’t make a difference, put this module back and remove the other one. Use your computer one or two days with the other module
  • disable the HD in the BIOS (or unplug it) and boot from a Linux live CD - no matter which distro - try to use your computer one or two days with this live system.
  • I take it you’re not an overclocker, aren’t you?
  • open your case and clean the dust with a gas duster (not your fingers)
  • Does the computer take some extra time when you turn it on? - check/replace power supply
  • Do you have another graphic card, try it!
  • If none of those tests could provide an information, I would start to look for another mainboard.
  • the solution might also not be listed above (happens frequently :frowning: )

One more thing to try:
If this machine can be accessed from another machine via ssh, try that when the freeze happens. It might allow you to do that if peripherals are frozen but the system is still active. Then, you can check the logs. (I have come across such situations before).

tx - I’ll try your solutions the coming days and report back.

In which logs should I take a look?

I would look in

/var/log/messages

and dmesg but there are probably other log files as well

I see you have a lot of suggestions to follow up :slight_smile:

Here are a few more.

Go into your system bios.

Bios > Performance > Memory override

Command rate = set this to 2T
Memory voltage = set to 1.55

Datasheet for your memory = 1.5v +/- 0.075v
http://www.valueram.com/datasheets/KVR1333D3N9_2G.pdf

What power supply are you using?

Unstable voltages can also cause freezing and other weird issues.

No, try that before the freeze happens !:wink: