Optimus machine with nvidia 470.63.01-43.1 fails to boot after updating kernel Kernel to 5.14.2-1

I updated tumbleweed yesterday (zypper red && zypper dip) and now it fails to boot.

Nvidia 470.63.01-43.1 is in use and was not updated. Kernel, however, was updated from 5.14.1-1-default to Kernel 5.14.2-1-default, and the nvidia module therefore recompiled.

I asked for help on Reddit first and added photos of my screen there:

First photo shows where boot hangs on the current system state.

It hangs after “xhci_hcd: can’t change power state from D3cold to D0 (config space inaccessible)“

Second photo shows the snapshots list after booting into Snapshot 1611, which is pre yesterday evening‘s update.

What shall I do? Is this a config issue or an Nvidia compatibility issue or Kernel bug?


  • Kernel 5.14.1-1-default

Not booting:

  • Kernel 5.14.2-1-default

The system is a Tongfang GK5CP0Z / XMG Neo 15 Early 2019 with NVIDIA RTX 2060. I am using it with an external HDMI monitor. HDMI is only available in nvidia mode, so I use prime-select to choose nvidia over intel.

If you think it’s an nvidia issue, you might try the troubleshooting steps at:


I was only able to get nvidia 470.63 working with my laptop by adding the kernel parameter acpi=off. However, your problem sounds different, as your system booted with 470.63 and the 5.14.1 kernel.

Hi Tuner

Thank you for your reply!

I have created a bug report in the mean time: https://bugzilla.opensuse.org/show_bug.cgi?id=1190608

Reducing kernel params to a bare minimum (as proposed at https://www.reddit.com/r/openSUSE/comments/ppyfcd/optimus_laptop_hangs_on_boot_after_yesterdays/hd7d3sq/?context=3) unfortunately made no difference at all.

I agree that it sounds different from the issue you describe. Also, notably the previous kernel, 5.14.1, boots just fine on the same system with the same drivers and all. Only 5.14.2 freezes on boot, reproducibly always with the same messages.

Can you duplicate the issue with the nouveau driver? A tainted kernel will likely only glean info from the packager… Have you asked on the Nvidia forum?

Hi malcomlewis!

Thank you for your hint - good point!

I tried booting 5.14.2-1-default with these two kernel params appended: module_blacklist=nvidia modprobe.blacklist=nvidia – but the problem remained.

Did I do this correctly, or would I need to also blacklist nvidia_drm, nvidia_uvm, nvidia_modeset and i2c_nvidia_gpu?

I have now used minimal kernel params and appended module_blacklist for all nvidia modules: Imgur: The magic of the Internet The result was the same as before. It does not seem to be related to nvidia at all. :-/

Great, then update the bug report and stick with that setup and hopefully you will gain some traction. I would also check dmesg or journalctl -b output to make sure tainted is not there. Upload that info, and probably dmidecode… There is a whole list of info.



I was advised to try a later kernel (5.14.5) from the Kernel:stable OBS repo (https://bugzilla.opensuse.org/show_bug.cgi?id=1190608#c8), and that worked!

After re-compiling the nvidia kernel module (nvidia-gfxG05-kmp-default), I was also able to boot using nvidia and run smoothly on 5.14.5 with external monitor and dGPU.

Apparently, 5.14.2 has a specific issue that does not occur with 5.14.5.

Hi ! I am facing the same issue than you (ie no display on laptop screen with NVIDIA driver) since 5.14.2 (it was working perfectly before).
I also switched to 5.14.5, but my laptop screen (dGPU) is still blank : did you change something in your x11 settings also ?

Help appreciated, thanks :slight_smile: !

Hi @inpixal

Actually, my issue was that the kernel failed to boot.

The part of the display and nvidia driver was just a side issue:
My specific laptop model only outputs HDMI through the NVIDIA graphics card, but not through the SoC intel graphics unit that would save a lot of energy using.
I did initially suspect the issue having to do with the nvidia driver; and installing an inofficial kernel meant that, at first, it only ran with the intel driver, so I couldn’t use my external screen. This, however, was not the central issue, just a symptom of the intermediate state between not having a booting kernel, and having a fully working system (back to nvidia & HDMI).
So, in my case, after compiling the nvidia kernel module for 5.14.5 completed the fully working system, and the issue was purely on the kernel’s internals, or its interfaces with bbswitch, ACPI or similar (who knows…). My issue might therefore be entirely unrelated to yours.

I believe you will have better luck opening an entirely new thread, and probably not on the “Install/Boot/Login” subforum.

Also, next to the opensuse forum, check out the nvidia forum’s linux section.

I wish you good luck in resolving the issue!