Optimus Hybrid Graphics with Intel Video Driver and Bumblebee Not Fully Functional

I have a HP Zbook 17 G2 that has hybrid graphics. Since OpenSUSE 13.2, I have disabled hybrid graphics and was successfully running the nVidia proprietary drivers exclusively. However, with Leap 42.1, there is a bug that causes Plasma 5’s Konsole not to play nicely with nVidia and I run into this bug several times each week. See:


So, in order to avoid this bug, I decided to get rid of the nVidia drivers, switch back to hybrid graphics in my BIOS, and run Bumblebee instead. However, I am unable to get 3D compositing to be fully functional with this setup. Here is what I did:

  1. Removed all nVidia packages
  2. Enabled hybrid graphics, installed the Intel video driver, xf86-video-intel, executed “mkinitrd” and then rebooted.
  3. Installed Bumblebee using: https://en.opensuse.org/SDB:NVIDIA_Bumblebee and then rebooted again.

I have done this three times and have been unable set the rendering backend to OpenGL 2.0 or 3.1. The compositor will only allow the rendering backend to be XRender which does not support most 3D functions such as the cube and wobbly windows.

Does anybody have any recommendations on how to fix this? When I first got this laptop, I got OpenGL 2.0 working great with Bumblebee on OpenSUSE 13.2 but I can’t get it to work with Leap 42.1. My grub2 startup Linux command line has “nomodeset”. Do I need to remove the nomodeset option for the Intel driver to be fully functional or am I doing something else wrong?

All three times that I have attempted the bumblebee installation, I eventually have disabled hibred graphics and reverted back to the stock nVidia proprietary drivers. However, this is time consuming and I want some fresh ideas to try before I attempt the change again. So, any recommended ideas are appreciated.



You are running from the intel. We don’t know what driver. Did you install the nvidia-bumblebee program?

You may want to look at this thread


I found a lot of discussion without any definite steps.
Can you please help me find where that way is written in the above mentioned thread?

Ask there my simple understanding is that the magic is done via a script. that should be linked to in that thread

I have MSI GP70 2PE Leopard. The method from here https://forums.opensuse.org/showthread.php/505270-ultimate-tutorial-installing-Bumblebee-driver-for-SUSE
was successful for me in the case of openSUSE 13.2 and also Leap 42.1.

This problem is now solved.

Thanks galko_ferdinan for your post! I was working from a very similar guide from here:


Two additional steps, not covered in the above guide, were required in order to get everything working. The main thing that I had to do for the intel graphics driver to work was to remove “nomodeset” from grub’s linux line. It was apparently put there by the nVidia installer when I installed the nVidia driver for running nVidia exclusively (with optimus hybrid video disabled). However, “nomodeset” was not removed from grub when I removed the nVidia driver with zypper. So, I had to remove it myself with yast’s boot loader kernel parameter settings.

The other thing that I had to do in order for Bumblebee to work was to edit /etc/modprobe.d/50-bbswitch.conf to include: “options bbswitch load_state=1 unload_state=1” followed by “mkinitird”.

Everything now appears to be running properly.

Thanks again.


Pretty sure the NVIDA drive does not use nomodeset setting in the kernel line. Not sure how it would get there since that stops the auto selection of drivers and reverts to the primitive fallback drivers. nomodeset is generally used at the boot screen to deal with video driver problems and should not be set in the permanent grub settings. NVIDIA will black list nouveau but that happens elsewhere and not in grub and should be reversed if the NVIDIA drive is properly removed.

That is very strange. I didn’t put nomodeset there and I can’t imagine where it would have otherwise come from. I installed Leap 42.1 from scratch so it could not have been a carry over from my 13.2 install either.