optical-media write speed with UDF extremely slow (< 10kb/s)

Hello Everybody!

i have recently realized that Linux supports packet writing and started experimenting with it.

i format the DVD or bD with


/ # mkudffs --media-type=XXX /dev/sr0

where XXX is any of hd, dvdram, mo or cdrw.
when using --media-type=dvd the media becomes read-only.

In either case as well as when i don’t specify --media-type the writing speed is not even reaching 10kb/s.
When burning a disc with a burning program the speed is about what the media is advertised for (e.g. 4x for a DVD+RW 4x).
When using the very same media formatted with mkudffs under m$ with packet writing the normal (i.e. advertised) writing speed is achieved as well.

When inserting the media, the following messages show in system log


  kernel: UDF-fs: INFO Mounting volume 'LinuxUDF', timestamp 2016/01/19 00:17 (103c)
  org.gtk.Private.UDisks2VolumeMonitor[3883]: disc.c:350: error opening file BDMV/index.bdmv
  org.gtk.Private.UDisks2VolumeMonitor[3883]: disc.c:350: error opening file BDMV/BACKUP/index.bdmv

but the disc is mounted automatically.
The last two lines are also displayed when a non UDF disc is inserted (and mounted automatically)

When umounting the media the following message appears


kernel: cdrom: sr0: dirty DVD+RW media, "finalizing"

What might the cause of the poor performance for packet writing under Linux be?

With CD-RW i used


cdrwtool -d /dev/sr0 -q

(which includes a mkudffs command)
the writing speed is much faster but the media is already full after a few MBs far off the 576MBs cdrwtools promises.

device: [MATSHITA][BD-MLT UJ267AM ][1.00]

reproduced the same behavior with a

[PLEXTOR ][DVDR PX-L890UE][1.01]

Finally got around to recover my CentOS 7 from the claws of !@#$%& m$ installer (thanks to dd and grub rescue ¦-)
burn speed for DVD+RW formatted with udf varies between 3.88 and 7.77 MB/s (theoretical max is 4x ~5.5 MB/s…)

Obviously my OpenSUSE installation / configuration is somehow corrupted. :frowning:

End good, everything good?

not really…

Assuming that my configuration was somehow messed up i took the resolution to make a fresh install of openSUSE 13.2.
Turned out that the 13.2 DVD (transfered to USB with SuSE Studio) did not yield a bootable install so i finally dropped back to a 12.3 install which i upgraded through YaST to 13.2… So far. so good, as packet writing indeed achieves the expected performance.
HOWEVER so many things that “simply” worked on my old install stopped working (most annoyingly auto mounting of optical & USB media). After quite some fidgeting to try and solve the issues i decided, unhappily to restore my old install.
Thanks to partimage (which doesn’t install on 13.2 anymore even though i still use it from an install done in 11 or 12 without problem) i was back up & running within ½ an hour :slight_smile:
With the intend to close this thread (obviously, not much interest) i put an UDF formatted DVD+RW in my drive and to verify things still didn’t work… BIG surprise, packet writing works like a charm! Which it actually did a couple weeks ago when i started playing around with UDF.

Go figure :-/

i’ll stick with openSUSE for now even though CentOS 7, booting reliably from a 2nd HD is the longer the more tempting…

:expressionless:

After restoring my original 13.2 install i was quite unhappy that automount of USB & optical media didn’t work anymore - tried to fiddle with rules in /etc/udev/rules.d/ without success and finally settles with adding a row in /etc/fstab


/dev/sr0             /mnt/sr0           iso9660,udf     nofail,defaults             0 0

which worked.
yesterday evening after restarting the laptop and inserting a USB card reader i was quite surprised to notice that automount was working again (i.e. media mounted under /media/<name> ) :slight_smile:

took a minute to edit out the line in /etc/fstab, inserting an optical disc in the reader and tadaaaa, mounted :smiley:
of course decided to check an UDF disc and… writing speed back to <10 Kb/s ;(

would thus seem that the automount conflicts with the writing speed of UDF on optical media…

solved it by editing the line in /etc/fstab and leaving it only for udf, after which UDF volumes mount on /mnt/sr0 and have normal writing speed (several MB/s)

automount also impedes the writing speed onto USB media even not formatted with UDF.though to a lesser extend (~500 Kb/s versus 10 Mb/s if mounted manually)