Opinions about this guide please

Hello all,

Whiles at work and bored I was surfing the web and found this guide on speeding up Opensuse 11.1. I would just like the opinions of some people with more linux experience than little ol’ me on if this is a good idea to do. Untill now I have happily used OpenSUSE 11.1 on my pc but my laptop is a bit sluggish. I was thinkin of using this guide to speed it up.

So, opinions please :slight_smile:

Hi

  1. if your using hibernate to disk then you will need to leave swap on.
    I prefer to leave it on in case you get a runaway task, then you have a
    chance to recover before things go haywire…
  2. Already done… :wink:
  3. My preference is for three VT’s
  4. Kernel tuning is really dependent on what the system is being used
    for, a whole world of it’s own :slight_smile:
  5. Need to read up on this
  6. Already done
  7. Don’t use KDE :wink:

2, 3 and 6 are normal for me. You should read up on 4 and 5 with
respect to your setup and implement as required.

Did you know about kernel messages using ctrl+alt+F10 and to get
back to your X server it’s ctrl+alt+F7


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 11:04, 1 user, load average: 0.10, 0.07, 0.07
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

Have another thought, if you have <2GB of RAM and running 32bit I would
also look at using the default kernel rather than the pae one to remove
those optimizations. Also remember is you change kernels and have
nvidia/ati vbox etc running you will need to reconfigure those jsut
like if the kernel was updated.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 11:39, 1 user, load average: 0.04, 0.08, 0.18
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

Some comments.

  1. After switching swap off the swap partition is of course still there as is the entry in /etc/fstab. After reboot IMHO swap will be on again.

  2. Switching off what you do not need is also good for security. Specialy services hat LISTEN in the network should be off when not needed. While I do not think that openSUSE has switched on many things when you did not ask for it, a check is not a bad idea.

netstat -utlp

gives who is listening.

  1. Either comment out by the # or change the “respawn” to “off”. Becomes active after a reboot or after
telinit q
  1. and 5) I back malcolmlewis, system tuning and performance is a science on its own.

  2. Already at the installation I uncheck Beagle (and AppArmor) so it never touches my systems.

  3. Being still on 10.3 I have no comment.

Switching off swap has the draw back that you’ll have more page faults, less cacheing, because by default openSUSE doesn’t write to swap unless it is under severe memory pressure.

If you’re in violent disagreement fine, but ask yourself if you really want you memory occupied by the data of programs that are just sitting there idle?

VM tuning

rob@fir:~> cat /proc/sys/vm/swappiness
60

root can do something like :

( echo 100 > /proc/sys/vm/swappiness ; sleep 120 ; echo 60 > /proc/sys/vm/swappiness ) &

What that does, is make the VM far keener to write memory pages written to by idle processes, into the swap space and free up some memory. Then it resets the default dislike of system to recover idle pages.

You may not save very many MiB of RAM that way, but those idle daemons are now, not using system resources. That means fewer page faults and more memory for cacheing.

cron jobs that go and read lots of disk OTOH, may have less impact on interactive user by lowering that value, so program pages are evicted rarely, and then you should find the desktop more responsive after programs have been idle. It’s a bit like using nice, to disturb the other uses of the system less.

If you do heavy work and then find an interactive program laggy despite system being currently idle, it should not take long to become responsive and whatever else you did, was faster in meantime.

Most of the page faults, will actually be for program data, pages that had to be evicted. Partitioning the disk, so system programs, swap space and /home are close together and not over sized may help the situation by reducing seek times, and utilising disk buffers better.

LOL, cool speedup. The whole KDE loads longer than the booting. :slight_smile:

I’m writing these tips and I guarantee that all of tips has been tested successfully :slight_smile: . Anyway, as mentioned on these tips, you must adjust the setting with your condition.

IMHO, openSUSE on standard install prepared for general purpose. It means that the developer try to keep the setting for general usage. I think it would be a better idea to make the setting ideal for us and fit with our requirement.

Hi
Very similar to this archive article;
How
To Speed Up Opensuse Boot Time And Manage Memory Better

As a Gnome user I also removed all the preload references to kde
in /etc/preload.d


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 23:16, 2 users, load average: 0.06, 0.07, 0.08
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

Which shows that it is all very related and relative to the usage you make of the system.

The time it takes to boot is not important when you boot once a month or less. As long as the program(s) you are working in do it faster then you can move the mouse for the next action, what is the need for speeding things up? So first identify any bottlenecks you might experience and then try to find a remedy (which might not be easy).

On the other hand, we all have from time to time some hobbyhorses working with computers. And when system tuning is such a hobbyhorse I will not discourage anybody to work on the fascinating world of system performance.

This is a laptop so I’m powering on/off very often, this is why the speed up important for me.

I use the hibernation, suspend system to disk, which has advantage that I can pick up where I left off.

I also have these functions enabled, but I have a problem with my network card. When the laptop comes back from hybernation/suspend the network card doesn’t have IP address and it can’t get new. I’m tried manually


rcnetwork restart

and the other dhcpd commands but nothing worked.
I remeber, under Windows Vista there was an option for reseting the network card, after that everything was fine. I don’t know how to do that in openSUSE.

Hi
You might try rmmod/modprobe on the module your card is using;


rcnetwork stop
rmmod <module_name>
sleep 3
modprobe <module_name>
sleep 3
rcnetowrk restart


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 8:18, 3 users, load average: 0.07, 0.07, 0.05
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

That’s odd. Do you have a bugzilla number for that?

I connect via DHCP to Internet, and it’s unaffected by Hibernate, in OS 10.3 and 11.1. It really should work for you, and time getting that sorted, may be collaborating with kernel hackers will pay off far more than, turning off idle daemons that add 0.25s to boot time.

BTW There’s a 20s boot project, being launched for 11.2.
So we can expect the default distro, to improve boot speed yet again, like 10.3 did.