OPI tries to connenect to a dubious adress

I have recently installed Tumbleweed with a clean install with an fresh /home. But i tried to use OPI to search a package that arent in the default repos and i get network errors from attempting to connect with too many attempts. I dont understand python error too well but it seems to connect to a dubious adress:

requests.exceptions.ConnectionError: HTTPSConnectionPool(host='***guoyunhe.me***', port=443): Max retries exceeded with url: /opi/proxy/index.php?obs_api
%252Fproject%253D%2527openSUSE%253AFactory%2527%26limit%3D0&obs_instance=openSUSE (Caused by NewConnectionError('<urllib3.connection.HTTPSConnectio
n object at 0x7f4010e2edf0>: Failed to establish a new connection: [Errno 101] Network is unreachable'))

I dont know why it tries to connect to that domain. For me it returns an unreachable adress error in the browser. I reinstalled opi several times with the # zypper rm -u opi command and its the same. I even tried with an other user account: Its the same error.

Also im new to the forums. If i didnt provide enough info or posted in the wrong subsections please dont get mad at me. Thanks in advance!

A quick google search shows me that the domain name is a web developer who is an active opensuse community member
this is his github page : https://github.com/guoyunhe

The OPI repo shown up on his github page .

I did a whois lookup for guoyunhe.me and i got this

Thanks for clearing this out! But still i cant figure out how to make opi work. Maybe is an error from this guy backend? Not sure.

Also i think i need to change the title but i dont know how to or if its even possible.

They are currently working on building a server based in their own infrastructure. ==> Link to Reddit.